Boot AmigaOs from USB stick

AmigaOne X5000 platform specific issues.
Post Reply
User avatar
tommysammy
Posts: 946
Joined: Mon Dec 20, 2010 9:03 pm
Location: Isselburg,Germany
Contact:

Boot AmigaOs from USB stick

Post by tommysammy »

I want to copy my SYS: partition 1:1 to an USB stick and boot from this USB stick.
Is it possible?
Which commands should i use in U-BOOT?
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network
User avatar
tommysammy
Posts: 946
Joined: Mon Dec 20, 2010 9:03 pm
Location: Isselburg,Germany
Contact:

Re: Boot AmigaOs from USB stick

Post by tommysammy »

I can answer myself
I copied my SYS partition to a SFS formated USB stick (Enhancer with SFS1.93 is installed)
I made a reset, pushed ESC to get U-Boot menu, then i selected Booting over USB.My X5000 boots from USB stick into Os.4.1
Very easy to handle :D
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network
Juzz
Posts: 8
Joined: Mon Oct 23, 2017 7:54 pm

Re: Boot AmigaOs from USB stick

Post by Juzz »

tommysammy wrote:I can answer myself
I copied my SYS partition to a SFS formated USB stick (Enhancer with SFS1.93 is installed)
I made a reset, pushed ESC to get U-Boot menu, then i selected Booting over USB.My X5000 boots from USB stick into Os.4.1
Very easy to handle :D
I've tried that, but after some reading of the USB drive - I get the "Insert disk" animation in the kickstart.
Do we need to put a slb onto the drive? Or can the usb stick I tried just not support booting? Now that I think about it - I'll give it a go with another stick.
smf
Beta Tester
Beta Tester
Posts: 112
Joined: Thu Nov 17, 2011 11:16 pm

Re: Boot AmigaOs from USB stick

Post by smf »

Juzz wrote: I've tried that, but after some reading of the USB drive - I get the "Insert disk" animation in the kickstart.
Do we need to put a slb onto the drive? Or can the usb stick I tried just not support booting? Now that I think about it - I'll give it a go with another stick.
SLB is not used by the X5000 so you can forgett about that :)
Did you install the drive with media toolbox and make your partition bootable?

AFAIK the bootloader in uboot will load the kickstart from any partition it can find with a kickstart drawer but when aos kicks in you'll need a bootable partition.
Post Reply