SDK:C/make very slow with OS4.1FE (SOLVED)

Have a question about our Software Developer Kit? Ask them here.
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: SDK:C/make very slow with OS4.1FE

Post by ssolie »

xenic wrote:Testing with the above makefile seems to indicate that the problem with make involves executing commands and not the gcc compiler commands themselves. The time difference is obviously a lot more than a few microseconds per command.
Note that GNU make does have to do a lot of work to properly set up things for each command that is executed. This means using a lot of the features of IDOS->CreateNewProc() that may not be used as much by other programs. Given we've had no luck with any other DOS commands, I'd focus on CreateNewProc() if you have some time to mess with things.
ExecSG Team Lead

User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 591
Joined: Sat Jun 18, 2011 2:40 am
Location: Portsmouth, UK
Contact:

Re: SDK:C/make very slow with OS4.1FE

Post by broadblues »

(using the timer command from os4depot - e.g. timer make).
Don't bother with such tools that add another level of confusion just type after you run make:

Code: Select all


make -f makefile 
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
ram:test.xyz  Deleted
10.RAM Disk:> set
Process          10
RC               0
Result2          0
_LastCommand     make
_LastCommandArgs -f makefile
_mchar           ||
_pchar           |
_RunTime         10.626666
_ShellVersion    53.15

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1447
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: SDK:C/make very slow with OS4.1FE

Post by nbache »

broadblues wrote:
(using the timer command from os4depot - e.g. timer make).
Don't bother with such tools that add another level of confusion just type after you run make:
Or simply use e.g. this in your Shell-startup:

Code: Select all

prompt "*E[33m%N.%S %R %W [%E] *`C:Date` *n$ *E[31m"
Best regards,

Niels

User avatar
colinw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 181
Joined: Mon Aug 15, 2011 9:20 am
Location: Brisbane, QLD. Australia.

Re: SDK:C/make very slow with OS4.1FE

Post by colinw »

ssolie wrote: Note that GNU make does have to do a lot of work to properly set up things for each command that is executed.
This means using a lot of the features of IDOS->CreateNewProc() that may not be used as much by other programs.
Given we've had no luck with any other DOS commands, I'd focus on CreateNewProc() if you have some time
to mess with things.

You were spot on, it's FIXED, the bug was in CreateNewProc().
There's barely 1 seconds in a minute difference now. (with and without the FFS: path)

zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: SDK:C/make very slow with OS4.1FE

Post by zzd10h »

@ColinW

Great that you find the problem !

Could this bug be related to general slowdown problem that some users encounters with FE (no problem under 4.1.6) ?

http://forum.hyperion-entertainment.biz ... =40#p31675

Thank you
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE

xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: SDK:C/make very slow with OS4.1FE

Post by xenic »

ssolie wrote: The GPL source code is included with every SDK so no need to bother me. :-)
I found the source in old SDKs but can't find it in recent SDKs. Where is it located in the current public SDK?
AmigaOne X1000 with 2GB memory - OS4.1 FE

xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: SDK:C/make very slow with OS4.1FE

Post by xenic »

colinw wrote: You were spot on, it's FIXED, the bug was in CreateNewProc().
There's barely 1 seconds in a minute difference now. (with and without the FFS: path)
Thanks Colin. Every bug-fix helps make OS4 better.
AmigaOne X1000 with 2GB memory - OS4.1 FE

User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: SDK:C/make very slow with OS4.1FE

Post by ssolie »

colinw wrote:
ssolie wrote: Note that GNU make does have to do a lot of work to properly set up things for each command that is executed.
This means using a lot of the features of IDOS->CreateNewProc() that may not be used as much by other programs.
Given we've had no luck with any other DOS commands, I'd focus on CreateNewProc() if you have some time
to mess with things.
You were spot on, it's FIXED, the bug was in CreateNewProc().
There's barely 1 seconds in a minute difference now. (with and without the FFS: path)
Just saw the commit and that was a sneaky one!

@all
We are working on an update package for 4.1 Final Edition so I expect this fix will be in there. In the mean time, you have a workaround although not a great one.
ExecSG Team Lead

zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: SDK:C/make very slow with OS4.1FE (SOLVED)

Post by zzd10h »

@SSolie
"@all
We are working on an update package for 4.1 Final Edition so I expect this fix will be in there. In the mean time, you have a workaround although not a great one."

Is this fix or this planned update will adress the following problem (see below) ?
Thx

"@ColinW
Great that you find the problem !
Could this bug be related to general slowdown problem that some users encounters with FE (no problem under 4.1.6) ?
viewtopic.php?f=14&t=2812&start=40#p31675
Thank you"
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE

User avatar
colinw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 181
Joined: Mon Aug 15, 2011 9:20 am
Location: Brisbane, QLD. Australia.

Re: SDK:C/make very slow with OS4.1FE

Post by colinw »

zzd10h wrote:@ColinW
Great that you find the problem !
Could this bug be related to general slowdown problem that some users encounters with FE (no problem under 4.1.6) ?
http://forum.hyperion-entertainment.biz ... =40#p31675
Thank you
Unlikely, the problem didn't apper to involve anything described, this issue was primarily a task priority loading and
competing issue when a special set of requirements were met, "make" just happened to create that special situation.
This quirk has been in there for years but no-one noticed before because they always had at least one dospacket based
filesystem partition in their shell path.

As Steven said, there will be updates available soon for these sort of post F.E issues.

Post Reply