new cart

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

new cart

Post by musa »

Hi Christian
Do you know if linux support this graphics card Sapphire AMD Radeon HD3450 (RV620 LE) 256MB DDR2 VGA S/VID-Out DVI PCI-e .
My 6870 has started to fail when it has been running for a while (black screen until the machine has cooled down)
If the answer is no, do you have a suggestion for a graphics card that has 3d support
Thank you in advance for your help
Peter (musa)
AmigaX1000
Follow me on twitter @basjoo_dk
daz
Beta Tester
Beta Tester
Posts: 328
Joined: Tue Dec 21, 2010 7:32 pm

Re: new cart

Post by daz »

musa wrote: Wed Jan 06, 2021 7:42 pm Hi Christian
Do you know if linux support this graphics card Sapphire AMD Radeon HD3450 (RV620 LE) 256MB DDR2 VGA S/VID-Out DVI PCI-e .
My 6870 has started to fail when it has been running for a while (black screen until the machine has cooled down)
If the answer is no, do you have a suggestion for a graphics card that has 3d support
Thank you in advance for your help
Peter (musa)
That card is fully supported for 2D and 3D under linux. RadeonHD supports it for 2D on AmigaOS too (IIRC).
It should be enabled in all current kernels too, drop us a line if you have problems.

The fault on your 6870 sounds like it is overheating, I'd check the thermal compound between the GPU/ram and fan/heatsink, this has been know to dry out over time. causing loss of cooling.

Regards
Darren
User avatar
xeno74
Posts: 6885
Joined: Fri Mar 23, 2012 7:58 am

Re: new cart

Post by xeno74 »

musa wrote: Wed Jan 06, 2021 7:42 pm Hi Christian
Do you know if linux support this graphics card Sapphire AMD Radeon HD3450 (RV620 LE) 256MB DDR2 VGA S/VID-Out DVI PCI-e .
My 6870 has started to fail when it has been running for a while (black screen until the machine has cooled down)
If the answer is no, do you have a suggestion for a graphics card that has 3d support
Thank you in advance for your help
Peter (musa)
Hi Musa,

Fortunately Darren has already answered your question.

Could you please test the RC2 of kernel 5.11 with your Radeon HD3450?

@Darren: Thanks for your answer.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

Re: new cart

Post by musa »

Thanks for the reply Christian and allso from Darren . Darren I think you're right about my 6870 problem. I will investigate it further later.
My new card is on its way and will be in use later this month. You hear from me there.
I also ordered an ASUS RADEON R7 250 OC 2GB DDR3 PCI-E GRAPHICS CARD for use with OS4.1 FE.
Thanks and happy new year to all
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

Re: new cart

Post by musa »

none of these cards worked.
Hd 3450 caused the machine to freeze. no startup.
RADEON R7 250 the machine start in basic vga mode.
ranger can see the card
but the card could not be selected in screen mode.
Trying to boot linux but black screen.
Trying now to change the cooling paste on my 6870 and see .
Musa
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
xeno74
Posts: 6885
Joined: Fri Mar 23, 2012 7:58 am

Re: new cart

Post by xeno74 »

musa wrote: Fri Jan 15, 2021 6:19 pm none of these cards worked.
Hd 3450 caused the machine to freeze. no startup.
RADEON R7 250 the machine start in basic vga mode.
ranger can see the card
but the card could not be selected in screen mode.
Trying to boot linux but black screen.
Trying now to change the cooling paste on my 6870 and see .
Musa
Which Linux distribution do you use?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

Re: new cart

Post by musa »

I use

Ubuntu 16.04
ubuntu 17 Remix
debian 10 64
Mint (debian 10)
Fedora
Suse

I think that was all.

i will try to repair my 6870 cart and then i think i will stop dreaming about 3d in amigaos. It's so hard to find a usable card.
There are different versions of the same card.
I have no problems with Linux and 6870.
Have a nice day.
We have snow here and its cold. :)
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

Re: new cart

Post by musa »

Hi
I'm still working on getting my 6870 card to work again but am missing a pack of cooling paste. In the meantime I have got a Radeon r7 240 to run workbench and try if it should be possible to boot some of my linux installations. Lightdm will not start so I expect to configure an xorg.conf for the right pci device and driver. For my 6870 I used radeon in the driver field but what should it say on a radeon r7 240?
Thank you in advance for your help
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
xeno74
Posts: 6885
Joined: Fri Mar 23, 2012 7:58 am

Re: new cart

Post by xeno74 »

musa wrote: Thu Jan 21, 2021 10:12 pm Hi
I'm still working on getting my 6870 card to work again but am missing a pack of cooling paste. In the meantime I have got a Radeon r7 240 to run workbench and try if it should be possible to boot some of my linux installations. Lightdm will not start so I expect to configure an xorg.conf for the right pci device and driver. For my 6870 I used radeon in the driver field but what should it say on a radeon r7 240?
Thank you in advance for your help
Please use fbdev because there are no radeon drivers that support the SI cards on the PPC platform.

Code: Select all

Section "Monitor"
Identifier "Monitor0"
EndSection

Section "Device"
Identifier "Device0"
Driver "fbdev"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
musa
Posts: 482
Joined: Tue Aug 23, 2011 7:58 pm

Re: new cart

Post by musa »

Hi Christian.
Thanks for your reply. I have managed to repair my 6870 graphics card and it seems to be running stable now. With Radeon 6870 in pci-e slot 1, my xorg.conf looks like this and gives 3d.

Code: Select all

 
 Section "Monitor"
Identifier "Monitor0"
EndSection

Section "Device"
Identifier "Device0"
Driver "radeon"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth	24
Modes "1920x1080_75.00"
EndSubSection
EndSection 
If I instead put with R7240 in pci-e slot 1 and the radio 6870 in pci-e slot 2, what should my xorg.conf look like? Lspci gives BusID "PCI: 3: 0: 0" is there anything else to change other than busid? Both cards can be seen in Amigaos. Currently I only use 6870 and it runs fine but does not provide 3d in Amigaos.
Thank you in advance for your help
Peter
Last edited by musa on Sun Jan 24, 2021 12:53 pm, edited 2 times in total.
AmigaX1000
Follow me on twitter @basjoo_dk
Post Reply