Installs 98% OS4.1FE on Cloanto A4000PC Emulator

A forum for Classic Amiga specific support issues.
Post Reply
User avatar
Posts: 43
Joined: Fri May 31, 2013 4:22 pm

Installs 98% OS4.1FE on Cloanto A4000PC Emulator

Post by gonegahgah »

I'm having trouble completing my install.

I guess I should start with the file checksum... 6cbcad9f27e77f156e255702cc540000 for ClassicInstallCD-53.71.iso.lha
I downloaded it today. Is that what it should be?

That lha file decompresses to 564850688 bytes for ClassicInstallCD-53.71.iso
I also had a copy in a file which decompresses that to 564850688 bytes also.
So being the same size I'm guessing I've got the latest download and that it downloaded okay?

My install gets to 98% and stops with the following error:
Volume AmigaOS 4.1 Final Edition has a read/write error Process 76 "Installation Utility"

The resultant 98% install runs but defaults to 320x256 in 4 colours and notifies of missing files for the dock.
I can change that to a few classic and "board" options but not the 1920x1080 I specified.
Looking in the AmigaOS4.1 drive I could see that .info files were missing (no icons) and many other files.
So from the PC side I set about copying the missing files from the iso to the SYS drive.

Windows 10 popped up a few things when copying from the .iso initially to a shared directory:
1) The file name you specified is not valid or too long.
Specify a different file name.
2) This is no longer located in E:\System\Devs\DOSDrivers. Verify the item's location and try again.
2b) Same message for
3) This is no longer located in E:\System\Emulation\AmigaDisks\Workbench3.1\Storage\DOSDrivers. Verify the item's location and try again.
2c) Same message for

I'm guessing 1 above isn't a problem for the install.
Could problems with the AUX files be the cause of the install read/write error?

I then used the following in an Amiga shell:
to copy files from the shared directory to AmigaOS4.1:
Checking the result the AUX files are nowhere to be seen so they couldn't be copied by the looks...

After manually copying I'm currently running OS4.1 successfully (by the looks).
But, I can only run up to PAL: High Res Lace as no better options appear but it is still an improvement.
It is still complaining about some missing files in the startup:
:C-68k/Version: Unknown command
CD: object not found
DisplayWarn: Unknown command
Loading AmigaOS 4.1 Final Edition Kickstart...
:C-68k/Version: Unknown command
:Installation-Support/BuildScreenModePrefs: Unknown command
:Installation-Support/BuildScreenModePrefs: Unknown command
and AmigDock can't says: The following icon file is missing: :AmigaOS4.1-Installation

Several repeated installs produce exactly the same result...
Am I the only person having this problem? Any suggestions please on how to fix it?
Posts: 59
Joined: Fri Nov 11, 2011 8:03 pm

Re: Installs 98% OS4.1FE on Cloanto A4000PC Emulator

Post by Benny »

I can not see a checksum on the website of Hyperion, but the size is the same here: 564.850.688
No problem here installing it in Amiga Forever value edition Windows 10 some time ago.

Did you use the predefined settings of the machine in Amiga Forever, that uses hardfiles, but is a little bit slower ?
Last edited by Benny on Thu Feb 07, 2019 2:49 pm, edited 1 time in total.
User avatar
Beta Tester
Beta Tester
Posts: 1549
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark

Re: Installs 98% OS4.1FE on Cloanto A4000PC Emulator

Post by nbache »


I believe I've heard several times in the past about problems with the file name AUX under Windows.

I'm pretty sure it has nothing to do with your problems, it's just Windows being dumb and thinking there's something dangerous about files which happen to have that name.

And the <<Global>>.prefs is simply not a valid name under DOS/Windows because of the >>, which are reserved for redirection (Windows is again too dumb to recognize when stuff is a file name and when it is a redirection).

If you want to, you could probably manually copy those files over with different names and then rename them later from within AmigaOS (but this is just a guess, I haven't tried it). Anyway, they are not really important, unless you want to set up a serially linked Shell from another machine.

About the missing files in the startup: It looks like you're running the temporary startupsequence which would be replaced by the final one once you have finished the setup, but I'm not sure about the details when running under emulation. At least the :Installation-Support/ directory is something which is found on the installation CD, not in your final system, and the same goes for the icon for (and the file) :AmigaOS4.1-Installation.

Best regards,

Posts: 1
Joined: Wed Mar 27, 2019 8:31 am

Re: Installs 98% OS4.1FE on Cloanto A4000PC Emulator

Post by karjo238 »

Hello there!

After many years of not having anything much to do with Amiga in any shape, I stumbled upon a Youtube video of someone installing AmigaOS4 on a Windows PC, and I thought "Hey, lets's give that a go!" It seemed a low-fuss method of seeing how much had changed over the many years I have been away from the scene.

However, my install fails in the same manner as gonegahgah, and no matter what options I try, nothing seems to work.

Has anybody found the cause of this problem, or will I have to copy files from the CD in order to get this to work? I am not really familiar with the AmigaOS filesystem, so if I had to do this, I would need a fairly simple list of instructions to follow.

If nothing can be done, I might well just leave it and try on another machine...

Many thanks.
Post Reply