NVGetVar crash and UBoot-Prefs misbehaving (NV-vars?)

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

NVGetVar crash and UBoot-Prefs misbehaving (NV-vars?)

Post by Raziel »

I just wanted to get rid of a second IDE scan (on my XE needed to boot from CDs) and started UBoot-Prefs...
boom!
a little window popped up with some text inside i wasn't able to read because immediately after it the UBoot Prefs window popped up (I think it's the dreaded "USB Error", but i am not sure)...sadly with no input possibilty as my USB (KB and Mouse) were killed in the process.
(The system itself runs along...i can tell because my docky clock keeps counting the seconds)

Well, i thought, lets have another try...reboot...start UBoot prefs and whoohoo, it's there and my USB is still alive aswell :-)
Funny though as ALL of the settings were set to default (at least in the UBoot Prefs window).
I know they were set to my liking on every reboot...so, it seems the first misbehaviour is UBoot Prefs not able to read the NV-vars anymore.
n.b. Closing the UBoot-Prefs doing nothing and opening them up again brings back the above mentioned little window and a dead USB kb/mouse.

kk, no problem, we are pros, or so i thought :-)
going to do the change in shell with C:NVGetVar
but unfortunately this one grims right away :-(
Hidden Text - Click to Show :
Crash log for task "nvgetvar"
Generated by GrimReaper 53.2
Crash occured in module nvgetvar at address 0x7FC3DBCC
Type of crash: DSI (Data Storage Interrupt) exception

Register dump:
GPR (General Purpose Registers):
0: 7FC3D124 6741EF40 DCD4E2F1 00000000 4AAF489F 00000000 01DA3650 01DA3674
8: 00000001 00000000 00000006 00000000 4C3F72D0 F83E2E1A 19E70C00 6B0718D0
16: 01E60000 EFDB3C60 01E60000 00098FF8 6789B9B0 68D32010 01441844 67ED9DC0
24: 6FF5F0E4 68D2D1E0 00000000 69740000 00000000 6FF8F300 01CA2AB4 6FC5B740


FPR (Floating Point Registers, NaN = Not a Number):
0: nan 0 0 0
4: 0 0 0 0
8: 0 0 0 0
12: 0 0 0 0
16: 0 0 0 0
20: 0 0 0 0
24: 0 0 0 0
28: 0 0 0 0

FPSCR (Floating Point Status and Control Register): 0x82008000


SPRs (Special Purpose Registers):
Machine State (msr) : 0x0000F030
Condition (cr) : 0x39955E35
Instruction Pointer (ip) : 0x7FC3DBCC
Xtended Exception (xer) : 0xE000FF7C
Count (ctr) : 0x0141C890
Link (lr) : 0x7FC3D158
DSI Status (dsisr) : 0x40000000
Data Address (dar) : 0x00000000



680x0 emulated registers:
DATA: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x7FC3DBCC belongs to module "nvgetvar" (HUNK/Kickstart)

Stack trace:
module nvgetvar at 0x7FC3DBCC (section 4 @ 0xBAC)
native kernel module dos.library.kmod+0x00022a0c
native kernel module kernel+0x000416ec
native kernel module kernel+0x0004176c


PPC disassembly:
7fc3dbc4: 409effec bne+ cr7,0x7FC3DBB0
7fc3dbc8: 4e800020 blr
*7fc3dbcc: 88030000 lbz r0,0(r3)
7fc3dbd0: 7c691b78 mr r9,r3
7fc3dbd4: 38600000 li r3,0

System information:

CPU
Model: Motorola MPC 7447/7457 Apollo V1.2
CPU speed: 1266 MHz
FSB speed: 133 MHz
Extensions: performancemonitor altivec

Machine
Machine name: AmigaOne
Memory: 524288 KB
Extensions: bus.pci bus.agp
Not sure what has happened since upd3, but i cannot access the NV-vars from Wb anymore, or so it seems

Any thoughts?
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
ZeroG
Posts: 119
Joined: Sat Jun 18, 2011 11:31 am
Location: Germany

Re: [BUG] NVGetVar crash and UBoot-Prefs misbehaving (NV-var

Post by ZeroG »

nvgetvar does not crash here (A1-XE & 4.1u4) and i don't have any problems with Prefs/UBoot.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: [BUG] NVGetVar crash and UBoot-Prefs misbehaving (NV-var

Post by Raziel »

ZeroG wrote:nvgetvar does not crash here (A1-XE & 4.1u4) and i don't have any problems with Prefs/UBoot.
Yes, i don't think it's nvgetvar per se either.
I believe my nvvars got corrupted somehow and nvgetvar is crashing due to the corrupted data...

If any of the devs know a way on how to access and print out the vars other than with nvgetvar i will do and post them so this crash can at least be worked around with an error message instead of a crash.

If this isn't possible, then i'll go on and drain the battery to set everything to default.

Just gimme a shout please

edit: btw, i can force my USB to stall by doing a "nvgetvar baudrate" :-)
(it doesn't print any of the values, though, just dies silently)
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
ZeroG
Posts: 119
Joined: Sat Jun 18, 2011 11:31 am
Location: Germany

Re: [BUG] NVGetVar crash and UBoot-Prefs misbehaving (NV-var

Post by ZeroG »

Does a UBoot-image that is created with SYS:System/BIOSUpdater include your nv-vars?
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: [BUG] NVGetVar crash and UBoot-Prefs misbehaving (NV-var

Post by Raziel »

ZeroG wrote:Does a UBoot-image that is created with SYS:System/BIOSUpdater include your nv-vars?
No idea (the image is all gibberish with no real text), but thanks for the hint.
I created and saved an image of my UBoot and am ready to send it to whoever wants to check it out.
I assume uploading would breach the UBoot (flash) copyright, so i'll only send it to a dev upn request.
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: [BUG] NVGetVar crash and UBoot-Prefs misbehaving (NV-var

Post by Raziel »

Ok, the behaviour is gone :-/

I remembered Ranger was able to read out the vars and tried if i can crash i aswell...it didn't :-)
If it has "fixed" it by just reading the vars ut i don't know, maybe the problem solved itself in the meantime.

Maybe it was an unsupported USB2 PCI card that was still plugged in, i don't know

Anywho, this crash is gone completely and i'm happy again and everyone can go back to their work :-D
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Post Reply