Fienix - New PowerPC Distro

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

kilaueabart wrote: Sat Aug 08, 2020 9:58 pm
caseycullen wrote: Wed Jul 29, 2020 4:50 am If you want to try out the new theme and tell me what you think, I packaged a "draft candidate" .deb that you can download here. After you install it, go to Control Center, Appearance, and select "Fienix Default".
I guess that's what I am using now, but only notice minor differences.
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

kilaueabart wrote: Fri Aug 07, 2020 11:40 pm Curiouser and curiouser. Today I found gnucash-4.1.tar.bz2 in Downloads, but have no idea how it got there, since Synaptic refuses to send it. I did unarchive it and try unsuccessfully to figure out a way to run it from /Downloads/gnucash-4.1/, but utterly baffled.

Today I was successful at refreshing synaptic and upgrading. Then just for the heck of it I tried downloading gnucash-common and gnucash-docs, ignoring gnucash itself, and I was successful in installing them, or at least so Synaptic informs me. I haven't really tried to find out where they might be on my disk yet. Probably no real point in doing so, without the main program.

Made one more try at gnucash without success, but when I check its Properties on Synaptic, I get Status: [!] Broken. So now I am starting to wonder if there is something wrong with the package at Synaptic and not something broken on my own computer.

I hope I will be forgiven for copying this over from an ArcticFox board to this more appropriate one.
It looks like I probably missed some dependencies. I'll take a look.
Thanks,
-Casey
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

Clicking "Properties" at gnucash in Synaptic gets me this, as Depends, italicized:

libboost-regex1.71.0-icu67
(I have 1.71.0-6+b2. -icu67 not listed at Synaptic. Googling "libboost-regex1.71.0-icu67" gets me "libboost-regex1.71.0_1.71.0-6+b2_amd64.deb," and a couple similar, looking a lot like what I already have.)

perl:any
(I reportedly have perl already. libboost-regex1.71.0-icu67 would presumably be part of it.)

Replaces: gnucash-common (<1:2.4.8-1~)
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

Cave Story is a platform-adventure game that received widespread critical acclaim, and is now available in the Fienix software repository.

Thanks to EXL, the developer of the open-source NXEngine, for committing changes so it builds on PowerPC. Both the engine and the game data (released by Studio Pixel as freeware) are in the repository. Just install the package "cavestory", and if you experience any issues please let me know!

-Casey

Image

Image

Image
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

xeno74 wrote: Mon Aug 10, 2020 12:38 pm Hi Casey,

I updated Fienix today. Unfortunately "mate-screenshot" doesn't work anymore. Could you please test it?

Thanks,
Christian
It works for me...
Image
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

kilaueabart wrote: Fri Aug 14, 2020 12:38 am Clicking "Properties" at gnucash in Synaptic gets me this, as Depends, italicized:

libboost-regex1.71.0-icu67
(I have 1.71.0-6+b2. -icu67 not listed at Synaptic. Googling "libboost-regex1.71.0-icu67" gets me "libboost-regex1.71.0_1.71.0-6+b2_amd64.deb," and a couple similar, looking a lot like what I already have.)

perl:any
(I reportedly have perl already. libboost-regex1.71.0-icu67 would presumably be part of it.)

Replaces: gnucash-common (<1:2.4.8-1~)
Could you please post the result of "apt-get install gnucash"?
Thanks.
User avatar
xeno74
Posts: 6322
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

caseycullen wrote: Fri Aug 14, 2020 3:43 am It works for me...
This dialog box works on my Fienix too but it doesn’t create any screenshots. I use mtPaint instead currently.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

caseycullen wrote: Fri Aug 14, 2020 3:48 am Could you please post the result of "apt-get install gnucash"?
Thanks.
Sure. I wish everything were so easy.

Code: Select all

root@Fienix:/home/fienix# apt-get install gnucash
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libbytes-random-secure-perl : Depends: libcrypt-random-seed-perl but it is not installable
                               Depends: libmath-random-isaac-perl but it is not installable
 libdatetime-format-strptime-perl : Depends: libdatetime-locale-perl (>= 1:1.23) but it is not going to be installed
                                    Depends: libdatetime-timezone-perl (>= 1:2.09) but it is not going to be installed
                                    Depends: libparams-validationcompiler-perl but it is not installable
                                    Depends: libspecio-perl but it is not installable
 libdatetime-perl : Depends: libdatetime-locale-perl (>= 1:1.06) but it is not going to be installed
                    Depends: libdatetime-timezone-perl (>= 1:2.02) but it is not going to be installed
                    Depends: libparams-validationcompiler-perl (>= 0.26) but it is not installable
                    Depends: libspecio-perl but it is not installable
 libgwenhywfar79 : Depends: libgnutls30 (>= 3.6.14) but 3.6.13-4 is to be installed
E: Unable to correct problems, you have held broken packages.
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

kilaueabart wrote: Sat Aug 15, 2020 9:58 pm Sure. I wish everything were so easy.

Code: Select all

root@Fienix:/home/fienix# apt-get install gnucash
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libbytes-random-secure-perl : Depends: libcrypt-random-seed-perl but it is not installable
                               Depends: libmath-random-isaac-perl but it is not installable
 libdatetime-format-strptime-perl : Depends: libdatetime-locale-perl (>= 1:1.23) but it is not going to be installed
                                    Depends: libdatetime-timezone-perl (>= 1:2.09) but it is not going to be installed
                                    Depends: libparams-validationcompiler-perl but it is not installable
                                    Depends: libspecio-perl but it is not installable
 libdatetime-perl : Depends: libdatetime-locale-perl (>= 1:1.06) but it is not going to be installed
                    Depends: libdatetime-timezone-perl (>= 1:2.02) but it is not going to be installed
                    Depends: libparams-validationcompiler-perl (>= 0.26) but it is not installable
                    Depends: libspecio-perl but it is not installable
 libgwenhywfar79 : Depends: libgnutls30 (>= 3.6.14) but 3.6.13-4 is to be installed
E: Unable to correct problems, you have held broken packages.
Please retry "apt-get install gnucash".

Thanks,
Casey
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

I did so immediately and the results were letter for letter the same as previously. Then I tried an apt-get update and repeated the apt-get install gnucash. At first glance it seemed like the same result, but no, curiously different:

Code: Select all

The following packages have unmet dependencies:
 libgnutls30 : Depends: libhogweed6 (>= 3.4.1~rc1) but it is not installable
               Depends: libnettle8 (>= 3.4.1~rc1) but it is not installable
 libparams-validationcompiler-perl : Depends: libeval-closure-perl but it is not installable
                                     Depends: libexception-class-perl but it is not installable
                                     Recommends: libclass-xsaccessor-perl but it is not going to be installed
 libspecio-perl : Depends: libdevel-stacktrace-perl but it is not installable
                  Depends: libeval-closure-perl but it is not installable
                  Depends: libmro-compat-perl but it is not installable
                  Depends: libxstring-perl but it is not installable
                  Recommends: libref-util-perl but it is not installable
On a side note, when I tried to Preview the above, the Interweb had quit working. I Restarted but after 11 minutes of Stop jobs I clicked the machine and rebooted. No internet. Restarted again, ditto. So I reluctantly came to Ubuntu. I often get up to five Stop jobs when closing fienix, but the most common one is something like For User Manager ID 1000, which usually ends in less than two minutes.
Post Reply