Kernel 5.8

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

FYI because of the KVM-PR issue:
Nicholas Piggin wrote: Hey, thanks for debugging it and reporting. I'm looking into it, will
try to get a fix soon.

Thanks,
Nick
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Nicholas Piggin has released a patch:
Nicholas Piggin wrote: Does this patch fix it for you?

The CTR register reload in the KVM interrupt path used the wrong save
area for SLB (and NMI) interrupts.

Code: Select all

Fixes: 9600f261acaaa ("powerpc/64s/exception: Move KVM test to common code")
Reported-by: Christian Zigotzky <chzigotzky@xenosoft.de>
Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
---
 arch/powerpc/kernel/exceptions-64s.S | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/powerpc/kernel/exceptions-64s.S b/arch/powerpc/kernel/exceptions-64s.S
index e70ebb5c318c..fa080694e581 100644
--- a/arch/powerpc/kernel/exceptions-64s.S
+++ b/arch/powerpc/kernel/exceptions-64s.S
@@ -270,7 +270,7 @@ BEGIN_FTR_SECTION
 END_FTR_SECTION_IFSET(CPU_FTR_CFAR)
 	.endif
 
-	ld	r10,PACA_EXGEN+EX_CTR(r13)
+	ld	r10,IAREA+EX_CTR(r13)
 	mtctr	r10
 BEGIN_FTR_SECTION
 	ld	r10,IAREA+EX_PPR(r13)
@@ -298,7 +298,7 @@ END_FTR_SECTION_IFSET(CPU_FTR_HAS_PPR)
 
 	.if IKVM_SKIP
 89:	mtocrf	0x80,r9
-	ld	r10,PACA_EXGEN+EX_CTR(r13)
+	ld	r10,IAREA+EX_CTR(r13)
 	mtctr	r10
 	ld	r9,IAREA+EX_R9(r13)
 	ld	r10,IAREA+EX_R10(r13)
-- 
2.23.0
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Hi All,

I released the RC1 of kernel 5.8 for the X1000 and X5000 today. The issue with KVM-PR has been solved. :-)

New:
Download: linux-image-5.8-rc1-X1000_X5000.tar.gz

Image

Image

Please test the kernels.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 619
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

Kernel 5.8 RC1 breaks the onboard DPAA network adapter of the AmigaOne X5000/20

Image

Big picture http://www.skateman.nl/wp-content/uploa ... 234930.png

Reverting back to Alpha 4 made the DPAA network adapter working again.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Skateman wrote: Mon Jun 15, 2020 8:56 pm Kernel 5.8 RC1 breaks the onboard DPAA network adapter of the AmigaOne X5000/20
Hi Skateman,

Thanks a lot for testing the RC1! :-)

Strange thing with the DPAA ethernet. I didn’t find any DPAA changes between the alpha4 and the RC1. I only found one DPAA2 commit between the alpha4 and the RC1 but our X5000 has DPAA1. The kernel developers expect a bisect from us but I can’t do it alone because the DPAA ethernet has never worked reliable on my X5000/20 and X5000/40. We need to create about 13 kernels for the bisect. I can do that but I need you for testing them on your X5000. It’s a lot of work. What do you think? Shall we do it?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 619
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

For me its key to have the onboard ethernet adapter working again.
I also think that most of us did not tried to unplug the inserted pci networkadapter so the X5K was using only its onboard adapter.
If thats the solution i dont know... but i wont revert back to using a pci nic.

That leaves me to the only possible option, and i am willing to test all kernels needed :-)
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Skateman wrote: Tue Jun 16, 2020 5:44 pm I also think that most of us did not tried to unplug the inserted pci networkadapter so the X5K was using only its onboard adapter.
I did it because MorphOS on my X5000/20 doesn't need an additional PCI network card. I successfully downloaded the RC1 with the onboard ethernet (p50x0eth.device:0) on MorphOS today and after unpacking the package I was able to copy the RC1 kernel to the Fienix-boot partition. Then I rebooted the X5000/20 and started Fienix with the RC1 successfully.

Screenshots:

Image

Image

I also tested the DPAA Ethernet with the stable kernel 5.7 and Darren's new cyrus-p5020.dtb on my X5000/20 but without any success.

Error messages:

Code: Select all

Jun 16 18:24:45 Fienix NetworkManager[3823]: <info>  [1592349885.1417] device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
Jun 16 18:24:45 Fienix NetworkManager[3823]: <info>  [1592349885.1550] device (eth1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
Skateman wrote: Tue Jun 16, 2020 5:44 pm That leaves me to the only possible option, and i am willing to test all kernels needed :-)
I will compile the first test kernel tomorrow.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

OK Skateman, let's test them ....

Code: Select all

git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git a

Code: Select all

git bisect start

Code: Select all

git bisect good 3d77e6a8804abcc0504c904bd6e5cdf3a5cf8162
(Good: Linux 5.7)

Code: Select all

git bisect bad b3a9e3b9622ae10064826dccb4f7a52bd88c7407
(Bad: Linux 5.8-rc1)

Download: uImage-dpaa1

Please test it.

Thanks
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 619
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

This kernel does not boot!
Uboot picture: http://www.skateman.nl/wp-content/uploa ... scaled.jpg
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 7370
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Skateman wrote: Wed Jun 17, 2020 8:25 am This kernel does not boot!
Uboot picture: http://www.skateman.nl/wp-content/uploa ... scaled.jpg
I see. This kernel needs the boot-v1.patch because of the boot issues at the beginning of the kernel 5.8 testing.

Please try it again with the following patched kernel: uImage-dpaa2
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
Post Reply