Background colour of text under icon

A forum for general AmigaOS 4.x support questions that are not platform-specific
dzanino
Posts: 21
Joined: Fri Aug 17, 2018 6:14 am

Background colour of text under icon

Post by dzanino »

Is there a way to set background colour, or contour colour of the text under icon on the workbench screen?
I have a black bacground as a bacdrop, and the text is black
Changing colour of the text doesnt fix my problem


I remember in AOS3.9 it was in Text app in Prefs Text+background
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1445
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Background colour of text under icon

Post by tonyw »

Open the Prefs drawer, then "Font".
Click on the "Workbench Icon Font" at the bottom of the page. Now you have a wide window labelled "Select Workbench desktop icon font".
You can select the style of the text under the icon (Text, Text + outline, etc). You can also select the colours of the text and the outline independently.
The row of colours "Text" selects the text colour, while the row "Field" selects the background colour.

I usually have white text with a black outline - it works no matter what the background picture shows.
cheers
tony
dzanino
Posts: 21
Joined: Fri Aug 17, 2018 6:14 am

Re: Background colour of text under icon

Post by dzanino »

Yes but this was in AmigaOS3.9
But in AOS4.1 (i have forgottne to mention it above)
I cant see it in "Font" app in Prefs
User avatar
MichaelMerkel
Beta Tester
Beta Tester
Posts: 350
Joined: Mon Dec 20, 2010 2:08 pm
Location: Germany
Contact:

Re: Background colour of text under icon

Post by MichaelMerkel »

sure font prefs is available in os4.1.
even in the contextmenu on workbench (if commodity is running).

regards...
michael
Michael Merkel :lol:
(Member of Amiga Freunde Pfalz)
User avatar
sundown
Beta Tester
Beta Tester
Posts: 465
Joined: Mon Dec 20, 2010 10:38 pm
Location: California, USA

Re: Background colour of text under icon

Post by sundown »

dzanino wrote:Yes but this was in AmigaOS3.9
But in AOS4.1 (i have forgottne to mention it above)
I cant see it in "Font" app in Prefs
Font prefs for 4.1 is the same, open fonts prefs, click on the workbench font Ff button to select size & colors.
X1000 - Antec Solo case, 4GB DDR2 mem, XFX R9 270 gfx card, Plextor DVD, 2 Samsung 1TB F3 HDD, RTL-8139 network card, Cooler Master Silent Pro 600W PSU
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1506
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Background colour of text under icon

Post by nbache »

Try playing around with the "Mode" chooser under the Text and Background colour gadgets. You can choose Text+[something], where [something] can be Background, Outline or Shadow (English words might differ, I'm looking at the Danish translation). When one of those is selected, the corresponding second colour selector opens for use - and of course the resulting effect is shown in the preview underneath.

Best regards,

Niels
dzanino
Posts: 21
Joined: Fri Aug 17, 2018 6:14 am

Re: Background colour of text under icon

Post by dzanino »

iam blind - where?
F39162A8-0A9A-4060-9902-6E807DE9E358.jpeg
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1506
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Background colour of text under icon

Post by nbache »

Hmm ... which version of OS 4.1 are you on?

Best regards,

Niels
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1445
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Background colour of text under icon

Post by tonyw »

Is that what you get when you click on the "Ff" button on the line "Workbench icon font" ?

If so, then the font prefs has been replaced by something else. I don't have anything like the "Font family" you show and I'm sure Niels hasn't either. It's a furphy.

My (our) font prefs is labelled "V53.6" from "10/5/2011", and it hasn't changed in OS4 since then. Do you have an Enhancer font replacement installed, perhaps?
cheers
tony
User avatar
trixie
Posts: 400
Joined: Thu Jun 30, 2011 2:54 pm
Location: Czech Republic

Re: Background colour of text under icon

Post by trixie »

tonyw wrote:Do you have an Enhancer font replacement installed, perhaps?
There is no Enhancer font replacement as far as I know.
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Post Reply