Altivec?

AmigaOne X5000 platform specific issues.
Post Reply
xenic
Posts: 1164
Joined: Sun Jun 19, 2011 12:06 am

Altivec?

Post by xenic »

I been testing programs that I've copied over from my X1000 and found that MUIMPlayer and MPlayer caused sever crashes. Both programs were set to use Altivec versions on my X1000 and are the cause of the crashes. When I switched both video player to non-altivec, they work as before on my X1000.

Does X5000 have Altivec? Is there some compatability issue between Altivec for different PowerPC processors?
AmigaOne X1000 with 2GB memory - OS4.1 FE

User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1410
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Altivec?

Post by tonyw »

No, the p5020 and p5040 CPUs do not have Altivec.
cheers
tony

User avatar
daveyw
Posts: 237
Joined: Mon Sep 12, 2011 7:44 pm

Re: Altivec?

Post by daveyw »

Hmmm...

AmigaOne - Altivec
SAM - No Altivec
X1000 - Altivec
X5000 - No Altivec

So I guess the next PPC Amiga will have Altivec? ;)

User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 516
Joined: Sat Jun 18, 2011 3:12 pm
Location: Finland
Contact:

Re: Altivec?

Post by salass00 »

The Tabor AKA A1222 doesn't have altivec either AFAIK.

Also not all Eyetech AmigaOne models had altivec (only the A1-XE models that came with G4 CPUs).

K-L
Posts: 76
Joined: Thu Sep 08, 2011 8:35 pm
Location: Lyon, France
Contact:

Re: Altivec?

Post by K-L »

Only PowerPC CPUs equipped with AltiVec and supported by AmigaOS 4.1 are : G4 (used in AmigaOne XE G4 and Pegasos II G4) and PA6T-1682M (used in X1000).
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition

Post Reply