Screen mode doesn't appear with Final Edition

AmigaOne X1000 platform specific issues.
Post Reply
softwarefailure
Posts: 101
Joined: Fri Feb 14, 2014 10:29 pm

Screen mode doesn't appear with Final Edition

Post by softwarefailure »

I just upgraded to Final Edition on the X1000 and the ScreenMode prefs do not allow me to select any resolution higher than 1024x768. 1024x768 is always the highest resolution offered in ScreenMode prefs but my monitor's default resolution is 1680x1050. I didn't have any such problems with OS4.1.6 on the X1000. The monitor is connected via DVI. This is what "DEVS:Monitors/Radeon HD 5450" looks like:

Code: Select all

CMPLENGTH=14
BOARDNAME=Radeon HD 5450
VSYNCMIN=60
VSYNCMAX=60
HSYNCMIN=31000
HSYNCMAX=85000
MODE=640x480@60
MODE=800x600@60
MODE=1024x768@60
MODE=1280x720@60
MODE=1280x800@60
MODE=1280x960@60
MODE=1280x1024@60
MODE=1440x900@60
MODE=1600x900@60
MODE=1600x1200@60
MODE=1680x1050@60
DISABLEFAKENATIVE=Yes
INTERRUPT=Yes
I've been playing around with all options offered by ScreenMode prefs (auto detect, 60hz modes only....) but it just doesn't work. I always end up with a 1024x768 screen mode. How can I get OS4 to use my monitor's native resolution of 1680x1050? Is this maybe a limitation of the RadeonHD demo version driver that comes with FE?

User avatar
Petrol
Beta Tester
Beta Tester
Posts: 164
Joined: Mon Dec 20, 2010 6:19 pm
Location: France

Re: Screen mode doesn't appear with Final Edition

Post by Petrol »

Hello,

You have to upgrade your RadeonHD driver. As an X1000 owner, you can download it via A-eon website or AmiStore.
The driver installed with the FE CD is a limited one (1024*768 max).

Regards,
Xavier.

softwarefailure
Posts: 101
Joined: Fri Feb 14, 2014 10:29 pm

Re: Screen mode doesn't appear with Final Edition

Post by softwarefailure »

Thanks, now it's working. Was that mentioned anywhere that 1024x768 is a limitation? I don't remember reading it and I'm a little annoyed because I've just wasted an hour of my life trying to figure out why no screen modes higher than 1024x768 are supported. This demo version limitation should really be made much more explicit to avoid user frustration.

User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 591
Joined: Sat Jun 18, 2011 2:40 am
Location: Portsmouth, UK
Contact:

Re: Screen mode doesn't appear with Final Edition

Post by broadblues »

softwarefailure wrote:Thanks, now it's working. Was that mentioned anywhere that 1024x768 is a limitation? I don't remember reading it and I'm a little annoyed because I've just wasted an hour of my life trying to figure out why no screen modes higher than 1024x768 are supported. This demo version limitation should really be made much more explicit to avoid user frustration.
It's mentioned about 4 times during the installation process and then there agreat big adverts for the full driver first thing staght after booting. How much more obvious can it bde made?

Post Reply