AutoDocs: clicktab_gc errors & discrepancies

Have a question about our Software Developer Kit? Ask them here.
Post Reply
User avatar
OldFart
Posts: 55
Joined: Tue Jul 12, 2011 2:56 pm
Location: Groningen, Netherlands

AutoDocs: clicktab_gc errors & discrepancies

Post by OldFart »

CLICKTAB_CurrentNode (struct Node *)
Currently selected tab node.

Defaults to NULL.

Applicability is (OM_GET, OM_SET, OM_NOTIFY)

SDK specifies ti_Data to be struct TabNode *

--------------------------------------------------
CLICKTAB_PageGroup (APTR) (V42)
Embedded page.gadget object child pointer.

Defaults to NULL.

Applicability is (OM_NEW, OM_SET)

SDK specifies ti_Data to be Object *

--------------------------------------------------
CLICKTAB_PageGroupBackFill (struct Hook *) (V42)
Embedded page.gadget object selected ClickTab
backfill pointer.

A layer backfill hook to provide a more complex
background pattern. See InstallLayerHook() for
more details about the backfill hook.

Defaults to NULL.

Applicability is (OM_NEW, OM_SET)

SDK specifies ti_Data to be Object *
Sleeping X5000, eagerly awaiting awakening
Dead MicroA1
A1200 in ElBox, c/w Blizzard '040 @ 50MHz + SCSI module, ZIV-board c/w (o.a.) cv64/3d + flickerdoubler + FastATA-ZIV + Lots of SCSI gear (for sale, willing to split)
RaspBerry Pi 2B, 3B & 4B (4Gb)
User avatar
trixie
Posts: 400
Joined: Thu Jun 30, 2011 2:54 pm
Location: Czech Republic

Re: AutoDocs: clicktab_gc errors & discrepancies

Post by trixie »

You'd better mention explicitly what you think is an error or a discrepancy. For instance, I don't see anything wrong here with CLICKTAB_PageGroup.
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 349
Joined: Mon Jan 17, 2011 9:42 pm

Re: AutoDocs: clicktab_gc errors & discrepancies

Post by Rigo »

Fixed at source level.

Simon
User avatar
trixie
Posts: 400
Joined: Thu Jun 30, 2011 2:54 pm
Location: Czech Republic

Re: AutoDocs: clicktab_gc errors & discrepancies

Post by trixie »

@Rigo

By the way, Simon - is there a reason why the CLICKTAB_PageGroup layout object pointer is not OM_GET-able?
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 349
Joined: Mon Jan 17, 2011 9:42 pm

Re: AutoDocs: clicktab_gc errors & discrepancies

Post by Rigo »

None that I know of, but the source may explain it. I'll have a look.

Simon
Post Reply