Lost wi-fi

AmigaOne X5000 platform specific issues related to Linux only.
Post Reply
User avatar
kilaueabart
Posts: 705
Joined: Mon Mar 05, 2012 2:36 am

Lost wi-fi

Post by kilaueabart »

I snagged a newer version of uImage-5.5 than I had gotten around to downloading and installing myself from Casey's newest soar's FIENIX-BOOT. Then I updated /etc/modules by adding 5.5.11_A-EON_X5000.

Could that be the reason I suddenly stopped getting wi-fi?

User avatar
Skateman
Posts: 494
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Lost wi-fi

Post by Skateman »

i would take the latest kernel from Christian and extract the contents.
Place the Kernel file on the location needed.. in my case its on the SD card.
Place the modules folder in /lib/modules (as root )

This should work.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world

User avatar
kilaueabart
Posts: 705
Joined: Mon Mar 05, 2012 2:36 am

Re: Lost wi-fi

Post by kilaueabart »

I thank you for the suggestion, but if the kernel "Modified" Sat 21 Mar 2020 09:05:26 AM PDT, the one Casey put in his FIENIX-BOOT, together with the 5.5.11_A-EON_X5000 module that Christian originally packaged with that kernel (I had downloaded and extracted the package but didn't get around to using it), don't get my wi-fi, can I be sure that Kernel 5.7 RC3-2 and its module will? I don't see a wi-fi symbol in your May 02 Big picture.

I have the impression that Christian has sometimes included wi-fi, sometimes not. I'm not 100% sure that having it does me any good, but internet is so slow in my Ubuntu browsers that I grasp at any possible advantage.

User avatar
xeno74
Posts: 6081
Joined: Fri Mar 23, 2012 7:58 am

Re: Lost wi-fi

Post by xeno74 »

kilaueabart wrote:
Mon May 04, 2020 12:23 am
I have the impression that Christian has sometimes included wi-fi, sometimes not. I'm not 100% sure that having it does me any good, but internet is so slow in my Ubuntu browsers that I grasp at any possible advantage.
Wi-fi is always included. I use it sometimes.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 6081
Joined: Fri Mar 23, 2012 7:58 am

Re: Lost wi-fi

Post by xeno74 »

kilaueabart wrote:
Mon May 04, 2020 12:23 am
can I be sure that Kernel 5.7 RC3-2 and its module will?
No, these modules don't work with the kernel 5.5.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply