Updater - Please insert volume SDK: in any drive

AmigaOne X5000 platform specific issues.
cpaek72
Posts: 4
Joined: Mon Jul 17, 2017 10:06 pm

Updater - Please insert volume SDK: in any drive

Post by cpaek72 »

I get a process 334 updater error - Please insert volume SDK: in any drive whenever I try to start up updater. I can cancel and bypass, but the error will keep on coming up every time I initiate the program. Please let me know how I can fix. thanks.

Charles
User avatar
Skateman
Posts: 555
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Updater - Please insert volume SDK: in any drive

Post by Skateman »

Download and install the SDK first.

http://www.hyperion-entertainment.biz/i ... &Itemid=63
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1501
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Updater - Please insert volume SDK: in any drive

Post by nbache »

That should not be necessary, unless you are a developer.

If Updater requests the SDK, something is wrong.

Which version of Updater do you have?

BTW, Updater is part of the Enhancer Software, not an official part of AmigaOS, so it might be better to discuss this on e.g. Amigans.net.

Best regards,

Niels
User avatar
daveyw
Posts: 237
Joined: Mon Sep 12, 2011 7:44 pm

Re: Updater - Please insert volume SDK: in any drive

Post by daveyw »

Yeah, I get this as well. I mentioned it on Amigans. Got zero response.

It started a month or so back when updater added some SDK elements.
cpaek72
Posts: 4
Joined: Mon Jul 17, 2017 10:06 pm

Re: Updater - Please insert volume SDK: in any drive

Post by cpaek72 »

Yeah, support is pretty poor. Hopefully someone has a fix.
User avatar
Skateman
Posts: 555
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Updater - Please insert volume SDK: in any drive

Post by Skateman »

I have the Enhancer 1.4 installed without any problems. I did install the SDK a while ago.
You might just give it a try...
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
amigakit
AmigaKit
AmigaKit
Posts: 294
Joined: Mon Mar 14, 2011 11:31 pm
Contact:

Re: Updater - Please insert volume SDK: in any drive

Post by amigakit »

Yeah, support is pretty poor. Hopefully someone has a fix.
We work hard to fix any issues that are presented to us and have over many months been pushing updated files through the Updater tool.

I just tried disabling the SDK: assign in my s:user-startup and then run Updater 53.50 again but I had no problem. Are you using an old version of Updater maybe ?

Yeah, I get this as well. I mentioned it on Amigans. Got zero response.
Maybe you can report issues on the official public forum of the Enhancer Software: http://forum.amiga.org/enhancersoftware

I am more likely to spot messages there because I do not visit this forum often.
Customer Help & Support: http://www.amigakit.com/help

www.amigakit.com Amiga Computer Store
User avatar
daveyw
Posts: 237
Joined: Mon Sep 12, 2011 7:44 pm

Re: Updater - Please insert volume SDK: in any drive

Post by daveyw »

I am running Updater version 53.50 (26.08.2018)

You will need to tell me if this is the most recent version or not.

Updater is looking for LDCK on SDK:C. Could that be why it is lookginf for volume SDK:?
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1501
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Updater - Please insert volume SDK: in any drive

Post by nbache »

daveyw wrote:I am running Updater version 53.50 (26.08.2018)

You will need to tell me if this is the most recent version or not.
It is.
Updater is looking for LDCK on SDK:C. Could that be why it is lookginf for volume SDK:?
Aha.

LDCK is a developer tool (a new toolkit for building libraries or something). Thus it is only relevant for developers who will naturally have the SDK.

It sounds like the server side database behind Updater needs to be updated so Updater doesn't offer this unless there is an SDK: assign.

Matthew?

Best regards,

Niels
User avatar
Raziel
Posts: 988
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Updater - Please insert volume SDK: in any drive

Post by Raziel »

LDCK is still not available for my account to be downloaded...why?

I have the SDK installed, so you want us to pay for SDK stuff now?
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Post Reply