Kernel 4.11

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Kernel 4.11

Post by xeno74 »

Hi All,

The Linux 4.11 merge window is open. :-) A lot of source code has been added to the Linux Git last night.

I compiled the first alpha from the Linux Git today.

New:
Download: vmlinux-4.11-alpha1-AmigaONE_X1000.tar.gz

Screenshot of the Nemo config for the kernel 4.11:

Image

Please test the alpha1.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

daz
Beta Tester
Beta Tester
Posts: 314
Joined: Tue Dec 21, 2010 7:32 pm

Re: Kernel 4.11

Post by daz »

xeno74 wrote:Hi All,

The Linux 4.11 merge window is open. :-) A lot of source code has been added to the Linux Git last night.

I compiled the first alpha from the Linux Git today.

New:
Download: vmlinux-4.11-alpha1-AmigaONE_X1000.tar.gz

Screenshot of the Nemo config for the kernel 4.11:
I notice you still have PASEMI_IOMMU_DMA_FORCE selected, that should have been fixed by:
commit 416f37d0816b powerpc/pasemi: Fix coherent_dma_mask for DMA engine

Note also there are 3 of my patches due to be merged, so our patch will be changing again soon.

I've tested my build from linux-next, seems to be working nicely.
Also there seems to be a new Radeon firmware added to the kernel: si58_mc.bin. Note sure which cards need it though.

Regards
Darren

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

Hi Darren,

Thanks a lot for the hints.
daz wrote: I notice you still have PASEMI_IOMMU_DMA_FORCE selected, that should have been fixed by:
commit 416f37d0816b powerpc/pasemi: Fix coherent_dma_mask for DMA engine
I will deactivate the option PASEMI_IOMMU_DMA_FORCE.
daz wrote: Note also there are 3 of my patches due to be merged, so our patch will be changing again soon.
I've found only the 2 following patches. Where is the third patch?
daz wrote: I've tested my build from linux-next, seems to be working nicely.
Also there seems to be a new Radeon firmware added to the kernel: si58_mc.bin. Note sure which cards need it though.

Regards
Darren
I've found the new firmware: people.freedesktop.org/~agd5f

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

New Nemo patch and config for the alpha2:
Our Nemo patch has become smaller again. :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

Hi All,

Darren moved a lot of source code from the Nemo patch to the official kernel source code again. Thereby our Nemo patch has become smaller again. :-)

I compiled the alpha2 with the new smaller Nemo patch 4.11-1 and with the kernel config nemo-4.11-alpha2.config today.

New:
Download: vmlinux-4.11-alpha2-AmigaONE_X1000.tar.gz

BTW, it is still possible to upgrade packages on ubuntu MATE 17.04 PowerPC. I upgraded some packages yesterday and today.

Screenshot of ubuntu MATE 17.04 PowerPC with the new alpha2:

Image

Please test the alpha2.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

Hi All,

I got some error messages with the latest Linux Git version including the new PowerPC updates (powerpc-4.11-1):

Code: Select all

arch/powerpc/platforms/pasemi/pci.c:281:2: error: implicit declaration of function 'isa_bridge_find_early' [-Werror=implicit-function-declaration]
  isa_bridge_find_early(hose);
  ^
cc1: some warnings being treated as errors
make[2]: *** [arch/powerpc/platforms/pasemi/pci.o] Error 1
make[1]: *** [arch/powerpc/platforms/pasemi] Error 2
make: *** [arch/powerpc/platforms] Error 2
The Linux PPC kernel developers moved the declaration of 'isa_bridge_find_early' from the file 'arch/powerpc/include/asm/pci-bridge.h' to 'arch/powerpc/include/asm/isa-bridge.h'.

I added

Code: Select all

#include <asm/isa-bridge.h>
to the part 'arch/powerpc/platforms/pasemi/pci.c' in our Nemo patch. This solved the problem.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

New Nemo patch for the alpha3: nemo_4.11-2.patch
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

Hi All,

I compiled the latest Git version with the new Nemo patch 4.11-2 today.

New:
Download: vmlinux-4.11-alpha3-AmigaONE_X1000.tar.gz

It is still possible to upgrade ubuntu MATE 17.04 PowerPC. I was able to upgrade it today. Maybe we reach the final version of ubuntu MATE 17.04 PowerPC.

Screenshot of ubuntu MATE 17.04 PowerPC with the new alpha3:

Image

Please test the alpha3.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5711
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.11

Post by xeno74 »

Hi All,

Great news! :-)

Darren's X1000 audio driver patch was added to the Linux Git last night.

Link: ALSA: hda/patch_sigmatel: Add AmigaOne X1000 pin configs

Because of that I created a new Nemo patch today.

Download: nemo_4.11-3.patch

Our Nemo patch has become smaller again. :-)

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply