Foiled again?

AmigaOne X1000 platform specific issues related to Linux only.
Post Reply
User avatar
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Foiled again?

Post by kilaueabart »

Using a fresh install of Ubuntu 12.04 LTS just to be sure that no mistakes I might have made before would remain to haunt me, I made a fresh attempt at a chroot 15.10 MATE. I used a print out of the instructions this time, and for about three hours I thought there was a good chance that I would succeed this time.

There was a possible problem early on. Perhaps I should have quit when, after the three mount commands near the beginning, "chroot . /bin/bash" brought this negative remark:
bash: warning: setlocale: LC_ALL: cannot change locale (en-GB.UTF-S)
but "cat /etc/issue" brought the desired
Ubuntu Wily Werewolf (development branch) \n \l
so I supposed that everything was all right. There were a lot of lines about "Cannot do [something or other to] locale" during the "apt-get install ubuntu-mate-desktop" but the next thing that really caused me to worry was when I followed the instruction
Please leave the ubuntu MATE 15.10 chroot with
I suddenly noticed these two lines:
root@bart-desktop:/# exit
It looks like I was already out of chroot, and I "exited" into it!
Also I had started the session with "sudo su" but when I typed
mount --bind /tmp/.X11-unix ./tmp/.X11-unix
that was apparently no longer in effect: "only root can do that."
So I sudo su'ed again and the mount command worked, as did "xhost + local:," but this time "chroot . /bin/bash" got "chroot: failed ... No such file or directory"!
I went ahead with "export DISPLAY=:0" and "firefox" anyway, expecting nothing, but in fact a feeble version of Firefox did appear on screen. No menus or anything so I couldn't see what version it was trying to be. I can still get that firefox by cd-ing to /chroot-wily in a terminal and typing "firefox," but that's pointless.

Anyway, I guess my question is, should I have given up the first time the "/bin/bash" thing complained? And why wasn't I still in chroot when I wanted to exit it? Did some of the stuff I was downloading go to the wrong places?
Post Reply