AmigaOne X1000 platform specific issues related to Linux only.
Post Reply
User avatar
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am


Post by kilaueabart »

Although I cannot get a normal Ubuntu screen (no icons whatsoever, just the AmigaOne picture -- history below if you haven't seen it yet), I have discovered I can do quite a bit there, either with Terminal (I wasn't aware of this until I googled for Ubuntu CLI commands) or Ctrl^Alt^F2.

I can get Firefox (gksudo firefox) and Scribus (gksudo scribus). Firefox comes up really bare, no tabs, no bookmarks, but I got on this forum with some googling. Unfortunately I seem to have changed my password since last listing it in my Documents password list. Fortunately Odyssey on OS4 remembers it (but my OS4 password list has it wrong too! I'll set a new one and write it down somewhere before I log out. Oops! Shot down again by needing my current password before I can change it :roll: ).

I'm not sure how much I can do from an Ubuntu terminal. I tried GParted (with gksudo, because it has a graphic interface). I was ignored, no warning or anything.

What I would really like to do now is copy my Home directory from /dev/sdb1 to /dev/sdb2. Then I could reinstall Ubuntu 12.04 from the install disk without losing a lot of rather important files. With OS4, it's simple to copy files from one partition to another. So far, I haven't been able to figure out how to do it in Ubuntu. Is it possible? Actually, I'd be happy just to copy to a USB card, but so far I haven't been able to connect with any USBdisk0:. I can't remember whether I tried Cf0:. That would be OK too.

I had a job to do with Scribus so I was in Ubuntu (12.04). About the time I finished the job, the little "Update" thing started waving at me, so I clicked it, and it said something about having 256(?) updates! I was shocked at the number but I started it anyway. Big mistake?

It went on for a very long time. At one point I went ahead and took my afternoon 20-minute nap. The screen had turned off by the time I woke up, and when I awakened it, there was nothing there but the background. I found that clicking on the screen brought up some kind of multiple-choice window, and one of the choices brought up the Settings window. About half of the places where there should be icons were blank, but clicking in the space brought up the sub-setting window that was named there (the names showed, just no icons). Nothing of any use to me.

I was able to get the CLI, where I did another step in the chroot Ubuntu MATE process, but I have no idea whether I can do anything useful there in the way of getting my proper Desktop back, the one with a bunch of program icons down the left-hand side and a useful thing (handy for shutting down, e.g.) in the upper right corner.

I was really in a pickle because I needed to use my Scribus product today. I could list the file in the CLI. I wondered if maybe the CLI could contact a flash drive, so I plugged one in. The CLI noticed something about a "[sdd]" but I could not cd to it, so even if I could remember the CLI copy command ("cp" maybe?) it wouldn't do any good. I removed the thumb drive and exited the CLI.

Back on the pretty, but bare, Ubuntu screen, I plugged the thumb drive in again and wow! It opened on-screen. And for some reason it gave me access to my desktop. I was able to copy the important file to the thumb drive and bring it to OS4 where I printed the necessary copies and will soon e-mail it to over two-hundred addressees. Very lucky.

Then I hopefully turned the machine off completely for a minute or two and rebooted Ubuntu. Got the same icon-less Ubuntu screen, the basic one that comes in the background when one installs from the DVD, but this time clicking the mouse on it had no result at all, nor did plugging in the flash drive.

I was still able to get the CLI. This time when I plugged the flash drive in, I got notified of some "[sde]" rather than "[sdd]," but still useless info.

I'm hoping someone will tell me how to fix this without completely reinstalling Ubuntu from the install DVD.
Post Reply