Forum does not remember my login

This is the place to ask if you have any issues with our forum system. These include questions about your account, PM's, login trouble, etc.
Post Reply
User avatar
abalaban
Beta Tester
Beta Tester
Posts: 456
Joined: Mon Dec 20, 2010 2:09 pm
Location: France
Contact:

Forum does not remember my login

Post by abalaban »

Using the URL support.amigaos.net the forum does not remember my login details, while using forum.hyperion-entertainment.biz it does. I'm currently using Chrome under Win7/64bits. It may also be the reason why each time I'm trying to visit the forum from Timberwolf I have to login again (even when I specified the "remember me" option).
Chrome does seem to block any cookie when using support.amigaos.net
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Forum does not remember my login

Post by ssolie »

The cookie won't work if you enter the site from support.amigaos.net. It only works if you use forum.hyperion-entertainment.biz. I haven't had time to look into how to fix it to work with both yet.
ExecSG Team Lead
User avatar
abalaban
Beta Tester
Beta Tester
Posts: 456
Joined: Mon Dec 20, 2010 2:09 pm
Location: France
Contact:

Re: Forum does not remember my login

Post by abalaban »

Ok at least it's a know issue. As support.amigaos.net is the URL used in the notification messages sent by the forum it would be good to have this one working while looking for a solution to have both working at the same time?
A workaround can be to have one just redirect to the second URL, using HTTP redirect or anything else?
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC
User avatar
Phantom
Posts: 73
Joined: Sun Jun 19, 2011 2:15 pm
Location: Colossal Cave, Valaii
Contact:

Re: Forum does not remember my login

Post by Phantom »

Yes I had the same problem and switched to forum.hyperion-entertainment.biz too.
To Be A True Adventurer, You Ought To Play Real Text Adventures
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Forum does not remember my login

Post by ssolie »

I think I finally fixed this problem.

Instead of support.amigaos.net being an alias I added an Apache rewrite rule to change that to forum.hyperion-entertainment.biz. The phpBB software we use for the forums does not allow multiple names for the same site and likely never will so this is probably the best workaround.
ExecSG Team Lead
Post Reply