How to optimize ENVVARS on SAM460ex Lite?

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
User avatar
fingus
Posts: 35
Joined: Sat Jun 18, 2011 6:10 pm

How to optimize ENVVARS on SAM460ex Lite?

Post by fingus »

I receive my Sam460ex Lite-Board, installed all Updates and now i need to speedup things on Uboot before Kickstart-Files are loaded.

My configuration of UBoot and Sam460 is:

SII3114-Sata-PCI:
Unit0: HDD
Unit1: DVD-RW
Unit2-3: no device plugged in

Radeon-HD-Card on PCI-e 4x

Onboard SATA-II not used
PCI-e 1x not used


Uboot is searching for Devices 2-3 on SII3114-Card, how to set ENVIRONMENT-Variable to prevent this?
Are there other ENVVAR-Optimations to speedup Boot a litte?

After Kickstart-Files are loaded the whole Boot-Speed of Workbench is okay (DMA on HDD is turned on, very fast!)

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by Spectre660 »

Try setting from cli
Nvsetvar s4sii_maxbus=1

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1447
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by nbache »

Spectre660 wrote:Try setting from cli
Nvsetvar s4sii_maxbus=1
Nope, he wrote that it's an SiI3114 card, and that the onboard SATA isn't used. So it should be:

Code: Select all

nvsetvar sii3114ide_maxbus=1
.

Best regards,

Niels

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by Spectre660 »

You are very right.
I must have been suffering from "AmigaLag" when I typed that. :oops:


nbache wrote:
Spectre660 wrote:Try setting from cli
Nvsetvar s4sii_maxbus=1
Nope, he wrote that it's an SiI3114 card, and that the onboard SATA isn't used. So it should be:

Code: Select all

nvsetvar sii3114ide_maxbus=1
.

Best regards,

Niels

User avatar
fingus
Posts: 35
Joined: Sat Jun 18, 2011 6:10 pm

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by fingus »

nbache wrote:
Spectre660 wrote:Try setting from cli
Nvsetvar s4sii_maxbus=1
Nope, he wrote that it's an SiI3114 card, and that the onboard SATA isn't used. So it should be:

Code: Select all

nvsetvar sii3114ide_maxbus=1
.

Best regards,

Niels
Its not working. The sam is still searching for devices 2 & 3.

Is there a typo?

Isn´t it siL3114?

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by Spectre660 »

Try the Nvsetvar s4sii_maxbus=1.
It works on my Sam440ep-flex.

User avatar
Slayer
Beta Tester
Beta Tester
Posts: 851
Joined: Tue Dec 21, 2010 4:19 am
Location: New Zealand

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by Slayer »

Just quickly I seem to recall the nvsetvar didn't require nor work if you included the = sign just try a space next time also type nvgetvar to make sure your syntax is remembered and is displayed correctly

Sorry I am still lounging around in Aussie Melbourne heat and nowhere near my machines just this lousy win7 worklap top! :o so this is all off the top of my head :|
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1447
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by nbache »

fingus wrote:Is there a typo?

Isn´t it siL3114?
No, that's a common mistake. The brand is called "Silicon Image", and the acronym consists of "Si" which is the chemical symbol for Silicon, followed by a capital "I" for Image. Therefore the device driver was also named with two i's, sii3114ide.device.

I'm not sure why it doesn't have the desired effect.

An alternative could be to set the sii3114ide_conf variable to 1200. This tells the system that there is a hard disk (1) on the first port, a CD/DVD (2) on the second, and nothing on the two others.

Best regards,

Niels

User avatar
fingus
Posts: 35
Joined: Sat Jun 18, 2011 6:10 pm

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by fingus »

Spectre660 wrote:Try the Nvsetvar s4sii_maxbus=1.
It works on my Sam440ep-flex.
This is working, thanks!

I typed it inside AmigaOS-Shell not Uboot. It seems this "=" thing just work with Shell but not Uboot.


And how to remove the non functional entry "sii3114ide_maxbus=1" from Uboot?
Is there a command to delete it?

User avatar
cha05e90
Posts: 89
Joined: Fri Jun 17, 2011 10:15 pm
Location: Germany
Contact:

Re: How to optimize ENVVARS on SAM460ex Lite?

Post by cha05e90 »

Just set the variable to nothing/empty.
X1000|II/G4|440ep|2000/060|2000/040|1000

Post Reply