AOne500/SAM460 unstable after update 5 [Solved]

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

AOne500/SAM460 unstable after update 5 [Solved]

Post by morpa »

EDIT: Heavily edited post as i wanted to gather everything i tried in one place

Hello all!
I just bought me an (barely) used a1-500/SAM 460ex with the following specs:
AmigaOne 500:
SAM460ex/1.15 GHz,
2 GB RAM,
500 GB HDD,
DVD-RW Drive,
SATA Controller SiI3512 PCI (2 ports), (now 3114, 4 ports),
Amiga one keyboard and mouse. AmigaOS 4.1 OEM (on CD-ROM and HDD)
Graphics Card: Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI


The problem is, it was heavy unstable when Kickstarts/kernel from update 5. I sometimes lose the partitions, (and sometimes get some DSI:s, some freezes)
I compared the files in kickstarts that were different between update 4 and update 5, and replaced them one by one to find the unstable one. When i use "kickstarts/kernel" from update 4 in update 5 everything runs ok and stable,

I tried:
* Clean install(s) - up until update 5 everything seems to work fine.
* Switching the cd and hd sata places, didn't help. Tried using only the sxx3512, that and the MB-sata, and so on.
* Installing radeon driver 0.53
* Did'nt install any thirdparty software, except, owb, ibrowse, netsurf timberwolf.
* I run SFS02. I also totally wiped harddrive and RGB. and tried *SFS - (within 128 gb limit - no difference )* FFS - seemed to work slightly better but were unbearbly slow, so back to sfs2
* Verified that jumpers on motherboard J37 to J39 are as set as in manual.(open,closed,closed)
* Verified that the jumper for Onboard SATA2/PCI are open.(Pci)
* Verified that the filesystem SFS02 has blocksize 512 and buffer 1000 (as manual says)
* Replaced 2032 battery and put in a new sata cable, just in case.
* Deleted ENV/ENVARC:Rhingioserver.prefs files
* Verified that uboot is the latest (January xxxx 12) something.
* Adding extra drives and usbstuff to see if the PSU had any problems
* Tried to examine if the problems are heatreleated , which it doesn't seem to be (and then earlier updates would behave the same)
* Tried another SATA card - 3114 (No difference)
* Ran some memorytester programs - memtester http://os4depot.net/index.php?function= ... tester.lzx etc. They showed memory OK.
* Tried another SATA drive (SSD). No difference.
* Made sure the archives of updates were'nt corrupted. Redownload, etc.
* Tried a heavier PSU - (450w - http://www.silverstonetek.com/product.php?pid=342) . No difference
* Tried exprimenting with different buffers, using SFSQuery to look for good cache values. Tried DH1: with JXFS. Nope. (block:512,masks, buffers checked)
* Then tried another SATA-harddrive: 2 partitions, 10 gb SFS, 40 gb jxfs.Nope. (block:512,masks, buffers checked)
* update 6 applied.


AND FINALLY: Changed memory module and it WORKS MUCH BETTER NOW!! S

See you at os4depot:)
Last edited by morpa on Wed Dec 12, 2012 8:57 pm, edited 28 times in total.
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1463
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: A1500 unstable after update 5 - Lot's of DSI's

Post by nbache »

What is Rhinoserver? And can you post a crash log (use the "Hidden" tags, please).

Best regards,

Niels

User avatar
Aslak3
Posts: 9
Joined: Mon Aug 20, 2012 10:20 pm

Re: A1500 unstable after update 5 - Lot's of DSI's

Post by Aslak3 »

nbache wrote:What is Rhinoserver? And can you post a crash log (use the "Hidden" tags, please).
It is the notification server (the thing which puts messages on the scren for new emails etc).

I had/have issues with networking. Not DSIs though; but rather network death which showed itself as "no buffer space" when doing pings etc. I have yet to get to the bottom of it, but luckily it only happens every few weeks.

Maybe your problems are heat-related?

Lawrence

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: A1500 unstable after update 5 - Lot's of DSI's

Post by morpa »

EDIT: I just edited the first post, to gather all i tried so far, as it might help someone else looking for a problem-checklist. Also updated the questions. Thanks for answers so far!!
Last edited by morpa on Wed Oct 31, 2012 10:17 pm, edited 5 times in total.
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1463
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: A1500 unstable after update 5 - Lot's of DSI's

Post by nbache »

Aslak3 wrote:
nbache wrote:What is Rhinoserver?
It is the notification server (the thing which puts messages on the scren for new emails etc).
Aha ... RinghioServer. Sorry, didn't think of that one.

Best regards,

Niels

User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: A1500/SAM460 unstable after update 5 - DSI

Post by Elwood »

morpa wrote: The problem is, it's heavy unstable when Kickstarts/kernel from update 5. I get some DSI:s, some freezes, and sometimes it doesn't seem to find the partitions.
This looks like the instability I had. Read this.

Also can you try without the SiI3512? so connect the HD to the internal SATA port but keep the DVD connected at least to the PSU.
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: A1500/SAM460 unstable after update 5 - DSI

Post by morpa »

Thanks for the hint Elwood. Tried adding a drive and usb-stuff, but it didn't help for me. Back to the kickstarts/kernel file from update 4.--
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: AOne500/SAM460 unstable after update 5

Post by Elwood »

Do you have a spare memory module you can try? Yes I know it works with an old kernel but still...
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

Elwood wrote:Do you have a spare memory module you can try? Yes I know it works with an old kernel but still...
Don't have one at the moment, but i'll try to see if i can get hold of one. Meanwhile - Changed Satacard to a 3114 (no difference), and also ran memtester (http://os4depot.net/index.php?function= ... tester.lzx) (memtester showed no probs).
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

Did you try to download the update 5 archive again and install ? .

morpa wrote:
Elwood wrote:Do you have a spare memory module you can try? Yes I know it works with an old kernel but still...
Don't have one at the moment, but i'll try to see if i can get hold of one. Meanwhile - Changed Satacard to a 3114 (no difference), and also ran memtester (http://os4depot.net/index.php?function= ... tester.lzx) (memtester showed no probs).

Post Reply