First keyboard press eaten...

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
User avatar
cha05e90
Posts: 89
Joined: Fri Jun 17, 2011 10:15 pm
Location: Germany
Contact:

First keyboard press eaten...

Post by cha05e90 »

Hello,

I suppose this one might already reported somewhere, so just for the record: On my SAM440ep (mini), UBoot 1.3.1b, the first keyboard press (A-Eon AmigaOne USB keyboard) after booting OS4.1 Update 2 is "eaten"/ignored.
X1000|II/G4|440ep|2000/060|2000/040|1000

xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: First keyboard press eaten...

Post by xenic »

The same thing happens on my SAM Flex 800MZ OS4.1u2 also. It seems like it happens at other times too but I haven't been able to consistantly reproduce occurances after the initial reboot occurance. It's a minor problem for me.
CORRECTION: It's not the first key that gets eaten on my system. It I hold down the first character I enter after a reboot it doesn't repeat. The first char I enter after a boot or reboot won't repeat if the key is held down. Sorry for the erronious report in my initial response.
AmigaOne X1000 with 2GB memory - OS4.1 FE

User avatar
nubechecorre
Posts: 69
Joined: Fri Jun 17, 2011 11:28 pm
Location: Sanremo
Contact:

Re: First keyboard press eaten...

Post by nubechecorre »

that bug happened also here on my sam, but then it disappeared.. i don't know why and how it disappeared but it did.. sorry no much help :(
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse

Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: First keyboard press eaten...

Post by Spectre660 »

Is this not an Issue with Uboot ?
Same thing happens when you enter the Uboot shell .

User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: First keyboard press eaten...

Post by Elwood »

cha05e90 wrote:I suppose this one might already reported somewhere, so just for the record: On my SAM440ep (mini), UBoot 1.3.1b,...
Are you sure it's Uboot 1...b ? Version 1...d can be found here: http://www.acube-systems.biz/index.php? ... ware&pid=1

There was an OS4 bug reported and fixed in uhci.usbhcd 53.9
I checked and in Update2 there is no new uhci.usbhcd. Which version do you have?
Last edited by Elwood on Wed Jun 22, 2011 7:59 am, edited 1 time in total.
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester

Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: First keyboard press eaten...

Post by Spectre660 »

14.System:> version System:Kickstart/uhci.usbhcd
uhci.usbhcd 53.7

User avatar
fingus
Posts: 35
Joined: Sat Jun 18, 2011 6:10 pm

Re: First keyboard press eaten...

Post by fingus »

cha05e90 wrote:Hello,

I suppose this one might already reported somewhere, so just for the record: On my SAM440ep (mini), UBoot 1.3.1b, the first keyboard press (A-Eon AmigaOne USB keyboard) after booting OS4.1 Update 2 is "eaten"/ignored.
I can confirm it.

User avatar
Olrick
Posts: 70
Joined: Mon Mar 07, 2011 3:24 pm
Location: Rennes, France

Re: First keyboard press eaten...

Post by Olrick »

I used to have the same trouble but I didn't notice when it disappeared.
All I can say is that my uhci.usbhcd version is 53.7 and my Bios is 1.3.1d.
Have you checked your BIOS version ?
God grant me the Serenity to accept the things I cannot change; Courage to change the things I can; and Wisdom to know the difference.

User avatar
cha05e90
Posts: 89
Joined: Fri Jun 17, 2011 10:15 pm
Location: Germany
Contact:

Re: First keyboard press eaten...

Post by cha05e90 »

Elwood wrote:Are you sure it's Uboot 1...b ? Version 1...d can be found here: http://www.acube-systems.biz/index.php? ... ware&pid=1

There was an OS4 bug reported and fixed in uhci.usbhcd 53.9
I checked and in Update2 there is no new uhci.usbhcd. Which version do you have?
My uhci.usbhcd version is 53.7. And, yes, I know there are newer UBoot versions, but I only flash a new version if I really, really have to. According to the readme's from ACube there seems no special fix for this "eat-first-keypress" problem present in UBoot - AFAIK.

If someone can confirm that a UBoot update will cure this problem, I'll consider it.
X1000|II/G4|440ep|2000/060|2000/040|1000

Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: First keyboard press eaten...

Post by Spectre660 »

Its is gone with U-Boot 1.3.1d on a Sam flex. From the Uboot Shell and from OS 4.1 cli and from Notepad .

Post Reply