Problem with Slimline CDRW/DVD Drives and MicroA1

A forum for AmigaOne XE and MicroA1-C specific issues.
Post Reply
Mikey_C
Posts: 23
Joined: Mon Oct 10, 2011 6:38 pm

Problem with Slimline CDRW/DVD Drives and MicroA1

Post by Mikey_C »

Hi Guys

I am looking for some help in solving this puzzle.

(in short, I had to rehouse my MicroA1 into a new case which contains a
slimline laptop drive and is connected via an interface which converts a Laptop ide socket, to a normal ide 2.5")

The HD is connected via the MicroA1 Primary 3.5" IDE Interface.
the CD/DVD Drive is connected via the secondary 2.5" Interface.

The problem I have is that I have tried two drives on being a Sony Model
No. CRX880A and a TSSTCor Prod Drive. (In either case, the disc will not
boot as it keeps coming up with an Error "Unknown Sense Key 05 ASC 24 ASCQ
00=4096 <-- 4096 appears in red.

I am using uboot 1.2.0

If anyone has any ideas as to how I can get these slimline cd rw/dvd rom
drives to work, i'd be most grateful

Cheers

Mikey C

Mikey_C
Posts: 23
Joined: Mon Oct 10, 2011 6:38 pm

Re: Problem with Slimline CDRW/DVD Drives and MicroA1

Post by Mikey_C »

I take it I am on my own on this one huh?

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1426
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Problem with Slimline CDRW/DVD Drives and MicroA1

Post by nbache »

Mikey_C wrote:I take it I am on my own on this one huh?
Well, you're a betatester, so there's still Bugzilla. Maybe a relevant developer sees it there ...?

Best regards,

Niels

Mikey_C
Posts: 23
Joined: Mon Oct 10, 2011 6:38 pm

Re: Problem with Slimline CDRW/DVD Drives and MicroA1

Post by Mikey_C »

Yes, I could post it there but unfortunately I think the problem lies in U-Boot and since no one is likely to update u-boot for such an old machine, I think I may as well call it a day.

Cheers anyway Sir

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1426
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Problem with Slimline CDRW/DVD Drives and MicroA1

Post by nbache »

Mikey_C wrote:Yes, I could post it there but unfortunately I think the problem lies in U-Boot and since no one is likely to update u-boot for such an old machine, I think I may as well call it a day.
Well, it sounds like the first step would be to find someone who could explain the error message and possibly suggest what could be done to get rid of it. And that someone might be someone who has experience in the IDE drivers etc.

I don't know enough about the MicroA1 myself to give any better suggestions. All I can add is that I have a Panasonic slimline DVD-RW/RAM burner in my Sam440ep (together with a 2,5" SSD disk), and that works with no such problems. But these are SATA, of course.

Best regards,

Niels

xenic
Posts: 1164
Joined: Sun Jun 19, 2011 12:06 am

Re: Problem with Slimline CDRW/DVD Drives and MicroA1

Post by xenic »

The laptop IDE header (2.5") was a serious design flaw in my view. It lacks a keying slot and elevated edge to prevent improper insertion of the ribbon connector. If you're not careful you can insert connector in reverse or miss the alignment by one set of pins. I fried the original DVD drive that was included with my µA1 with incorrect alignment but Software Hut was kind enough to replace it. The last time I opened my µA1 to clean the CPU Fan etc, I did it again but this time the board must have been damaged so that header no longer works. I found a longer ribbon cable with 2 connectors and connected the DVD drive as the second drive on the primary port. It works but I won't be able to connect a second hard drive anymore. Since I'm now using my SAM and just keep the µA1 in the closet as a backup, I'm not worried about the limitation. You too might want to try the DVD as the second drive on your primary IDE header (3.5") to see if you can get it working.
AmigaOne X1000 with 2GB memory - OS4.1 FE

Post Reply