Scripts don't abort properly in 3.1.4

A forum for Classic Amiga specific support issues.
fx81
Posts: 1
Joined: Fri Nov 02, 2018 6:59 am

Scripts don't abort properly in 3.1.4

Post by fx81 »

When a program quits with an errorcode in a script - the script doesn't stop running like it should even with failat set lower than the returncode. So failat is basically doing nothing in 3.1.4.

Here's an image trying to illustrate the issue, setresult is a simple program a friend wrote that basically just quits with the argument given as returncode.

Image
NinjaCyborg
Posts: 15
Joined: Wed Oct 10, 2018 11:28 pm

Re: Scripts don't abort properly in 3.1.4

Post by NinjaCyborg »

You'll probably get a response if you post it at amiga.org and alert ThoR to it. Or just email ThoR
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Scripts don't abort properly in 3.1.4

Post by Raziel »

@NinjaCyborg

Why?
This is the Hyperion support forums...he should get a response from the main devs just fine here.
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
NinjaCyborg
Posts: 15
Joined: Wed Oct 10, 2018 11:28 pm

Re: Scripts don't abort properly in 3.1.4

Post by NinjaCyborg »

Considering ThoR last posted here like, 18 months ago, and posts on forum amiga every day, stop wasting my time with your irrelevant reply please.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Scripts don't abort properly in 3.1.4

Post by Raziel »

@NinjaCyborg

Wow, no manners seem to be your credo.

My reply was perfectly valid, if you have nothing better to do than to tell people off, you'd better find a new medication
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
NinjaCyborg
Posts: 15
Joined: Wed Oct 10, 2018 11:28 pm

Re: Scripts don't abort properly in 3.1.4

Post by NinjaCyborg »

So you butt in to a conversation with nothing useful to say, give bad advice, and then somehow I'm the rude one when I tell it how it is?
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Scripts don't abort properly in 3.1.4

Post by Raziel »

NinjaCyborg wrote:So you butt in to a conversation with nothing useful to say, give bad advice, and then somehow I'm the rude one when I tell it how it is?
Yes
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
kolla
Posts: 19
Joined: Wed Oct 24, 2018 10:38 am

Re: Scripts don't abort properly in 3.1.4

Post by kolla »

I can confirm that shell 46 is whack... this is rather serious and fundamental - how on earth could this pass betatesting??
Image

I am back on 45.39 and all is good again.
Image

Can we expect Hyperion to fix this broken kickstart? Probably not.
Gulliver
Posts: 27
Joined: Fri Sep 28, 2018 11:29 pm

Re: Scripts don't abort properly in 3.1.4

Post by Gulliver »

Hi kolla,

Please dont be so harsh on the 3.1.4 team.

The entire team, was, and still is a very small group of people and the work carried out by us was extremely extensive given the size and manpower available.
We had to face bugs dating back to 1993 (and many times even before the nineties), and mess up with ancient programing languages like BCPL and a lot of compiler specific dependencies which were not documented or evident at first sight. The work we did was truly monumental, and I am not saying this because I want to brag, I am telling you this so that you understand and apreciate all the hard work we did for our hobby, which I am sure is yours too.

That said, I understand and respect that you particularly have lots of different points of view regarding AmigaOS or us as a team, but please be empathic and more kind when addressing them as we are all people trying to push our hobby a little bit forward and sometimes being so harsh or bitter against any of us, certainly only helps to kill our motivation.

Back to topic (sorry for my long rant):

The bug has already been reported internally. It will be addressed in the upcoming update fix to 3.1.4 which will be released in the near future (free of charge for 3.1.4 customers).

We are still collecting and fixing bugs, as despite what you could think, we had a surprisingly low occurence of them, despite our forecasts.

It might probably be addressed as a fix performed by a new version of SetPatch.

Thank you for your report fx81.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Scripts don't abort properly in 3.1.4

Post by Raziel »

@Gulliver
We are still collecting and fixing bugs, as despite what you could think, we had a surprisingly low occurence of them, despite our forecasts.
How are you collecting bugs?
Is there a central place where users can report them or are you doing manual forum scans?
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Post Reply