AmiCygnix & Update 4

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

AmiCygnix & Update 4

Post by Nicsoft »

While AmigaOS 4.1 and all the AmigaOS programs runs way much better with Update 4...
Many of my AmiCygnix programs won't start any more (although AmiCygnix itself seems to run OK)! :?
Any suggestions!? I find it very strange (Computer = Sam 460 with 2GB RAM)...

User avatar
tommysammy
Posts: 946
Joined: Mon Dec 20, 2010 9:03 pm
Location: Isselburg,Germany
Contact:

Re: AmiCygnix & Update 4

Post by tommysammy »

Install it again, maybe there are missing two libraries ;)
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network

User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

Re: AmiCygnix & Update 4

Post by Nicsoft »

tommysammy wrote:Install it again, maybe there are missing two libraries ;)
All the AmiCygnix libraries are there... Perhaps AmiCygnix needs an update, to be fully compatible with AmigaOS 4.1 Update 4!? :?

User avatar
tommysammy
Posts: 946
Joined: Mon Dec 20, 2010 9:03 pm
Location: Isselburg,Germany
Contact:

Re: AmiCygnix & Update 4

Post by tommysammy »

Nicsoft wrote:
tommysammy wrote:Install it again, maybe there are missing two libraries ;)
All the AmiCygnix libraries are there... Perhaps AmiCygnix needs an update, to be fully compatible with AmigaOS 4.1 Update 4!? :?
No it works here fine under UPDATE 4 and 5
Have you installed threads.library and sysvipc.library?
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network

User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

Re: AmiCygnix & Update 4

Post by Nicsoft »

threads.library and sysvipc.library are still present in SYS:Libs/. Just as before updating to Update 4. Strange...

mpiva
Posts: 35
Joined: Sun Jul 03, 2011 10:05 pm

Re: AmiCygnix & Update 4

Post by mpiva »

Just tried AbiWord, Gnumeric, and Gimp on my Sam460ex with Update 4 and they all seem to load fine. Sorry, it must be something with your system. Can you say whcih specific programs aren't loading properly? What happens; do they crash or just refuse to load?

User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

Re: AmiCygnix & Update 4

Post by Nicsoft »

Before Update 4 (on Update 2 & 3) all my AmiCygnix programs worked just fine...

The programs that does start, like before Update 4 (= works fine):
bitmap
GPicView Image Viewer
pixmap
Xpdf
All the programs in the "Settings" menu
All the programs in the "System Tools" menu
NetSurf
AbiWord
All the programs in the "Accessories" menu

The programs that simply refuses to start, under Update 4 (= they doesn't crash though):
All the programs in the "Game" menu = [ amicygnix-games.lha ] that is.
Gimp
Gnumeric

User avatar
tommysammy
Posts: 946
Joined: Mon Dec 20, 2010 9:03 pm
Location: Isselburg,Germany
Contact:

Re: AmiCygnix & Update 4

Post by tommysammy »

Nicsoft wrote:Before Update 4 (on Update 2 & 3) all my AmiCygnix programs worked just fine...

The programs that does start, like before Update 4 (= works fine):
bitmap
GPicView Image Viewer
pixmap
Xpdf
All the programs in the "Settings" menu
All the programs in the "System Tools" menu
NetSurf
AbiWord
All the programs in the "Accessories" menu

The programs that simply refuses to start, under Update 4 (= they doesn't crash though):
All the programs in the "Game" menu = [ amicygnix-games.lha ] that is.
Gimp
Gnumeric

Have you this in your userstartup?

;BEGIN Cygnix
assign Cygnix: "Work:AmiCygnix"
execute Cygnix:s/Cygnix-Startup
;END Cygnix
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network

User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

Re: AmiCygnix & Update 4

Post by Nicsoft »

tommysammy wrote:
Have you this in your userstartup?

;BEGIN Cygnix
assign Cygnix: "Work:AmiCygnix"
execute Cygnix:s/Cygnix-Startup
;END Cygnix
Yes! And I reinstalled everything as previously suggested...
(Then having to redo my settings, all over again)

User avatar
Nicsoft
Posts: 29
Joined: Fri Jun 17, 2011 11:02 pm

Re: AmiCygnix & Update 4

Post by Nicsoft »

Problem solved! :)

Trying a lower screen-resolution solved the problem!
Update 4 stopped those programs (memory issue? / graphips-driver issue?) with my present screen-resolution...
Conclusion. Running AmiCygnix in a lower resolution made the programs start again.

Post Reply