KVM switch has stopped working with Update 4

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
mpiva
Posts: 35
Joined: Sun Jul 03, 2011 10:05 pm

KVM switch has stopped working with Update 4

Post by mpiva »

I just installed Update 4. It installed with no problems, but when my Sam460ex restarted, my mouse and keyboard wouldn't work. Upon further investigation, I discovered it's actually my KVM switch that Update 4 doesn't like. My IOGEAR KVM switch with Logitech Wireless keyboard/mouse worked perfectly on Update 2; it sort of worked on Update 3 (if I disabled EHCI, which I needed to do anyway to get the wireless keyboard/mouse to work at all), and it doesn't work at all on Update 4 (but at least my wireless keyboard/mouse finally work with EHCI on but only if plugged directly into a USB port).

I've tried plugging my wireless keyboard/mouse as well as a regular wired keyboard into my KVM switch. Either way, it seems to recognize the KVM switch as a "HUB" but not anything that gets plugged into it. It just says the attachment failed.

User avatar
djrikki
Posts: 138
Joined: Fri Jun 17, 2011 10:21 pm
Location: Grimsby, Lincolnshire, UK
Contact:

Re: KVM switch has stopped working with Update 4

Post by djrikki »

In the Update 4 installation guide it says that OHCI has been disabled on SAM 460s due to a silicon bug. Perhaps that is relevant to your circumstance?

User avatar
ChrisH
Beta Tester
Beta Tester
Posts: 920
Joined: Mon Dec 20, 2010 9:09 pm
Contact:

Re: KVM switch has stopped working with Update 4

Post by ChrisH »

OS4's USB seems to be a bit "picky" about hubs (esp Update 3), at least on the Sam440, but I never had it not working at all (I have a KVM too). Hopefully some beta-tester has a Sam460, and so can test USB hubs.

mpiva
Posts: 35
Joined: Sun Jul 03, 2011 10:05 pm

Re: KVM switch has stopped working with Update 4

Post by mpiva »

I'm looking at replacing my IOGEAR KVM switch now that Update 4 has rendered it useless. Does anyone have any experience with the DLINK KVM 222 on an AmigaOS4.1.4 system?

chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Re: KVM switch has stopped working with Update 4

Post by chris »

ChrisH wrote:OS4's USB seems to be a bit "picky" about hubs (esp Update 3)
Update 4 is no better in my experience. I have to keep un/re-plugging my keyboard to get it and the inbuilt hub + devices to work. After a while it just stops. Sometimes it only works for a matter of seconds.

Sometimes the keybaord works but nothing attached to it. Often it's the other way round. I've just got the situation now that the mouse attached to the back is refusing to work for more than a couple of seconds, no matter how much reconnecting I do of it and the keyboard.

Here is the usb.log in case it helps:
Hidden Text - Click to Show :
I: [10:48:03] USB stack | | ==========
I: [10:48:03] USB stack | | USB System Software Task started
I: [10:48:03] USB stack | | Starting HCDs...
I: [10:48:03] USB stack | New Fkt | Fkt 0x5FF8FDC0 at level -1
I: [10:48:03] USB stack | New Fkt | Fkt 0x5FF8FE60 at level 0
I: [10:48:04] USB stack | New Fkt | Fkt 0x5FF8FF00 at level -1
I: [10:48:04] USB stack | New Fkt | Fkt 0x5FDF7010 at level 0
I: [10:48:04] USB stack | New Fkt | Fkt 0x5FDF70B0 at level -1
I: [10:48:04] USB stack | New Fkt | Fkt 0x5FDF7150 at level 0
I: [10:48:04] USB stack | | ...HCDs started.
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FF8FE60 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FDF7010 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FDF7150 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FF8FE60 initialized
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FDF7010 initialized
I: [10:48:04] USB Fkt Init | Init Fkt | Fkt 0x5FDF7150 initialized
I: [10:48:04] hub.usbfd | HUB | Hub "Rear Roothub (ohci.usbhcd/0)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [10:48:04] hub.usbfd | HUB | Hub "Rear Roothub (ehci.usbhcd/0)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [10:48:04] hub.usbfd | HUB | Hub "Front Roothub (ohci.usbhcd/1)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [10:48:04] hub.usbfd | HUB | All ports are empty
I: [10:48:04] hub.usbfd | HUB | All ports are empty
I: [10:48:04] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [10:48:04] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [10:48:05] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [10:48:05] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [10:48:05] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [10:48:05] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [10:48:05] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [10:48:05] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [10:48:05] USB stack | New Fkt | Fkt 0x5FDF73D0 at level 1
I: [10:48:05] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [10:48:05] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [10:48:05] hub.usbfd | HUB | Driver Running
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF73D0 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF73D0 initialized
I: [10:48:05] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [10:48:05] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [10:48:05] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [10:48:05] USB stack | New Fkt | Fkt 0x5FDF7510 at level 1
I: [10:48:05] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF7510 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF7510 initialized
I: [10:48:05] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [10:48:05] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [10:48:05] hub.usbfd | HUB | All ports are empty
I: [10:48:05] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [10:48:05] USB stack | New Fkt | Fkt 0x5FDF7650 at level 2
I: [10:48:05] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF7650 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [10:48:05] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF7650 initialized
I: [10:48:05] hub.usbfd | Hub port | Device at port 3 of hub "Hub in Apple Extended USB Keybo" is full-speed.
I: [10:48:05] USB stack | New Fkt | Fkt 0x5FDF76F0 at level 2
I: [10:48:05] hub.usbfd | HUB | Device on hub port 3 successfully added.
I: [10:48:05] hub.usbfd | HUB | Driver Running
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF76F0 is {Vendor: 0x05AC, Product: 0x020C, Class: 00.00}
I: [10:48:05] USB Fkt Init | Init Fkt | Fkt 0x5FDF76F0 initialized
W: [10:48:05] USB FD fkt start | BindInterfaceDriver | No interface driver of fkt 0x5FDF76F0/ifc 0x5FD76140 {Class 03.00} has been found
I: [10:48:05] USB FD ifc start | Sys_EndInitialAttachmentPhase | Initial USB Attachment Phase terminated
I: [10:48:15] USB stack Process | | USB System Software Process started.
I: [10:48:15] USB stack Process | | Reading FD descriptors...
I: [10:48:15] USB stack Process | | ...FD infos read
I: [10:48:15] USB stack Process | Rebind FD | Weak FD "bootmouse.usbfd" for Ifc 0x5FE33E50 is being preempted.
I: [10:48:15] USB stack Process | Rebind FD | Weak FD "bootkeyboard.usbfd" for Ifc 0x5FD76040 is being preempted.
I: [10:48:15] USB stack Process | | Starting HCDs...
I: [10:48:15] USB stack Process | | ...HCDs started.
I: [10:48:15] USB stack Process | | USB stack fullbooted
I: [10:48:15] USB FD fkt start | Sys_EndInitialAttachmentPhase | Initial USB Attachment Phase terminated
I: [10:48:15] hid.usbfd | HID driver | USB Interface bound
I: [10:48:15] hid.usbfd | HID driver | USB Interface bound
I: [10:48:15] hid.usbfd | HID driver | USB Interface bound
I: [10:48:15] hid.usbfd | HID Server | Interrupt req. returned -33
I: [11:28:32] hub.usbfd | HUB | Status Change Pipe error -33
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hub.usbfd | HUB | Status Change Pipe error -35
I: [11:28:32] hub.usbfd | HUB | Detaching Function removed from hub port 2
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:32] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:28:33] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:28:33] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:28:33] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [11:28:33] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [11:28:33] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [11:28:33] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [11:28:33] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [11:28:33] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:28:34] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [11:28:34] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [11:28:34] USB stack | New Fkt | Fkt 0x5fdf7510 at level 1
I: [11:28:34] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [11:28:34] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [11:28:34] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [11:28:34] USB stack | New Fkt | Fkt 0x5fdf75b0 at level 1
I: [11:28:34] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 initialized
I: [11:28:34] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 initialized
I: [11:28:34] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [11:28:34] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:28:34] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:28:34] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 2
I: [11:28:34] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:28:34] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:28:34] hub.usbfd | HUB | All ports are empty
I: [11:28:34] hid.usbfd | HID driver | USB Interface bound
I: [11:28:34] hub.usbfd | Hub port | Device at port 3 of hub "Hub in Apple Extended USB Keybo" is full-speed.
I: [11:28:34] USB stack | New Fkt | Fkt 0x5c2e0330 at level 2
I: [11:28:34] hub.usbfd | HUB | Device on hub port 3 successfully added.
I: [11:28:34] hub.usbfd | HUB | Driver Running
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 is {Vendor: 0x05AC, Product: 0x020C, Class: 00.00}
I: [11:28:34] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 initialized
I: [11:28:34] hid.usbfd | HID driver | USB Interface bound
I: [11:28:34] hid.usbfd | HID driver | USB Interface bound
I: [11:38:48] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:56] hub.usbfd | HUB | Status Change Pipe error -33
I: [11:38:56] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:56] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:56] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:56] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:56] hub.usbfd | HUB | Status Change Pipe error -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:38:57] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:38:57] hub.usbfd | HUB | Detaching Function removed from hub port 2
I: [11:38:59] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:38:59] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [11:38:59] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [11:38:59] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [11:38:59] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [11:38:59] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [11:38:59] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:38:59] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [11:38:59] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [11:38:59] USB stack | New Fkt | Fkt 0x5fdf7510 at level 1
I: [11:38:59] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:38:59] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [11:38:59] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 initialized
I: [11:38:59] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [11:38:59] USB stack | New Fkt | Fkt 0x5fdf75b0 at level 1
I: [11:38:59] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [11:38:59] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [11:38:59] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [11:38:59] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [11:38:59] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 initialized
I: [11:38:59] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [11:39:00] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:00] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:39:00] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 2
I: [11:39:00] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:00] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:00] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:39:00] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:39:00] hid.usbfd | HID driver | USB Interface bound
I: [11:39:00] hub.usbfd | Hub port | Device at port 3 of hub "Hub in Apple Extended USB Keybo" is full-speed.
I: [11:39:00] USB stack | New Fkt | Fkt 0x5c2e0330 at level 2
I: [11:39:00] hub.usbfd | HUB | Device on hub port 3 successfully added.
I: [11:39:00] hub.usbfd | HUB | Driver Running
I: [11:39:00] hub.usbfd | HUB | All ports are empty
I: [11:39:00] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 is {Vendor: 0x05AC, Product: 0x020C, Class: 00.00}
I: [11:39:00] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 initialized
I: [11:39:00] hid.usbfd | HID driver | USB Interface bound
I: [11:39:00] hid.usbfd | HID driver | USB Interface bound
I: [11:39:01] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:07] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:39:11] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:11] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:39:11] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 2
I: [11:39:11] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:11] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:39:11] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:39:11] hid.usbfd | HID driver | USB Interface bound
I: [11:39:14] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:17] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:17] hub.usbfd | HUB | Status Change Pipe error -35
I: [11:39:17] hub.usbfd | HUB | Status Change Pipe error -33
I: [11:39:17] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:39:17] hub.usbfd | HUB | Detaching Function removed from hub port 2
I: [11:39:19] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:20] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [11:39:20] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [11:39:20] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [11:39:20] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [11:39:20] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [11:39:20] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:20] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [11:39:20] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [11:39:20] USB stack | New Fkt | Fkt 0x5fdf75b0 at level 1
I: [11:39:20] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 initialized
I: [11:39:20] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [11:39:20] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [11:39:20] USB stack | New Fkt | Fkt 0x5fdf7510 at level 1
I: [11:39:20] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [11:39:20] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 initialized
I: [11:39:20] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [11:39:20] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:20] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:39:20] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 2
I: [11:39:20] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:20] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:39:20] hid.usbfd | HID driver | USB Interface bound
I: [11:39:20] hub.usbfd | Hub port | Device at port 3 of hub "Hub in Apple Extended USB Keybo" is full-speed.
I: [11:39:20] USB stack | New Fkt | Fkt 0x5c2e0330 at level 2
I: [11:39:20] hub.usbfd | HUB | Device on hub port 3 successfully added.
I: [11:39:20] hub.usbfd | HUB | Driver Running
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 is {Vendor: 0x05AC, Product: 0x020C, Class: 00.00}
I: [11:39:20] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 initialized
I: [11:39:20] hub.usbfd | HUB | All ports are empty
I: [11:39:20] hid.usbfd | HID driver | USB Interface bound
I: [11:39:20] hid.usbfd | HID driver | USB Interface bound
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hub.usbfd | HUB | Status Change Pipe error -33
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hub.usbfd | HUB | Status Change Pipe error -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hid.usbfd | HID Server | Interrupt req. returned -35
I: [11:39:24] hub.usbfd | HUB | Detaching Function removed from hub port 2
I: [11:39:24] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:39:26] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:27] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [11:39:27] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [11:39:27] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [11:39:27] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [11:39:27] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [11:39:27] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:27] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [11:39:27] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [11:39:27] USB stack | New Fkt | Fkt 0x5fdf75b0 at level 1
I: [11:39:27] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 initialized
I: [11:39:27] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [11:39:27] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [11:39:27] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 1
I: [11:39:27] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [11:39:27] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:39:27] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [11:39:27] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:27] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:39:27] USB stack | New Fkt | Fkt 0x5fdf7510 at level 2
I: [11:39:27] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:27] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:39:27] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 initialized
I: [11:39:27] hub.usbfd | HUB | Reset request for port 3 failed (error -35)
W: [11:39:27] hub.usbfd | HUB | Resetting hub port 3 and trying again
I: [11:39:27] hub.usbfd | HUB | Reset request for port 3 failed (error -35)
W: [11:39:27] hub.usbfd | HUB | Resetting hub port 3 and trying again
I: [11:39:27] hub.usbfd | HUB | Reset request for port 3 failed (error -32)
W: [11:39:27] hub.usbfd | HUB | Resetting hub port 3 and trying again
I: [11:39:27] hub.usbfd | HUB | Reset request for port 3 failed (error -32)
W: [11:39:27] hub.usbfd | HUB | Hub port 3 attachment was not possible
E: [11:39:27] hub.usbfd | HUB | Resetting port 3 of hub "Hub in Apple Extended USB Keybo" failed. Device adding aborted
E: [11:39:27] hid.usbfd | DoControlXfer | Destall failed: io_Error = -32
E: [11:39:27] hid.usbfd | HID driver | Setup error: Error reading HID Report Descriptor (-32)
I: [11:39:27] hid.usbfd | HID driver | Failed to load ReportDescriptor
E: [11:39:27] hid.usbfd | HID driver | Interface binding failed. Error -32
I: [11:39:27] hub.usbfd | HUB | Unable to reset hub port.
Device adding aborted.
I: [11:39:27] hub.usbfd | HUB | Driver Running
I: [11:39:27] hub.usbfd | HUB | All ports are empty
I: [11:39:32] hub.usbfd | HUB | Status Change Pipe error -33
I: [11:39:32] hub.usbfd | HUB | Status Change Pipe error -35
I: [11:39:32] hub.usbfd | HUB | Detaching Function removed from hub port 1
I: [11:39:32] hub.usbfd | HUB | Detaching Function removed from hub port 2
I: [11:39:37] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:38] EHCI Controller Task Unit 0 | EHCI | Device at port 0 is a fullspeed device. Giving up ownership.
I: [11:39:38] hub.usbfd | HUB | Port 1 of hub "Rear Roothub (ehci.usbhcd/0)" reset timed out
W: [11:39:38] hub.usbfd | HUB | Resetting hub port 1 and trying again
I: [11:39:38] hub.usbfd | HUB | Reset request for port 1 failed (error -23)
E: [11:39:38] hub.usbfd | HUB | Resetting port 1 of hub "Rear Roothub (ehci.usbhcd/0)" failed. Device adding aborted
I: [11:39:38] hub.usbfd | HUB | Device found on port 2 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [11:39:38] hub.usbfd | HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [11:39:38] hub.usbfd | Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is full-speed.
I: [11:39:38] USB stack | New Fkt | Fkt 0x5fdf73d0 at level 1
I: [11:39:38] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 is {Vendor: 0x05AC, Product: 0x1003, Class: 09.00}
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf73d0 initialized
I: [11:39:38] hub.usbfd | HUB | Hub "Hub in Apple Extended USB Keybo" has TT thinktime of 8 full speed bittimes and protocol 0
I: [11:39:38] hub.usbfd | Hub port | Device at port 2 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [11:39:38] USB stack | New Fkt | Fkt 0x5fdf75b0 at level 1
I: [11:39:38] hub.usbfd | HUB | Device on hub port 2 successfully added.
I: [11:39:38] EHCI Controller Task Unit 0 | EHCI | Port 1 is not in reset state.
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 is {Vendor: 0x05E3, Product: 0x0605, Class: 09.00}
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf75b0 initialized
I: [11:39:38] hub.usbfd | HUB | Hub "USB2.0 Hub" has TT thinktime of 32 full speed bittimes and protocol 1
I: [11:39:38] hub.usbfd | HUB | Device found on port 1 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:38] hub.usbfd | Hub port | Device at port 1 of hub "Hub in Apple Extended USB Keybo" is low-speed.
I: [11:39:38] USB stack | New Fkt | Fkt 0x5fdf7510 at level 2
I: [11:39:38] hub.usbfd | HUB | Device on hub port 1 successfully added.
I: [11:39:38] hub.usbfd | HUB | Device found on port 3 of hub "Hub in Apple Extended USB Keybo".
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 is {Vendor: 0x046D, Product: 0xC014, Class: 00.00}
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5fdf7510 initialized
I: [11:39:38] hid.usbfd | HID driver | USB Interface bound
I: [11:39:38] hub.usbfd | Hub port | Device at port 3 of hub "Hub in Apple Extended USB Keybo" is full-speed.
I: [11:39:38] USB stack | New Fkt | Fkt 0x5c2e0330 at level 2
I: [11:39:38] hub.usbfd | HUB | Device on hub port 3 successfully added.
I: [11:39:38] hub.usbfd | HUB | Driver Running
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 is {Vendor: 0x05AC, Product: 0x020C, Class: 00.00}
I: [11:39:38] USB Fkt Init | Init Fkt | Fkt 0x5c2e0330 initialized
I: [11:39:38] hub.usbfd | HUB | All ports are empty
I: [11:39:38] hid.usbfd | HID driver | USB Interface bound
I: [11:39:38] hid.usbfd | HID driver | USB Interface bound
I: [11:39:40] hid.usbfd | HID Server | Interrupt req. returned -35

Post Reply