Radeon 9250 128MB GFX memory 64 MB since OS4.1 update 1

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
alex-kid
Posts: 3
Joined: Mon Oct 31, 2011 4:01 pm

Radeon 9250 128MB GFX memory 64 MB since OS4.1 update 1

Post by alex-kid »

Hi,

i will try to describe the problem i have as best i can, because my english is....

Since a year i own a used SAM440ep Flex 800 with ATI Radeon 9250 128 MB GFX memory. The installed System was OS4.1 update 2. I use a resolution of 1600x900x32.
After the game "Aquaria" was ported i tried to play this game.
The requirements said that much MB of GFX memory will be needed, so the game "could" run on SAM440ep with it's built in GFX chip.

I started the game with a 16Bit screen on my SAM flex, but the game "run's" veeerrry slowly....feeled 1 frames per second.
So i installed the program Ranger which shows me max. 64 MB of Radeon memory.

After i copied ATIRadeon.chip and Radeon from original OS4.1 CD (update 0) to SYS:Kickstart/ and to SYS:Devs/Monitors/, disabled the function "Erkenne Einstellungen automatisch" (this must be :-( ) under SYS:Prefs/Screenmode ->Monitore, make a cold boot with that settings and start Ranger, Ranger detects / shows 128 MB GFX memory.

I set different screenmodes (e.g. 1600x900, 800x600, 640x480 and so on because there weren't so much preinstalled) under SYS:Prefs/ScreenMode -> Monitore.
After that, i tried to play Aquaria again and....the game works fine.

I have tested it again and again (with and without my "hack"). I have the same results as i described.

Since i installed update 3, Ranger shows 64 MB GFX memory again.

So here the results of Ranger with my "hack" (1600x900x32):
Total memory: 134.201.344
Free memory: 98.962.688 largest: 98.927.264

with the original update 3 data:
Total memory: 67.092.480
Free memory: 29.936.886 largest: 29.901.472

PCI Device is 0x5960
PCI Vendor is 0x1002

I can live with the changes i have done, but maybe it is possible to find the reason for this problem.

Best Regards,
Alex
SAM440ep Flex 800, 1 GB RAM, ATI Radeon 9250
User avatar
turbo4.1
Posts: 16
Joined: Sat Jul 02, 2011 12:14 pm

Re: Radeon 9250 128MB GFX memory 64 MB since OS4.1 update 1

Post by turbo4.1 »

@alex-kid
i had the same problem with the graphic memory.
the solution was to buy a another card. sorry!
the problem seems, that the memory of your card is not in one memory block at all.
Amiga user since 1987
Sam440Flex 666Mhz, Radeon 9250, 1GB RAM
Post Reply