How to disable APPDIR:?

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
softwarefailure
Posts: 96
Joined: Fri Feb 14, 2014 10:29 pm

How to disable APPDIR:?

Post by softwarefailure »

I had some very strange behaviour until I noticed that this was caused by the new APPDIR: feature which I didn't know about. Is there any way to disable it? I've currently saved an empty file as ENVARC:APPDIR to make it go away but of course that is a rather brute force solution. Maybe there is a more elegant one.

User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 591
Joined: Sat Jun 18, 2011 2:40 am
Location: Portsmouth, UK
Contact:

Re: How to disable APPDIR:?

Post by broadblues »

if the problem you are experiencing is due to wrong versions of certain programs running (gcc if your switching compiler versions is one example) then you probably don't want to disable appdir: per seh but remove it from the PATH.

I'm presuming your are running FE ( maybe update 1 ) so check your S:Startup-sequence and note the line that sets the path, remove APPDIR: from the end.

The way it's setup in that release workd well for user but less well for developers.

User avatar
colinw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 181
Joined: Mon Aug 15, 2011 9:20 am
Location: Brisbane, QLD. Australia.

Re: How to disable APPDIR:?

Post by colinw »

softwarefailure wrote:I had some very strange behaviour until I noticed that this was caused by the new APPDIR: feature which I didn't know about. Is there any way to disable it? I've currently saved an empty file as ENVARC:APPDIR to make it go away but of course that is a rather brute force solution. Maybe there is a more elegant one.
There sure is, as broadblues mentioned, it's probably the path to APPDIR: which is added before the user-startup
is executed from your startup-sequence which also executes your SDK-startup, so the APPDIR: path comes before
any assignments from your developer environment.

The current methodology to make it work for everyone is to remove the appdir: entry from the global path
in your startup-sequence and place the following immediately before the "LoadWB" command instead...

Assign >nil: exists APPDIR:
if NOT WARN
Path ADD APPDIR:
endif

This way you still get the benefit, but the paths are in the order setup by your sdk-startup script.

Post Reply