Soft reboot hangs on FE upd 1

A forum for general AmigaOS 4.x support questions that are not platform-specific
blmara
Posts: 64
Joined: Thu Jun 23, 2011 9:03 am
Location: Vantaa, Finland

Soft reboot hangs on FE upd 1

Post by blmara »

Hi,

using AmigaOne X1000. After updating to AOS4.1 FE update 1, normal hard boot works as it should. When doing a soft reboot (CTRL-Alt-AltGR or shell command Reboot fast) the booting hangs when showing the final AmigaOS 4.1 logo. Tried taking out everything in WBStartup and even commenting out User-Startup and Network-Startup lines in Startup-Sequence, no change. When doing a hard reset with the Reset button of X1000, boots normally. Any ideas?

Marko R.
Marko

User avatar
Raziel
Posts: 952
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Soft reboot hangs on FE upd 1

Post by Raziel »

I cannot confirm this behaviour.

Soft Reboot works as good with upd1 as it did with FE
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg

User avatar
ZeroG
Posts: 119
Joined: Sat Jun 18, 2011 11:31 am
Location: Germany

Re: Soft reboot hangs on FE upd 1

Post by ZeroG »

Are you sure that amigaboot.of has been updated?

When i got my X1000 the amigaboot.of was on a small FFS partition (50MB) named BDH0: (with disabled automount so that it does not show up normaly), and the OS itself was installed on DH0: using SFS.
I keeped it that way, but had to manually update the file (default path is SYS: ).

User avatar
Raziel
Posts: 952
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Soft reboot hangs on FE upd 1

Post by Raziel »

Just for comparision..

amigaboot 53.21 (13.06.2016) on SYS:
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg

blmara
Posts: 64
Joined: Thu Jun 23, 2011 9:03 am
Location: Vantaa, Finland

Re: Soft reboot hangs on FE upd 1

Post by blmara »

Raziel wrote:Just for comparision..

amigaboot 53.21 (13.06.2016) on SYS:
Same for me.

Marko
Marko

User avatar
MichaelMerkel
Beta Tester
Beta Tester
Posts: 344
Joined: Mon Dec 20, 2010 2:08 pm
Location: Germany
Contact:

Re: Soft reboot hangs on FE upd 1

Post by MichaelMerkel »

ZeroG wrote:Are you sure that amigaboot.of has been updated?

When i got my X1000 the amigaboot.of was on a small FFS partition (50MB) named BDH0: (with disabled automount so that it does not show up normaly), and the OS itself was installed on DH0: using SFS.
I keeped it that way, but had to manually update the file (default path is SYS: ).
he could open a shell and type:

Code: Select all

nvgetvar
in the resulting output check for all lines containing "amigaboot.of" e.g. smth like:

Code: Select all

MENU_0_COMMAND=bootauto ; setenv amigaboot_quiet Y ; boot -fs=amigafs ide0.1:amigaboot.of
M
this points to the place amigaboot is loaded from. in my case the first partition on the fist disk

so to be sure check with mediatoolbox if there exists a "boot" partition before the actual partitions.

regards...
michael
Michael Merkel :lol:
(Member of Amiga Freunde Pfalz)

blmara
Posts: 64
Joined: Thu Jun 23, 2011 9:03 am
Location: Vantaa, Finland

Re: Soft reboot hangs on FE upd 1

Post by blmara »

MichaelMerkel wrote:
ZeroG wrote:Are you sure that amigaboot.of has been updated?

When i got my X1000 the amigaboot.of was on a small FFS partition (50MB) named BDH0: (with disabled automount so that it does not show up normaly), and the OS itself was installed on DH0: using SFS.
I keeped it that way, but had to manually update the file (default path is SYS: ).
he could open a shell and type:

Code: Select all

nvgetvar
in the resulting output check for all lines containing "amigaboot.of" e.g. smth like:

Code: Select all

MENU_0_COMMAND=bootauto ; setenv amigaboot_quiet Y ; boot -fs=amigafs ide0.1:amigaboot.of
M
this points to the place amigaboot is loaded from. in my case the first partition on the fist disk

so to be sure check with mediatoolbox if there exists a "boot" partition before the actual partitions.

regards...
michael
Thanks for both, actually found the BDH0: partition which contained amigaboot.of v 53.4 and the boot partition is actually the partition 0:

Code: Select all

MENU_0_COMMAND=setenv amigaboot_quiet Y ;boot -fs=amigafs ide0.0:amigaboot.of
But, even if I updated the old amigaboot.of to the newest, boot still hangs.

Marko

BTW, is the AmiUpdate/Installer able to mount these hidden boot partitions or is it the "things you just have to know" if amigaboot.of is updated in the future?

Marko
Marko

User avatar
MichaelMerkel
Beta Tester
Beta Tester
Posts: 344
Joined: Mon Dec 20, 2010 2:08 pm
Location: Germany
Contact:

Re: Soft reboot hangs on FE upd 1

Post by MichaelMerkel »

blmara wrote: BTW, is the AmiUpdate/Installer able to mount these hidden boot partitions or is it the "things you just have to know" if amigaboot.of is updated in the future?
no. it's the users choice where to place the amigaboot file and if the partition is visible or not.
so you could mount it and hide it from workbench to get a similar result. but then you can at least access it with filer/asl requester.

strange that you have this boot problem. no idea actually :-(

regards...
michael
Michael Merkel :lol:
(Member of Amiga Freunde Pfalz)

User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1426
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Soft reboot hangs on FE upd 1

Post by tonyw »

It can't be an amigaboot problem. Amigaboot doesn't affect a "warm" reboot, since amigaboot is only used to load Kickstart from disk during a cold reboot.

So the real question is: What is happening to kill the reboot?

If you connect a serial terminal, you can find the cause quickly - probably something is crashing. If you can't read the debug output, you could boot "Without Startup-Sequence" and see if that goes better, but that will be slow and frustrating. The serial terminal output is much more useful.

I have an SSD on my X1000 that sometimes won't come up ready. The disk driver then chokes and goes into a loop, spitting out a "timeout" message once a minute, while hogging the system. You will only see the "timeout" message if the system "Debuglevel" is 1 or more.
cheers
tony

User avatar
Raziel
Posts: 952
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Soft reboot hangs on FE upd 1

Post by Raziel »

MichaelMerkel wrote:
blmara wrote: BTW, is the AmiUpdate/Installer able to mount these hidden boot partitions or is it the "things you just have to know" if amigaboot.of is updated in the future?
no. it's the users choice where to place the amigaboot file and if the partition is visible or not.
so you could mount it and hide it from workbench to get a similar result. but then you can at least access it with filer/asl requester.

strange that you have this boot problem. no idea actually :-(

regards...
michael
While it might be correct that the user can have the boot.of file anywhere he/she wants, it's still a fact that the original AmigaOS4 installer created a hidden bootable FFS partition on the very first install as first partition on the available hdd...and used that to boot from it.

This wasn't rectified or mentioned in the following update installers and as such still remains the default

Now, *if* there is *NEED* to have the boot.of updated (be it because of bug fixes or additions) and the installer does so only on the first "visible" partition it can access (which isn't used by default through CFE, as we just learned), then why doesn't the installer at least tell the user about that...or, even better takes care of the updating of the *used* boot.of file on said hidden partition?

I don't have a problem with updating it on the hidden partition, but other users might not have the knowledge and end up using a buggy boot.of which will draw even more problems in the future, won't it?

EDIT: Just checked, i still had 52.4 from 2010 on the boot partion, updated now, still fine on soft reboot
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg

Post Reply