Bug in Screenmodes Prefs

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Bug in Screenmodes Prefs

Post by Raziel »

I have found buggy behaviour in Screenmode Prefs.

When on the Monitors tab the MODEs from the Devs:Monitors/ file get read in wrong to the "Manual settings" field.
(btw, why is "settings" lower case? All other headlines are upper case?)

All MODEs are read in properly except MODEs that were set to a Hz frequency LOWER than 60 Hz.
Those MODEs will always be set back to the default 60 Hz(in the Screenmode Prefs display, not in the Devs:Monitor/ file).

I had to lower one entry to 55 Hz to make it work with my monitor.

This setting though will always show up as 60 Hz even if the Devs:Monitors/ file still holds the right freuqency setting...so, this is a bug i think because
1) It gives the user wrong feedback about the actual setting and
2) it will always change those settings lower than 60 Hz back to the default thus altering the user changes *if* the user saves or misses to tidy up the changes made by Screenmode Prefs (every time).
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Re: Bug in Screenmodes Prefs

Post by ancalimon »

For me, I can not create 320x200 resolutions since it changes 200 to 240 upon pressing enter.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Bug in Screenmodes Prefs

Post by Raziel »

Really no one else with this problem?

Betatester confirmation, maybe? Please?
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
Severin
Beta Tester
Beta Tester
Posts: 189
Joined: Mon Dec 20, 2010 1:41 pm

Re: Bug in Screenmodes Prefs

Post by Severin »

ancalimon wrote:For me, I can not create 320x200 resolutions since it changes 200 to 240 upon pressing enter.
Most likely because 320x240 is the minimum size a radeon graphics card can display (640x480 on HD cards), on a classic just use NTSC or fakenative modes on newer machines, there is no need for a 320x200 screenmode to be defined.
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Re: Bug in Screenmodes Prefs

Post by ancalimon »

Severin wrote:
ancalimon wrote:For me, I can not create 320x200 resolutions since it changes 200 to 240 upon pressing enter.
Most likely because 320x240 is the minimum size a radeon graphics card can display (640x480 on HD cards), on a classic just use NTSC or fakenative modes on newer machines, there is no need for a 320x200 screenmode to be defined.
I do not have a Radeon but a CVisionPPC.
User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Bug in Screenmodes Prefs

Post by Srtest »

I have the same thing. At first I set a 50Hz on a separate monitor file for an analogue monitor dedicated to Amiga gaming and after playing a little with it and trying various modes while also testing a Picasso96 mode I've picked up on a forum from a known manual about playing old games on CRT, the pref reset my setting to 60Hz and refused to go lower since that moment. Writing the mode directly to the tooltype didn't help either. I guess it had something to do with the switch between auto and manual detect mode and the changing of names of the monitor file.
User avatar
Severin
Beta Tester
Beta Tester
Posts: 189
Joined: Mon Dec 20, 2010 1:41 pm

Re: Bug in Screenmodes Prefs

Post by Severin »

Srtest wrote:I have the same thing.
The simple solution is to not edit the devs:monitors files with screenmode prefs. Just edit them the old fashioned way via the tooltypes. Make sure you do not have a DDCMODE entry and if on a classic you might want DISABLEFAKENATIVE=Yes.
Post Reply