Update 3 Install - failed to load LIBPYTHON25.SO

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
User avatar
Ghost
Posts: 2
Joined: Sat Jun 18, 2011 7:51 am

Update 3 Install - failed to load LIBPYTHON25.SO

Post by Ghost »

What does the message mean? Where to find the library or how is it possible to install Update 3 on the SAM440?
-= Master and Commander =-

User avatar
Ghost
Posts: 2
Joined: Sat Jun 18, 2011 7:51 am

Re: Update 3 Install - failed to load LIBPYTHON25.SO

Post by Ghost »

I just copied the SOBJ Order of my clean AOS 4.1 U2 Installation to SOBJ an did a reset. After that I installed Update 3 without the trouble.
-= Master and Commander =-

User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1415
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Update 3 Install - failed to load LIBPYTHON25.SO

Post by tonyw »

If the file is missing, it can only be because of a bad download or faulty installation. The file is definitely included in the install archive (you can see it when you open the archive with UnArc).

Use only UnArc to open the archive (don't go using known buggy apps like DOpus).
cheers
tony

User avatar
Hypex
Beta Tester
Beta Tester
Posts: 403
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Update 3 Install - failed to load LIBPYTHON25.SO

Post by Hypex »

tonyw wrote:If the file is missing, it can only be because of a bad download or faulty installation. The file is definitely included in the install archive (you can see it when you open the archive with UnArc).

Use only UnArc to open the archive (don't go using known buggy apps like DOpus).
I do agree DOpus can be buggy, but with extracting it's not to blame directly as it uses LhA. So anyone who uses DOpus to extract (as I do sometimes) needs to make sure their LhA is up to date.

User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1415
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Update 3 Install - failed to load LIBPYTHON25.SO

Post by tonyw »

That's not the point. The installation has been designed and tested using UnArc. Don't go "trying" other means and then wailing for help if it doesn't work.

We know what DOES work, so use that in the first instance. If you want to experiment, you can do that later to your heart's content.

To quote para #1 of the ReadMe:
1. Unpacking
------------
It is advisable to use UnArc to unpack the archive. It is mandatory that
the protection bits on the files remain intact. Lha does not do this by
default unless told to but UnArc does. If you haven't used UnArc we strongly
recommend you delete the unpacked archive again and use UnArc.
cheers
tony

User avatar
Hypex
Beta Tester
Beta Tester
Posts: 403
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Update 3 Install - failed to load LIBPYTHON25.SO

Post by Hypex »

FWIW I know about these things and always use UnArc myself as instructed. However some people do use a PC extract the files and burn to a CD which is worse than using LhA!

And from this I have a recommendation. I noticed that internet instructiions were brief and say to read the information in the archive. Because of the above reasons I think it should state there on site not to extract on a PC. If you already did so on a PC then a Readme file telling you how to exract the archive is in the wrong place as it's then too late! So IMHO this warning should appear before you see the archive. ;-)

Post Reply