Context Menu "Extract" and archive file

A forum for general AmigaOS 4.x support questions that are not platform-specific
User avatar
nubechecorre
Posts: 69
Joined: Fri Jun 17, 2011 11:28 pm
Location: Sanremo
Contact:

Context Menu "Extract" and archive file

Post by nubechecorre »

When i try to open an archive like lha or zip using the context menu option "extract" i get this message:
sys:rexxc/rxset: Comando sconosciuto
9 *-* 'sys:rexxc/rxset' id '`requestfile DRAWERSONLY TITLE="...
+++ Command returned 10
manca un argomento dopo la parola chiave
14 *-* 'xadunfile 'file' DEST='path;
+++ Command returned 20
Is there some configuration that i am missing?
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse
User avatar
Petrol
Beta Tester
Beta Tester
Posts: 164
Joined: Mon Dec 20, 2010 6:19 pm
Location: France

Re: Context Menu "Extract" and archive file

Post by Petrol »

What's the version of the file ExtractArc.rexx in your Sys:S/Arexx/ drawer? And the rx one too?

Regards,
Petrol.
User avatar
samo79
Posts: 555
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Context Menu "Extract" and archive file

Post by samo79 »

I got the same problem here, but:
sys:rexxc/rxset
Is that the correct default path under a standard AmigaOS4 installation ?
User avatar
Petrol
Beta Tester
Beta Tester
Posts: 164
Joined: Mon Dec 20, 2010 6:19 pm
Location: France

Re: Context Menu "Extract" and archive file

Post by Petrol »

HEre Rxset is in root of the C: drawer.

Regards,
Petrol.
User avatar
samo79
Posts: 555
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Context Menu "Extract" and archive file

Post by samo79 »

Same here so "rexxc" part on the current default path may be wrong, can it be an old AmigaOS3 path :?:
User avatar
Petrol
Beta Tester
Beta Tester
Posts: 164
Joined: Mon Dec 20, 2010 6:19 pm
Location: France

Re: Context Menu "Extract" and archive file

Post by Petrol »

Could you give the version of the file ExtractArc.rexx in your Sys:S/Arexx/ drawer?

Regards,
Petrol.
User avatar
samo79
Posts: 555
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Context Menu "Extract" and archive file

Post by samo79 »

Sure it is:
ExtractArc.rexx 52.2 (17.12.2006) Christoph Gutjahr
I use AmigaOS 4.1 Update 4 of course

EDIT: I solve the problem ! ;)

On ExtractArc.rexx file I just modify this line:
'sys:rexxc/rxset' id '`requestfile DRAWERSONLY TITLE="Select destination directory"`'
To:
'sys:c/rxset' id '`requestfile DRAWERSONLY TITLE="Select destination directory"`'
So in short as i suspected the "rexxc" path is wrong and need to be changed to "c", please can you add a ticket for that ? :)
chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Re: Context Menu "Extract" and archive file

Post by chris »

samo79 wrote:
'sys:rexxc/rxset' id '`requestfile DRAWERSONLY TITLE="Select destination directory"`'
To:
'sys:c/rxset' id '`requestfile DRAWERSONLY TITLE="Select destination directory"`'
It ought to be c:rxset

In fact, it should always have been that :)
User avatar
nubechecorre
Posts: 69
Joined: Fri Jun 17, 2011 11:28 pm
Location: Sanremo
Contact:

Re: Context Menu "Extract" and archive file

Post by nubechecorre »

Thanks Chris, thanks Samo :)

I wonder why no one complains about that problem...
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse
User avatar
samo79
Posts: 555
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Context Menu "Extract" and archive file

Post by samo79 »

Yep infact is a bit strange, this ARexx file is quite old (2006, from the OS 4.0 era ?), maybe at the time the path was different and correct under OS 4.0 but since then maybe they forget to update it according to the new (?) path on 4.1 or just they decide to not release an update for it (yet).

Don't know i never use AmigaOS 4.0 at home, my first AmigaOS was the 4.1 :D
Post Reply