Graphics Card -Sam 440ep-Flex PCI slot

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Post by Spectre660 »

You need to verify that the cards are still working, Once you are sure of that then you know that there is another issue.
Best way is to try them on a PC as I have said before. I used to have a radeon 9250 that was always causing problems due to how it fit in the PCI slot. it even drove me to change to another computer case were it worked well until it developed a problem were the output became snowy .In the first case if I bumped the video cable it could take an hour of so to get it back in the PCI slot properly so the machine would boot.

Radov wrote:Yes, I have noticed this "no vga" entry too, but can assure You, that this card was perfectly working with AmigaOS 4.1 update 2.
This week I'll get new RS232 connector, maybe another logs will say more...

PS. On the other hand - yes, I do have problem with PCI slots. Radeon 9200 must fit pefectly or screen gets some weird colored lines/trash. Those lines doesn't seem to make system to be less stable though...
PS2. Both the other Radeons: 7500 and 9250 were unable to boot update 3 & 4 a long before I've noticed first problems with PCI slots. Oh... and I've already them with update2 installed again: without any problems ...
Radov
Posts: 8
Joined: Thu Aug 30, 2012 1:37 pm

Re: Graphics Card -Sam 440ep-Flex PCI slot

Post by Radov »

You need to verify that the cards are still working (...)
OK. Done.

PC
Radeon 7500 - working
Radeon 9200 - working
Radeon 9250L - working

AmigaOS 4.1 update 1 (boot from CD)
Radeon 7500 - working
Radeon 9200 - working
Radeon 9250L - hangs up just after the kickstart load screen (and that’s disappointing – this card used to work with u1-u2…)

AmigaOS 4.1 update 5
Radeon 7500 - hangs up after the AmigaOS 4.1 boot screen
Radeon 9200 - working
Radeon 9250L - hangs up just after the kickstart load screen

-----------------------
And one more thing:
Update4 was giving me tons of output (those logs from my previous messages were from U4). Update5 prints nothing, only the standard power on info from uboot appears… I’ve tried it with different debuglevel values (1..7)…
So, the only serial debug output I can see now is:
Radeon 7500 Update5 serial output :
U-Boot 1.3.1d (Feb 15 2011 - 17:02:59)


CPU: AMCC PowerPC 440EP Rev. C at 799.999 MHz (PLB=133, OPB=66, EBC=66 MHz)
I2C boot EEPROM enabled
Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
Internal PCI arbiter enabled, PCI async ext clock used
32 kB I-Cache 32 kB D-Cache
Board: Sam440ep-flex
I2C: ready
DRAM: 1024 MB
PCI: Bus Dev VenId DevId Class Int
01 04 1013 6005 0401 00
01 05 1033 0035 0c03 00
01 05 1033 0035 0c03 00
01 05 1033 00e0 0c03 00
01 06 1002 5157 0300 ff
00 0a 12d8 8150 0604 00
00 0e 1095 3114 0180 00
In: serial
Out: serial
Err: serial
Net: ppc_4xx_eth0, ppc_4xx_eth1
SM502: not found
VGA: 1
VESA: OK
[hidden=""Radeon 9250L Update5 serial output"]U-Boot 1.3.1d (Feb 15 2011 - 17:02:59)

CPU: AMCC PowerPC 440EP Rev. C at 799.999 MHz (PLB=133, OPB=66, EBC=66 MHz)
I2C boot EEPROM enabled
Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
Internal PCI arbiter enabled, PCI async ext clock used
32 kB I-Cache 32 kB D-Cache
Board: Sam440ep-flex
I2C: ready
DRAM: 1024 MB
PCI: Bus Dev VenId DevId Class Int
01 04 1013 6005 0401 00
01 05 1033 0035 0c03 00
01 05 1033 0035 0c03 00
01 05 1033 00e0 0c03 00
00 0a 12d8 8150 0604 00
00 0c 1002 5960 0300 ff
00 0c 1002 5940 0380 ff
00 0e 1095 3114 0180 00
In: serial
Out: serial
Err: serial
Net: ppc_4xx_eth0, ppc_4xx_eth1
SM502: not found[/hidden]
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Post by Spectre660 »

You could try after disable rtg.library DMA with "setenv save Picasso96/UseDMA 0".
The DMA was introduce in update 3
Radov
Posts: 8
Joined: Thu Aug 30, 2012 1:37 pm

Re: Graphics Card -Sam 440ep-Flex PCI slot

Post by Radov »

You could try after disable rtg.library DMA
Thanks! It makes my Radeon 7500 to boot with Update 5 (though it would be better to have it working with DMA turned ON...)
Unfortunately - Radeon 9250L still can’t go past the kickstart screen. It’s weird a bit, because it has boot today my PC. I will try it once more tomorrow…
Post Reply