Mixer problem still on.

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

acmn wrote:
javierdlr wrote:
acmn wrote:Well. This I found out. Mixer 1.32 works ok and Mixer 1.36 too, but not Mixer 1.37.
So I stick to Mixer 1.36. Thank you, javierdlr.
Did you try V1.38?
http://openamiga.org/attachment/project/62/mixer138.lha
is in os4depot too.
Yes, V1.38 does the same...

Will check V1.36 and what changed in V1.37 & V.138. If you want, give me your email so I can send you a test version ASAP.
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

Problem fixed!!
If someone has the same problem, a quick fix (hope it works) is to use ADJUST_GUI tooltype.
V1.39 will come ASAP (adding prefs window).
Pseudaxos
Posts: 8
Joined: Sat Jan 11, 2014 12:36 pm

Re: Mixer problem still on.

Post by Pseudaxos »

I have the same problem. None of Mixer versions worked with my EnvyHT24. Where could I find this quick fix ?
Thanks
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

Pseudaxos wrote:I have the same problem. None of Mixer versions worked with my EnvyHT24. Where could I find this quick fix ?
Thanks
If NONE of previous versions of Mixer worked with your soundcard am afraid it won't work with such V1.39beta (it just fixed other kind of bug).
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Mixer problem still on.

Post by Spectre660 »

@Javierdir

is this AC97 codec option to enable the cards possible ?


http://amigaworld.net/modules/newbb/vie ... &19#708049
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

Spectre660 wrote:@Javierdir

is this AC97 codec option to enable the cards possible ?


http://amigaworld.net/modules/newbb/vie ... &19#708049

Eeerm NO IDEA, but if you have an ENVY soundcard, post here what 'pciscan 0xVENDOR 0xDEVICE details' outputs and will try to check/add in Mixer sources Subsystem Vendor & ID, mine is a sam460ex with onboard sound, so I use:

Code: Select all

#pciscan
## Vendor Device Vendor name             Description
01 0x1095 0x3114 Silicon Image, Inc.     SiI 3114 [SATALink/SATARaid] Serial ATA Controller
02 0x126F 0x0501 Silicon Motion, Inc.    SM501 VoyagerGX Rev. AA
03 0xACBE 0x0001 Unknown                 Unknown
04 0x1002 0x6759 Advanced Micro Devices, Turks PRO [Radeon HD 6570/7570/8550]
05 0x1002 0xAA90 Advanced Micro Devices, Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
#
#pciscan 0x126f 0x0501 detail
Device #1:
  Vendor:           0x126F (Silicon Motion, Inc.)
  Device:           0x0501 (SM501 VoyagerGX Rev. AA)
  Class code:       0x038000
  RevisionID:       0xC0
  Interrupt:        Line 0x74, Pin 0x01
  Subsystem Vendor: 0x0101
  Subsystem ID:     0x0101
  Resource range #0 (MEMORY)
    Base address:     0x84000000
    Physical address: 0x84000000
    Size:             0x04000000
  Resource range #1 (MEMORY)
    Base address:     0x88000000
    Physical address: 0x88000000
    Size:             0x00200000
#
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Mixer problem still on.

Post by Spectre660 »

My Sam460ex is dead but I had posted the pciscan output in the same thread on AmigaWorld.net.

Programs:Tools/PCIScan/pciscan 0x1412 0x1724 detail

Device #1:
Vendor: 0x1412 (VIA Technologies Inc.)
Device: 0x1724 (VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller)
Class code: 0x040100
RevisionID: 0x01
Interrupt: Line 0x60, Pin 0x01
Subsystem Vendor: 0x1412
Subsystem ID: 0x2403
Resource range #0 (IO)
Base address: 0x00002000
Physical address: 0x00002000
Size: 0x00000020
Resource range #1 (IO)
Base address: 0x00002080
Physical address: 0x00002080
Size: 0x00000080
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

Spectre660 wrote:My Sam460ex is dead but I had posted the pciscan output in the same thread on AmigaWorld.net.

Programs:Tools/PCIScan/pciscan 0x1412 0x1724 detail

Device #1:
Vendor: 0x1412 (VIA Technologies Inc.)
Device: 0x1724 (VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller)
Class code: 0x040100
RevisionID: 0x01
Interrupt: Line 0x60, Pin 0x01
Subsystem Vendor: 0x1412
Subsystem ID: 0x2403
THX cooked a Mixer.docky version (just up/down master volume) with your Subsystem Vendor & ID, tell my your email (mine is jabierdlrATgmailDOTcom) and will send such executable to see if it works or makes your system explode ;-)
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Mixer problem still on.

Post by Spectre660 »

My Sam460ex got destroyed by a failed power supply last Sunday week so
You will have to get someone else to try it.
This is the card being sold by Acube so it should not be to hard to find someone with one.
Maybe Elwood ? :D

javierdlr wrote:
Spectre660 wrote:My Sam460ex is dead but I had posted the pciscan output in the same thread on AmigaWorld.net.

Programs:Tools/PCIScan/pciscan 0x1412 0x1724 detail

Device #1:
Vendor: 0x1412 (VIA Technologies Inc.)
Device: 0x1724 (VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller)
Class code: 0x040100
RevisionID: 0x01
Interrupt: Line 0x60, Pin 0x01
Subsystem Vendor: 0x1412
Subsystem ID: 0x2403
THX cooked a Mixer.docky version (just up/down master volume) with your Subsystem Vendor & ID, tell my your email (mine is jabierdlrATgmailDOTcom) and will send such executable to see if it works or makes your system explode ;-)
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Mixer problem still on.

Post by javierdlr »

Opps, so you can test it :-/ Anyone wanna test?

@Pseudaxos
Hi do you use an ENVY soundcard?
Can you do from Shell/CLI: pciscan detail

and send me or post on forum output.
You should see something like this:
..
Device #1:
Vendor: 0x1412 (VIA Technologies Inc.)
Device: 0x1724 (VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller)
Class code: 0x040100
RevisionID: 0x01
Interrupt: Line 0x60, Pin 0x01
Subsystem Vendor: 0x1412
Subsystem ID: 0x2403
..
Post Reply