Kernel 5.10

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
kilaueabart
Posts: 803
Joined: Mon Mar 05, 2012 2:36 am

Re: Kernel 5.10

Post by kilaueabart »

Downloaded RC4 yesterday, have been using several hours today.
User avatar
xeno74
Posts: 6796
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.10

Post by xeno74 »

kilaueabart wrote: Tue Nov 17, 2020 11:00 pm Downloaded RC4 yesterday, have been using several hours today.
Great! Thanks for testing! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6796
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.10

Post by xeno74 »

Hi All,

I released the RC5 of kernel 5.10 for the X1000 and X5000 today.

New:
Download: linux-image-5.10-rc5-X1000_X5000.tar.gz

Screenshot of Fienix with the RC5 and with a virtual MintPPC with also the RC5 in a QEMU/KVM HV machine:

Image

Please test the kernels.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
acefnq
Posts: 211
Joined: Fri Sep 09, 2011 9:58 am

Re: Kernel 5.10

Post by acefnq »

Christian
RC5 up and running with no issues. many thanks.

ace
User avatar
xeno74
Posts: 6796
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.10

Post by xeno74 »

acefnq wrote: Sun Nov 29, 2020 7:58 am Christian
RC5 up and running with no issues. many thanks.

ace
Hi Ace,

Thanks a lot for testing the RC5! :-)

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
daz
Beta Tester
Beta Tester
Posts: 328
Joined: Tue Dec 21, 2010 7:32 pm

Re: Kernel 5.10

Post by daz »

;
Skateman wrote: Wed Nov 11, 2020 5:21 pm
xeno74 wrote: Wed Nov 11, 2020 11:14 am
Skateman wrote: Tue Nov 10, 2020 6:42 pm I think that you are still using an internal PCI ethernet adapter as well.
No, it isn’t an internal PCI ethernet adapter installed in my MorphOS compatible X5000 because MorphOS can use the onboard ethernet without any problems.
OK, so it has to be the Linux configuration.
Yes, so It would seem, I did ask some of you to try a slightly different kernel: see here: viewtopic.php?p=51504#p51504

Not had any reports yet..

Regards
Darren
User avatar
xeno74
Posts: 6796
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.10

Post by xeno74 »

daz wrote: Sun Nov 29, 2020 10:42 pm Yes, so It would seem, I did ask some of you to try a slightly different kernel: see here: viewtopic.php?p=51504#p51504

Not had any reports yet..

Regards
Darren
Hi Darren,

I tried your kernel today but without any success.

Code: Select all

device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
device (eth1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
manager: NetworkManager state is now DISCONNECTED
Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
Roland
Posts: 529
Joined: Tue May 02, 2017 7:23 am

Re: Kernel 5.10

Post by Roland »

daz wrote: Sun Nov 29, 2020 10:42 pm ... I did ask some of you to try a slightly different kernel: see here: viewtopic.php?p=51504#p51504

Not had any reports yet..
Sorry... I had already forgotten that when I finally get back to my X5000. But now I tested it, and there was no change... Onboard ethernet still needs the 'unplug-replug' trick to work.
- Roland -
Roland
Posts: 529
Joined: Tue May 02, 2017 7:23 am

Re: Kernel 5.10

Post by Roland »

xeno74 wrote: Mon Nov 30, 2020 1:59 pm Here is the RC6 of kernel 5.10 for testing.
Works ok with MintPPC. Onboard ethernet starts only after unplug-replug...
- Roland -
Post Reply