Fienix - Problem creating USB stick for X5000

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
Skateman
Posts: 543
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Fienix - Problem creating USB stick for X5000

Post by Skateman »

The pci devices(s) in my machine:

PCI Devices
PCI bridge Freescale Semiconductor Inc Device 0421 (rev 20) (prog-if 00 [Normal decode])
VGA compatible controller Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] (prog-if 00 [VGA controller])
Audio device Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
PCI bridge Freescale Semiconductor Inc Device 0421 (rev 20) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Microsemi / PMC / IDT 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02) (prog-if 00 [Normal decode])
PCI bridge Pericom Semiconductor PI7C9X111SL PCIe-to-PCI Reversible Bridge (rev 02) (prog-if 00 [Normal decode])
Multimedia audio controller VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
SATA controller ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01) (prog-if 01 [AHCI 1.0])
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

I made some progress tonight. After recreating the stick on my Fedora box at work with the new image you put up, I was able to resize the partition and see the FIENIX-DISK partition as it should be.

I tried booting the stick and this time success. Well, kind of. It was starting Fienix this time, and finally got to a Fienix Login: prompt. This is what it looked like:

(Cleared screen after boot up)
Fienix Fienix tty1
Fienix Login: tipc: TX() has been purged, node left!

screen then would clear and repeat

Fienix Fienix tty1
Fienix Login:

I'd type in fienix at the login prompt and hit enter and the screen would clear to a flashing cursor and then the cursor stopped flashing and just sits there.
CTRL + ALT + F1 does nothing either.

Tried 6 or 7 times and got the same result each time.
Not sure what to do next but at least it is booting up now to the login prompt.
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

Does anyone know why this would happen? I never get a password prompt before it freezes up.
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by caseycullen »

tlgrooms wrote: Wed Jun 24, 2020 10:02 pm Does anyone know why this would happen? I never get a password prompt before it freezes up.
What happens if you press Ctrl + Alt + F1 as soon as you're prompted for the user?
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

Nothing. Just sits at the login prompt. When I type in fienix for the user, i never get a password prompt. Eventually the screen clears and I have a flashing cursor in the upperleft and corner for just a short bit then it turns solid and nothing else. CTRL + ALT + F1 does nothing at that point either.
User avatar
caseycullen
Posts: 397
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by caseycullen »

tlgrooms wrote: Thu Jun 25, 2020 4:34 pm Nothing. Just sits at the login prompt. When I type in fienix for the user, i never get a password prompt. Eventually the screen clears and I have a flashing cursor in the upperleft and corner for just a short bit then it turns solid and nothing else. CTRL + ALT + F1 does nothing at that point either.
Are you able to mount FIENIX-DISK from the new image? If so, try to copy /usr/lib/fienix-gpu-bandage/xorg.conf to /etc/X11/xorg.conf and see if that helps.
Sorry no one has a more definitive answer, I don't think we've encountered this particular issue with anyone else.
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

Yes, I can mount both partitions now whereas I couldn't before. I'll give that a try tonight when I get home.
Thanks for all the hard work you've put into it and the help here as well. I hope to use it soon ha!

One question, I am thinking about upgrading to a Radeon RX-550 in the future. Will it work with Fienix?
I'd like to stick with something that will work.
User avatar
Skateman
Posts: 543
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Fienix - Problem creating USB stick for X5000

Post by Skateman »

Only older Radeon cards have 3D acceleration support. For newer cards like the Southern Islands chipsets and newer RX chipset are no PowerPC based drivers made. That said, i am using a Radeon R7 250 card (SI) and i am running a linux desktop in a Full HD resolution 1920x1080. So no 3D support but very usable
I have decided to sitck with AmigaOS and 3D support, and Linux without 3D support. I bought the X5000 after all for using it with AmigaOS 4.1.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

Is there a card which will allow you to run OS 4, Morphos and Fienix that you are aware of?

I'd like to put another card in my x5000 so i can hook up further drives (sata) but have no free PCI slots due to having a soundblaster in one and a realtek ethernet card in the other. Is there a pcie sata card that will work with OS4?

Thanks for your help.
tlgrooms
Posts: 20
Joined: Tue Jun 02, 2020 9:24 pm
Location: Mayflower, AR USA
Contact:

Re: Fienix - Problem creating USB stick for X5000

Post by tlgrooms »

Got the updated Fienix usb stick from AOTL today. Tried it several times. It boots and clears the screen to a flashing cursor and does nothing else.

Tried copying the xorg.conf file as suggested on the usb stick I had created. Still having the problem where I never get a password prompt and CTRL + ALT + F1 doesn't do anything, eventually clears the screen with a flashing cursor and then goes solid then nothing else.

I tried hooking up another monitor to make sure it wasn't the monitor but get the same thing with both sticks.
Post Reply