Kernel 5.8

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
Skateman
Posts: 543
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

Kernel 5.8 RC2 running fine on the AmigaOne X5000. Also the onboard Ethernet adapter is working great!

Image

Big picture: http://www.skateman.nl/wp-content/uploa ... 213506.png
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Skateman wrote: Mon Jun 22, 2020 8:38 pm Kernel 5.8 RC2 running fine on the AmigaOne X5000. Also the onboard Ethernet adapter is working great!
Great! Many thanks for testing! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Hi Skateman,

Alexander has replied because of our test results.
Alexander Gordeev wrote: Hi Christian,

Could you please check if the kernel passes CONFIG_TEST_BITMAP self-test?

Thanks!
I compiled a test kernel with the option "CONFIG_TEST_BITMAP=y" today. Could you please boot it and look for the bitmap tests with "dmesg | grep -i bitmap"?

Download: uImage-dpaa18

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Bitmap test result from my X5000/40:

Code: Select all

[    0.296563] test_bitmap: loaded.
[    0.296894] test_bitmap: parselist: 14: input is '0-2047:128/256' OK, Time: 540
[    0.296920] test_bitmap: parselist_user: 14: input is '0-2047:128/256' OK, Time: 680
[    0.299994] test_bitmap: all 1663 tests passed
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 543
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

Kernel 5.8 DPAA18 Breaks the onboard Ethernet adapter

Image

Big picture http://www.skateman.nl/wp-content/uploa ... 221604.png

Code: Select all

skateman@X5000LNX:~$ dmesg | grep -i bitmap
[    0.297756] test_bitmap: loaded.
[    0.298113] test_bitmap: parselist: 14: input is '0-2047:128/256' OK, Time: 562
[    0.298142] test_bitmap: parselist_user: 14: input is '0-2047:128/256' OK, Time: 761
[    0.301553] test_bitmap: all 1663 tests passed
skateman@X5000LNX:~$
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Skateman wrote: Wed Jun 24, 2020 7:22 pm Kernel 5.8 DPAA18 Breaks the onboard Ethernet adapter

Code: Select all

skateman@X5000LNX:~$ dmesg | grep -i bitmap
[    0.297756] test_bitmap: loaded.
[    0.298113] test_bitmap: parselist: 14: input is '0-2047:128/256' OK, Time: 562
[    0.298142] test_bitmap: parselist_user: 14: input is '0-2047:128/256' OK, Time: 761
[    0.301553] test_bitmap: all 1663 tests passed
skateman@X5000LNX:~$
Thanks a lot for testing! I reported our test results to Alexander today.

Link to the test thread: FSL P5020/P5040: DPAA Ethernet issue with the latest Git kernel -- Linuxppc-dev mailing list
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

FYI because of the DPAA Ethernet issue:
Alexander Gordeev wrote: Thanks for the test! So it works as expected.

I would suggest to compare what is going on on the device probing
with and without the bisected commit.

There seems to be MAC and PHY mode initialization issue that might
resulted from the bitmap format change.

I put Madalin and Sascha on CC as they have done some works on
this part recently.

Thanks!
OK, we have to wait. I will patch the RC3 with our dpaa-v1 patch again.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6319
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.8

Post by xeno74 »

Hi All,

I released the RC3 of kernel 5.8 for the X1000 and X5000 today.

New:
Download: linux-image-5.8-rc3-X1000_X5000.tar.gz

Image

Please test the kernels.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 543
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.8

Post by Skateman »

Kernel 5.8 RC3 running fine on the AmigaOne X5000

Image

Big picture http://www.skateman.nl/wp-content/uploa ... 224956.png
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
Post Reply