Page 9 of 10

Re: Kernel 5.7

Posted: Thu May 21, 2020 7:58 pm
by Roland
Tested the RC6... Seems to work here, also shutdown. Only problem is that starting the onboard ethernet still needs the unplug/replug trick.

Re: Kernel 5.7

Posted: Thu May 21, 2020 8:48 pm
by Skateman
Roland wrote:
Thu May 21, 2020 7:58 pm
Tested the RC6... Seems to work here, also shutdown. Only problem is that starting the onboard ethernet still needs the unplug/replug trick.
Do you also have another network card in your machine... or just the onboard DPAA adapter in use ?

Re: Kernel 5.7

Posted: Thu May 21, 2020 9:22 pm
by Roland
Skateman wrote:
Thu May 21, 2020 8:48 pm
Do you also have another network card in your machine... or just the onboard DPAA adapter in use ?
I have also a RTL8169 card installed.

Re: Kernel 5.7

Posted: Fri May 22, 2020 11:33 am
by Skateman
I dont have any other NICs in use anymore... just the onboard X5000 adapter.
I guess thats the only difference .

Re: Kernel 5.7

Posted: Mon May 25, 2020 5:43 am
by xeno74
acefnq wrote:
Wed May 20, 2020 1:28 pm
Skateman
Does your X5000 boot with the included dtb of 5.7 RC6?

ace
Have you seen any error messages?

Re: Kernel 5.7

Posted: Mon May 25, 2020 11:56 am
by acefnq
Ok, I accept Dunce of the Year Award! I had neglected to change my env boot variable. DTB working fine and machine powering down. Sorry chaps. Shoot me now!


ace

Re: Kernel 5.7

Posted: Mon May 25, 2020 4:04 pm
by xeno74
Hi All,

I released the RC7 of kernel 5.7 for testing today.

New:
Download: linux-image-5.7-rc7-X1000_X5000.tar.gz

Screenshot of a SuSE 6.0 guest (Kernel 2.0.36) from 1999 and a S.u.S.E. Linux 4.2 guest (Kernel 1.99.4) from 1996 on Xubuntu 16.04.6 PowerPC (host) with kernel 5.7-rc7:

Image

Please test the kernels.

Thanks,
Christian

Re: Kernel 5.7

Posted: Tue May 26, 2020 7:35 am
by Skateman
Kernel 5.7 RC7 up and running on the AmigaOne X5000

Image

Big picture http://www.skateman.nl/wp-content/uploa ... -27-41.png

Re: Kernel 5.7

Posted: Tue May 26, 2020 1:01 pm
by xeno74
Skateman wrote:
Tue May 26, 2020 7:35 am
Kernel 5.7 RC7 up and running on the AmigaOne X5000
Fantastic! Thank you for testing the RC7! :-)

Re: Kernel 5.7

Posted: Sat May 30, 2020 8:18 pm
by daz
xeno74 wrote:
Sun May 03, 2020 2:25 pm
Hi Darren,

I successfully tested the RC3-2 and the new cyrus-p5040.dtb with Fienix Soar 3.0-20200426 on my X5000/40 today.

Results:
  • power-off and restart are working! We don't need the cyrus patch anymore!!!!!! :-)
  • The hard disk LED works! Great!
  • The DPAA Ethernet works after a replug of the network cable.
Basically the DPAA Ethernet works now. Unfortunately something is odd with the first RJ45 socket of the onboard DPAA Ethernet. I have to insert the network cable in strongly so that a signal transmission works. After a reboot or power-off I have to replug the network cable. Simply plugging it in is not enough. I have to put it in strongly. I can't use the second Ethernet port because there is a piece of plastic in front of the second RJ45 socket. The issue with displaying to much DPAA Ethernet interfaces is solved! I see only two DPAA Ethernet interfaces (eth0 and eth1).
I used to have this when I first got my X5000. I'm told it's due to the ports your X5000 is connected to, apparently some 100Mbit ports don't fully comply and upset the DPAA. I use a 5 port hub now, and that doesn't cause problems. Do you have a different router you could try? Or can you connect through a Hub device first?

Regards
Darren