Kernel 5.3

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

Hi All,

I successfully tested the RC8 of kernel 5.3 with Fienix on my A-EON AmigaOne X1000 today.

Screenshot of Fienix with the kernel 5.3-rc8 connected to wifi and to bluetooth speakers for using ViewTube in the new Arctic Fox 27.9.18:

Image

Please test the RC8.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Skateman
Posts: 386
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.3

Post by Skateman »

Kernel 5.3 RC8 is running fine on the AmigaOne X5000 !

Image

Big picture.. http://www.skateman.nl/wp-content/uploa ... 211730.png

Sorry for the delay :-)
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world

User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

Skateman wrote:Kernel 5.3 RC8 is running fine on the AmigaOne X5000 !

Sorry for the delay :-)
Hi Skateman,

Thanks a lot for testing the RC8! :-)

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

Hi All,

Here is the final version of kernel 5.3 for the X5000, X1000, and A1222. :-)
Download: linux-image-5.3-X1000_X5000_A1222.tar.gz

Screenshot of Debian 10 PowerPCSPE with the final kernel 5.3 on the Tabor board (A1222):

Image

You can also see the repositories with the last packages of Debian PowerPCSPE on the screenshot.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Skateman
Posts: 386
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Kernel 5.3

Post by Skateman »

Final kernel 5.3 up and running on the AmigaOne X5000!

Image

Big picture http://www.skateman.nl/wp-content/uploa ... 094645.png
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world

User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

Skateman wrote:Final kernel 5.3 up and running on the AmigaOne X5000!
Fantastic! :-) Many thanks for testing! :-) Have a nice weekend!
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

acefnq
Posts: 154
Joined: Fri Sep 09, 2011 9:58 am

Re: Kernel 5.3

Post by acefnq »

Christian
5.3 Final boots fine to SI card and Logitech mouse works. Thanks for your hard work.

ace

User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

acefnq wrote:Christian
5.3 Final boots fine to SI card and Logitech mouse works. Thanks for your hard work.

ace
Thanks a lot for testing! :-) Have a nice weekend! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Roland
Posts: 386
Joined: Tue May 02, 2017 7:23 am

Re: Kernel 5.3

Post by Roland »

I noticed that Kernel 5.3 has created a problem which does not exist in 4.20 or earlier... If there is a Dawicontrol DC 2976 UW SCSI board (PCI) installed, the system does not boot unless the RAM is limited to 3500M. This happens now even when there is nothing connected to the controller!
- Roland -

User avatar
xeno74
Posts: 5498
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 5.3

Post by xeno74 »

Roland wrote:I noticed that Kernel 5.3 has created a problem which does not exist in 4.20 or earlier... If there is a Dawicontrol DC 2976 UW SCSI board (PCI) installed, the system does not boot unless the RAM is limited to 3500M. This happens now even when there is nothing connected to the controller!
Hi Roland,

Thanks a lot for reporting the issue with the Dawicontrol DC 2976 UW SCSI board (PCI).

Could you please test the RC2 of kernel 5.4 with this SCSI board? I would like to know if the problem still exists in the latest kernel.

Please post the results in the kernel 5.4 test thread.

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply