Dual graphics cards - a couple of noob questions :-)

AmigaOne X5000 platform specific issues related to Linux only.
User avatar
JohnFante
Beta Tester
Beta Tester
Posts: 183
Joined: Tue Sep 04, 2012 6:48 am
Location: Copenhagen, Denmark

Dual graphics cards - a couple of noob questions :-)

Post by JohnFante »

I am trying to get dual graphics cards running in Fienix. Excuse me in advance if the questions has been answered before and my problem is noobish :D

I am running the 5.1.14 kernel but I can not seem to get 3d going on the FirePro 2250 that I have installed besides my R9270x.

I have installed the FirePro 2250 in the buttom PCIE1 slot and it shows up fine when I type lspci:

Code: Select all

fienix@Fienix:~$ lspci
0000:00:00.0 PCI bridge: Freescale Semiconductor Inc Device 0421 (rev 20)
0000:01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X]
0000:01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
1000:00:00.0 PCI bridge: Freescale Semiconductor Inc Device 0421 (rev 20)
1000:01:00.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:02:01.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:02:02.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:02:03.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:02:08.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:02:10.0 PCI bridge: Integrated Device Technology, Inc. [IDT] 89HPES12NT12G2 12-Lane 12-Port PCIe Gen2 System Interconnect Switch (rev 02)
1000:03:00.0 PCI bridge: Pericom Semiconductor PI7C9X111SL PCIe-to-PCI Reversible Bridge (rev 02)
1000:04:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
1000:04:05.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller (rev 02)
1000:05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV516 GL [FireMV 2250]
1000:05:00.1 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] RV516 GL [FireMV 2250] (Secondary)
1000:06:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)
1000:07:00.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
fienix@Fienix:~$ 
so it is found.

My cards are:

PCIx16=Radeon R9 270x
PCIx4=Empty
PCIx1:ENVy24PT soundcard
PCIx1FIrePro2250
PCI=Ethernet (used on linux)
PCI=SII3114

I can boot fine in both Fienix and OS4,1 with this configuration.

My Xorg.conf looks like this;

Code: Select all

Section "Monitor"
Identifier "Monitor0"
EndSection

Section "Device"
Identifier "Device0"
Driver "fbdev"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
If i exchange "fbdev" with "radeon" x does not start on boot. The same happens if there is no xorg.conf and also if I rename "libglamoregl.so".

I have searched a bit on the forum but not found any recent threads that deals with dual graphics cards under the 5,1.14 kernel.

Any suggestions? What have others exactly done to get 3D going on two graphics cards in Fienix?

I read somewhere that with to cards installed you do not have to have monitors connected to both cards but can just have one connected to the R9. Is that correct?

It can be that I have the wrong cards installed besides the FirePro but since it is found I do not think so. Or?
X5000 :-)
User avatar
xeno74
Posts: 8405
Joined: Fri Mar 23, 2012 7:58 am

Re: Dual graphics cards - a couple of noob questions :-)

Post by xeno74 »

Please try

Code: Select all

Section "Device"
            Identifier "ATI RV516 GL [FireMV 2250]"
            BusID   "PCI:05:00.1"
            Driver "radeon"
    EndSection
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
JohnFante
Beta Tester
Beta Tester
Posts: 183
Joined: Tue Sep 04, 2012 6:48 am
Location: Copenhagen, Denmark

Re: Dual graphics cards - a couple of noob questions :-)

Post by JohnFante »

xeno74 wrote:Please try

Code: Select all

Section "Device"
            Identifier "ATI RV516 GL [FireMV 2250]"
            BusID   "PCI:05:00.1"
            Driver "radeon"
    EndSection
Thank you!

Tried it and found out that I lack a DMS cable from the graphics card .... :oops:

I will report back when I got that. It looks like it is working.
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
Posts: 183
Joined: Tue Sep 04, 2012 6:48 am
Location: Copenhagen, Denmark

Re: Dual graphics cards - a couple of noob questions :-)

Post by JohnFante »

Bad news - at least for me!

When the FirePro is installed there is no sound in OS4.1 - so some kind of conflict exsists .... :cry:
X5000 :-)
User avatar
xeno74
Posts: 8405
Joined: Fri Mar 23, 2012 7:58 am

Re: Dual graphics cards - a couple of noob questions :-)

Post by xeno74 »

JohnFante wrote:Bad news - at least for me!

When the FirePro is installed there is no sound in OS4.1 - so some kind of conflict exsists .... :cry:
Does 3D hardware acceleration works on Fienix?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
gerograph
Posts: 95
Joined: Sun Mar 25, 2012 9:24 am
Location: Moers
Contact:

Re: Dual graphics cards - a couple of noob questions :-)

Post by gerograph »

I thought I post here as well:

Radeon HD 4650 in the second PCI Slot (counted from top) - this is planned for Linux
Radeon HIS in the firs PCI Slot (counted from top), this is where CFE is displayed (if plugged in) - planned for AmigaOS

When booting with old Debian Wheezy from USB Pendrive (see A-Eon Downloadsection and Trevor's install guide there), Radeon 4650 will be chosen and used out of the box. BUT when booting with Void Linux (see viewtopic.php?f=35&t=4714&start=20) I will get a black screen. It only works, when only one Graphic Card is hardwarewise mounted. Creating (!) an xorg.conf on Void didn't solve the problem, therefore I just copied some files over from debian Wheezy:
gerograph wrote: Tue Nov 23, 2021 12:38 pm I did it :-)...this is what I did:
  • mounted both Graphic Cards
  • booted the old Debian from USB (X1000 A-Eon Downloadsection), which brought me right into XFCE on my Radeon 4650
  • saved the file etc/X11/xorg.conf.d/10-vsync.conf
  • unmounted Graphic Card Radeon HIS
  • booted Void from HD
  • created a directory xorg.conf.d in /etc/X11
  • copied 10-vsync.conf into there
  • also copied 10-vsync.conf into usr/share/X11/xorg.conf.d
  • mounted 2nd Graphic Card again, and after reboot, everything worked like supposed

I am not 100% sure wether I need 10-vsync.conf in both locations ?
Do I still need 10-radeon.conf in usr/share/X11/xorg.conf.d ?


Image
User avatar
Skateman
Posts: 752
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Dual graphics cards - a couple of noob questions :-)

Post by Skateman »

This i how i got a second graphics card up and running in my AmigaOne X5000. (click on the link below)

https://www.skateman.nl/index.php/2022/ ... -graphics/

Image

Most issues i had was with getting a working xorg.conf. So here is mine based on the Driver "radeon"
Works with a Radeon HD5450 and 24 Inch samsung lcd panel.

Section “Monitor”
Identifier “Monitor0”
EndSection

Section “Device”
Identifier “Device1”
Driver “radeon”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
EndSection

Section “Module”
Load “dri”
Load “dri2”
Load “dbe”
Load “glx”
Load “type1”
Load “freetype”
Load “record”
EndSection

Section “DRI”
Mode 0666
EndSection

Section “Extensions”
Option “Composite” “Enable”
Option “RENDER” “Enable”
Option “RANDR” “Enable”
Option “DAMAGE” “Enable”
Option “GLX” “Enable”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
Viewport 0 0
EndSubSection
EndSection
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon RX 570 / Radeon X1900 / M-Audio 5.1 -> AmigaOS / Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
Posts: 752
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Dual graphics cards - a couple of noob questions :-)

Post by Skateman »

UPDATE!

The second graphics card has been upgraded. The Radeon 5450 is repaced for a Radeon 7450.

Old and New!
Image
7450 in PCIe riser
Image
Quick and dirty Low Profile fix... (but works)
Image
Inside view..(with a cardboard support bracket)
Image
GLmark2 based on the 5450
Image
GLmark2 Score of 537 based on 5450
Image
GLmark2 based on the 7450
Image
GLmark2 Score of 779 based on 7450
Image
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon RX 570 / Radeon X1900 / M-Audio 5.1 -> AmigaOS / Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
xeno74
Posts: 8405
Joined: Fri Mar 23, 2012 7:58 am

Re: Dual graphics cards - a couple of noob questions :-)

Post by xeno74 »

Skateman,

Fantastic solution! Thanks for sharing!

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Skateman
Posts: 752
Joined: Thu Aug 10, 2017 8:36 pm
Location: The Netherlands

Re: Dual graphics cards - a couple of noob questions :-)

Post by Skateman »

Some 3D games running Fienix Linux and the PCIeX1 connected Radeon 7450

https://youtu.be/H7ZJA6D-QgU
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon RX 570 / Radeon X1900 / M-Audio 5.1 -> AmigaOS / Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
Post Reply