Page 50 of 73

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 7:31 am
by UserH
AGH! A new version.. I'll have to test it on my T2080 dev system though.. As my X5000 system has sadly been pilfered for parts at the moment.. I'll let you know how it goes Casey.

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 2:30 pm
by Skateman
For me, Fienix boots into a black screen with a cursor prompt topleft....
Any ideas...

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 4:11 pm
by caseycullen
UserH wrote: Mon Apr 13, 2020 7:31 am AGH! A new version.. I'll have to test it on my T2080 dev system though.. As my X5000 system has sadly been pilfered for parts at the moment.. I'll let you know how it goes Casey.
That's great! Please let me know how it goes! I saw the project recently added instructions here.
-Casey

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 6:28 pm
by caseycullen
acefnq wrote: Sun Apr 12, 2020 11:01 am Casey
Up and running. Just tried KDE Connect with my Samsung S8+ and seems to work fine. Distro feels a fair bit faster. Just about to install some apps. Fantastic work, you should be proud of what you have achieved.

John
I used dd to copy the image to my partition, the passwords are the same as on Casey's webpage.

ace
Excellent! Thank you for reporting back about KDE Connect!
And thank you, I'm very happy with this release!
-Casey

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 6:29 pm
by caseycullen
acefnq wrote: Mon Apr 13, 2020 3:46 am Casey
I have installed a variety of software all working well except Warzone 2100. It appears we need an updated version to match the data package which is newer, whilst the main package depends on an older version. Other than that fantastic work.


ace
Thank you for reporting back about Warzone 2100; this should be fixed now. You will need to downgrade any prematurely updated packages back to version 3.2.1-4.
-Casey

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 7:21 pm
by xeno74
Skateman wrote: Mon Apr 13, 2020 2:30 pm For me, Fienix boots into a black screen with a cursor prompt topleft....
Any ideas...
Hi Skateman,

I know that you have a Radeon SI graphics card.
Do you have the library /usr/lib/xorg/modules/libglamoregl.so? If yes, then please prevent the libglamor module from loading. It is loaded if a Radeon HD7xxx or above card is detected and causes xorg to crash.

Code: Select all

sudo mv /usr/lib/xorg/modules/libglamoregl.so /usr/lib/xorg/modules/libglamoregl.so.bak
@Casey
Could you please rename the libglamoregl.so to libglamoregl.so.bak in your next img?

Thanks,
Christian

Re: Fienix - New PowerPC Distro

Posted: Mon Apr 13, 2020 8:40 pm
by Skateman
It has been renamed to .bak already.

I have copied my Xorg.conf from my ubuntu linux to Fienix. The Welcome screen shows up... i can login as fienix...
After login the screen turns to black again... mouse pointer still visible and responsive
All is running, can switch to a different TTY and work without the GUI in fienix.
It has to be something with the display drivers..
Let me fiddle a bit more...

Image
Big picture http://www.skateman.nl/wp-content/uploa ... -45-07.png

I found out that i can login as Root and get the "default" mate desktop!
So the issue is somewhere in the used Fienix theme..

The Xorg log is showing me this:..

X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
[ 20.200] Build Operating System: Linux 5.4.0-4-powerpc64 ppc Debian
[ 20.200] Current Operating System: Linux Fienix 5.7.0-rc1_A-EON_X5000 #1 SMP PREEMPT Mon Apr 13 08:35:35 CEST 2020 ppc64
[ 20.200] Kernel command line: root=/dev/sdc console=ttyS0,115200 console=tty0 rootdelay=5
[ 20.200] Build Date: 31 March 2020 10:14:40AM
[ 20.200] xorg-server 2:1.20.8-2 (https://www.debian.org/support)
[ 20.200] Current version of pixman: 0.36.0
[ 20.200] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 20.200] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 20.201] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 14 10:19:41 2020
[ 20.203] (==) Using config file: "/etc/X11/xorg.conf"
[ 20.203] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 20.210] (==) No Layout section. Using the first Screen section.
[ 20.210] (**) |-->Screen "Screen0" (0)
[ 20.210] (**) | |-->Monitor "Monitor0"
[ 20.211] (**) | |-->Device "Device0"
[ 20.211] (==) Automatically adding devices
[ 20.211] (==) Automatically enabling devices
[ 20.211] (==) Automatically adding GPU devices
[ 20.211] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 20.230] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 20.230] Entry deleted from font path.
[ 20.239] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 20.239] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 20.239] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 20.240] (II) Loader magic: 0xced738
[ 20.240] (II) Module ABI versions:
[ 20.240] X.Org ANSI C Emulation: 0.4
[ 20.240] X.Org Video Driver: 24.1
[ 20.240] X.Org XInput driver : 24.1
[ 20.240] X.Org Server Extension : 10.0
[ 20.242] (++) using VT number 7

[ 20.242] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 20.244] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 20.257] (--) PCI:*(1@0:0:0) 1002:683f:174b:a001 rev 0, Mem @ 0x00000000/268435456, 0x10000000/262144, I/O @ 0x00001000/256, BIOS @ 0x????????/131072
[ 20.268] (II) LoadModule: "glx"
[ 20.274] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 20.366] (II) Module glx: vendor="X.Org Foundation"
[ 20.366] compiled for 1.20.8, module version = 1.0.0
[ 20.366] ABI class: X.Org Server Extension, version 10.0
[ 20.366] (II) LoadModule: "fbdev"
[ 20.368] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 20.372] (II) Module fbdev: vendor="X.Org Foundation"
[ 20.372] compiled for 1.20.0, module version = 0.5.0
[ 20.372] Module class: X.Org Video Driver
[ 20.373] ABI class: X.Org Video Driver, version 24.0
[ 20.373] (II) FBDEV: driver for framebuffer: fbdev
[ 20.451] (II) Loading sub module "fbdevhw"
[ 20.451] (II) LoadModule: "fbdevhw"
[ 20.451] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 20.454] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 20.454] compiled for 1.20.8, module version = 0.0.2
[ 20.454] ABI class: X.Org Video Driver, version 24.1
[ 20.488] (**) FBDEV(0): claimed PCI slot 1@0:0:0
[ 20.488] (II) FBDEV(0): using default device
[ 20.488] (**) FBDEV(0): Depth 24, (--) framebuffer bpp 32
[ 20.488] (==) FBDEV(0): RGB weight 888
[ 20.488] (==) FBDEV(0): Default visual is TrueColor
[ 20.488] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 20.488] (II) FBDEV(0): hardware: radeondrmfb (video memory: 8100kB)
[ 20.488] (II) FBDEV(0): checking modes against framebuffer device...
[ 20.489] (II) FBDEV(0): checking modes against monitor...
[ 20.489] (II) FBDEV(0): Virtual size is 1920x1080 (pitch 1920)
[ 20.489] (**) FBDEV(0): Built-in mode "current"
[ 20.489] (==) FBDEV(0): DPI set to (96, 96)
[ 20.489] (II) Loading sub module "fb"
[ 20.489] (II) LoadModule: "fb"
[ 20.489] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 20.496] (II) Module fb: vendor="X.Org Foundation"
[ 20.496] compiled for 1.20.8, module version = 1.0.0
[ 20.496] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.496] (**) FBDEV(0): using shadow framebuffer
[ 20.496] (II) Loading sub module "shadow"
[ 20.496] (II) LoadModule: "shadow"
[ 20.496] (II) Loading /usr/lib/xorg/modules/libshadow.so
[ 20.502] (II) Module shadow: vendor="X.Org Foundation"
[ 20.502] compiled for 1.20.8, module version = 1.1.0
[ 20.502] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.593] (==) FBDEV(0): Backing store enabled
[ 20.597] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 20.598] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

Re: Fienix - New PowerPC Distro

Posted: Tue Apr 14, 2020 7:07 pm
by JohnFante
Minor issue:

The game Xracer does not start - at least on my system :) .

I get this when I try to start from shell (no menu item):

Code: Select all

fienix@Fienix:~$ xracer
xracer:main.c:528: error: open: No such file or directory
xracer:video.c:72: error: open: video/intro.mpeg: No such file or directory
xracer:joystick.c:45: error: failed to open joystick device /dev/js0: No such file or directory
xracer:jpeg.c:92: error: powerups/cannon.jpg: No such file or directory
xracer:texture.c:66: error: error loading texture file: powerups/cannon.jpg: No such file or directory
xracer:track.c:102: error: dlopen: /usr/lib/games/xracer/tracks/libtracksimple2.so: /usr/lib/games/xracer/tracks/libtracksimple2.so: cannot open shared object file: No such file or directory
xracer:main.c:486: error: load track: simple2: No such file or directory

Re: Fienix - New PowerPC Distro

Posted: Tue Apr 14, 2020 7:45 pm
by xeno74
Skateman,

Maybe 3D acceleration is enabled for the window manager of the default Fienix desktop.

Cheers,
Christian

Re: Fienix - New PowerPC Distro

Posted: Wed Apr 15, 2020 7:59 am
by xeno74
JohnFante wrote: Tue Apr 14, 2020 7:07 pm Minor issue:

The game Xracer does not start - at least on my system :) .

I get this when I try to start from shell (no menu item):

Code: Select all

fienix@Fienix:~$ xracer
xracer:main.c:528: error: open: No such file or directory
xracer:video.c:72: error: open: video/intro.mpeg: No such file or directory
xracer:joystick.c:45: error: failed to open joystick device /dev/js0: No such file or directory
xracer:jpeg.c:92: error: powerups/cannon.jpg: No such file or directory
xracer:texture.c:66: error: error loading texture file: powerups/cannon.jpg: No such file or directory
xracer:track.c:102: error: dlopen: /usr/lib/games/xracer/tracks/libtracksimple2.so: /usr/lib/games/xracer/tracks/libtracksimple2.so: cannot open shared object file: No such file or directory
xracer:main.c:486: error: load track: simple2: No such file or directory
Thanks a lot for reporting!

Please create the following symbolic link as root.

root@Fienix:/home/fienix#

Code: Select all

ln -s /usr/lib/games/xracer/tracks/libtracksimple2.so.0 /usr/lib/games/xracer/tracks/libtracksimple2.so
After that you can start xracer.

Further information:

q = Exit xracer
Cursor keys left and right = Steer left and right
Page Up and Page Down keys: Accelerate and brake

Options:
-f, --fullscreen Fullscreen mode.
-s, --size WIDTHxHEIGHT Set the screen size.