Fienix - New PowerPC Distro

AmigaOne X5000 platform specific issues related to Linux only.
Roland
Posts: 397
Joined: Tue May 02, 2017 7:23 am

Re: Fienix - New PowerPC Distro

Post by Roland »

caseycullen wrote:fienix-customization-layer does install a panel configuration. If you have your current configuration saved you should be able to switch back to it, but there appears to be a bug with MATE Tweak (documented in Ubuntu-MATE as well) relating to saving panel configurations right now, so if you don't want to risk having to set your panels up again then yes, just change the repository addresses manually. Delete the old ones.
Thanks for your advice! I changed the addresses manually, no problem there. A plenty of updates available now!

I noticed one update which was uninstallable due to dependency problems: 'mate-system-monitor'. But synaptic did not give any list of missing packages...
- Roland -

caseycullen
Posts: 332
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

Roland wrote:
caseycullen wrote:fienix-customization-layer does install a panel configuration. If you have your current configuration saved you should be able to switch back to it, but there appears to be a bug with MATE Tweak (documented in Ubuntu-MATE as well) relating to saving panel configurations right now, so if you don't want to risk having to set your panels up again then yes, just change the repository addresses manually. Delete the old ones.
Thanks for your advice! I changed the addresses manually, no problem there. A plenty of updates available now!

I noticed one update which was uninstallable due to dependency problems: 'mate-system-monitor'. But synaptic did not give any list of missing packages...
Thanks for letting me know. Please try again.

User avatar
xeno74
Posts: 5576
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

caseycullen wrote:Fienix UPDATES
Please test and let me know if you run into any issues. I'm calling this the "pre-release" of Fienix 2.0, codename "soar".

Package Updates
*MATE to 1.22.2
*Mesa graphics library to 19.3.2
*PulseAudio sound server to 13.0
*SDL libraries to 2.0.10
*Updates to various MATE applications (Caja, EOM, etc.)
*Evolution email to 3.34.1
*LibreOffice to 6.4.0
*Rawtherapee digital photo developer to 5.7
*Flowblade nonlinear video editor to 2.4
*Mopidy music client to 3.0.1
*smplayer media player to 19.10
*Many other updated packages

New Software
*Blueman bluetooth manager
*Redshift automatic screen color adjuster
*Maxima algebra system
*Regina mathematical software
*OpenVPN VPN
*OpenConnect VPN
*LAMP Stack (Apache2, MySQL 5.7, and PHP 7.3)

Repository Update
Fienix is now using a new software repository. When I made the old repository, it was really just a place to store add-on packages, and it didn't scale very well when I decided to create a whole new distro. The new repository should help me keep it organized and updated much easier. When you upgrade "fienix-customization-layer" your sources.list will automatically update to the new repositories, you do not need to do anything else.

Repository Addresses (for reference - your sources.list will update automatically)
deb http://fienix.servehttp.com/repos/fienix/soar/ soar-di main
deb http://fienix.servehttp.com/repos/fienix/soar/ soar-dh main
deb http://fienix.servehttp.com/repos/fienix/soar/ soar-cp main

-Casey
Hi Casey,

I was able to upgrade Fienix two days ago.

Screenshot:

Image

Thanks a lot for your hard work!

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Roland
Posts: 397
Joined: Tue May 02, 2017 7:23 am

Re: Fienix - New PowerPC Distro

Post by Roland »

Is TUN/TAP properly configured in Fienix? When trying to use FreeVPN with OpenVPN, I keep getting these errors (daemon.log):

Jan 20 14:59:39 Fienix nm-openvpn[3670]: write to TUN/TAP : Invalid argument (code=22)

I can currently connect to the FreeVPN server but not to any actual site. (Browser stays in 'loading' when I try). What should be done...?
- Roland -

caseycullen
Posts: 332
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

Roland wrote:Is TUN/TAP properly configured in Fienix? When trying to use FreeVPN with OpenVPN, I keep getting these errors (daemon.log):

Jan 20 14:59:39 Fienix nm-openvpn[3670]: write to TUN/TAP : Invalid argument (code=22)

I can currently connect to the FreeVPN server but not to any actual site. (Browser stays in 'loading' when I try). What should be done...?
The configuration can't be preset; the client config must match the server config. My understanding is that this error most often appears when the server is configured to use LZO data compression. In the Control Center go to Advanced Network Configuration, choose your VPN connection and click the Advanced button, then enable the "Enable LZO data compression" option.
-Casey

User avatar
kilaueabart
Posts: 660
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

Things just aren't working for me. Still couldn't get fienix-customization-layer with Synaptic; something "broken." The last time I tried to Reload, Synaptic griped

Code: Select all

Could not download all repository indexes
The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct."
Tried apt-get update, got this:

Code: Select all

Root@Fienix:/home/fienix# apt-get update
Reading package lists... Done
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/

Code: Select all

root@Fienix:/home/fienix# ls /var/lib/apt/lists
auxfiles
lock
partial
ppcutopia.ddns.net_repos_apt_debian_dists_fienix_InRelease
ppcutopia.ddns.net_repos_apt_debian_dists_fienix_main_binary-powerpc_Packages
ppcutopia.ddns.net_repos_apt_debian_dists_sid_InRelease
ppcutopia.ddns.net_repos_apt_debian_dists_sid_main_binary-powerpc_Packages
I seem to have successfully downloaded the soar .img. I would like to empty out Remix (/dev/sda6) and put soar there for now, but haven't been able to figure out how to do that either. Very discouraging.

caseycullen
Posts: 332
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

kilaueabart wrote:Things just aren't working for me. Still couldn't get fienix-customization-layer with Synaptic; something "broken." The last time I tried to Reload, Synaptic griped

Code: Select all

Could not download all repository indexes
The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct."
Tried apt-get update, got this:

Code: Select all

Root@Fienix:/home/fienix# apt-get update
Reading package lists... Done
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/

Code: Select all

root@Fienix:/home/fienix# ls /var/lib/apt/lists
auxfiles
lock
partial
ppcutopia.ddns.net_repos_apt_debian_dists_fienix_InRelease
ppcutopia.ddns.net_repos_apt_debian_dists_fienix_main_binary-powerpc_Packages
ppcutopia.ddns.net_repos_apt_debian_dists_sid_InRelease
ppcutopia.ddns.net_repos_apt_debian_dists_sid_main_binary-powerpc_Packages
I seem to have successfully downloaded the soar .img. I would like to empty out Remix (/dev/sda6) and put soar there for now, but haven't been able to figure out how to do that either. Very discouraging.
When you tried to "apt-get update" and received the error ending with "(11: Resource temporarily unavailable)", did you also have Synaptic open? If so, you'll need to close it first as you're only allowed to use one apt client at a time.

If you did not also have Synaptic open, please enter the following commands in order as su:

Code: Select all

killall apt apt-get

Code: Select all

rm /var/lib/apt/lists/lock

Code: Select all

rm /var/cache/apt/archives/lock

Code: Select all

rm /var/lib/dpkg/lock

Code: Select all

dpkg --configure -a
Then try "apt-get update" and "apt-get install fienix-customization-layer" again, and let me know the output.
-Casey

User avatar
kilaueabart
Posts: 660
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

caseycullen wrote: If you did not also have Synaptic open, please enter the following commands in order as su:

Code: Select all

killall apt apt-get

Code: Select all

rm /var/lib/apt/lists/lock

Code: Select all

rm /var/cache/apt/archives/lock

Code: Select all

rm /var/lib/dpkg/lock

Code: Select all

dpkg --configure -a
Then try "apt-get update" and "apt-get install fienix-customization-layer" again, and let me know the output.
-Casey
I think you were right about Synaptic being a problem. I tried again today with better(?) results, but still told I could not upgrade, as usual. I decided to try what you suggest above anyway, but sure enough:

Code: Select all

root@Fienix:/home/fienix# apt-get update
Hit:1 http://ppcutopia.ddns.net/repos/apt/debian fienix InRelease
Hit:2 http://ppcutopia.ddns.net/repos/apt/debian sid InRelease
Reading package lists... Done
root@Fienix:/home/fienix# apt-get install fienix-customization-layer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fienix-customization-layer : Depends: gir1.2-nma-1.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

caseycullen
Posts: 332
Joined: Sat Dec 17, 2016 7:12 am
Location: Madison, WI USA
Contact:

Re: Fienix - New PowerPC Distro

Post by caseycullen »

kilaueabart wrote:I think you were right about Synaptic being a problem. I tried again today with better(?) results, but still told I could not upgrade, as usual. I decided to try what you suggest above anyway, but sure enough:

Code: Select all

root@Fienix:/home/fienix# apt-get update
Hit:1 http://ppcutopia.ddns.net/repos/apt/debian fienix InRelease
Hit:2 http://ppcutopia.ddns.net/repos/apt/debian sid InRelease
Reading package lists... Done
root@Fienix:/home/fienix# apt-get install fienix-customization-layer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fienix-customization-layer : Depends: gir1.2-nma-1.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Thanks for helping to troubleshoot. I think I may have fixed it, please try again. If you receive the same warning, please try "apt-get install gir1.2-nma-1.0" and let me know the error.
-Casey

User avatar
kilaueabart
Posts: 660
Joined: Mon Mar 05, 2012 2:36 am

Re: Fienix - New PowerPC Distro

Post by kilaueabart »

caseycullen wrote: Thanks for helping to troubleshoot. I think I may have fixed it, please try again. If you receive the same warning, please try "apt-get install gir1.2-nma-1.0" and let me know the error.
-Casey
That made for an interesting session and some progress. I include the results, much edited (but I saved the whole batch just in case). I'm not sure how I should interpret the next-to-last line, so I quit experimenting.
I think it was very unkind to remove network-manager (1.20.2-1) and then tell me I need it but can't get it.

Code: Select all

root@Fienix:/home/fienix# apt-get update
Hit:1 http://ppcutopia.ddns.net/repos/apt/debian fienix InRelease
Get:2 http://ppcutopia.ddns.net/repos/apt/debian sid InRelease [2,216 B]
Get:3 http://ppcutopia.ddns.net/repos/apt/debian sid/main powerpc Packages [1,976 kB]
...
root@Fienix:/home/fienix# apt-get install fienix-customization-layer
...
Some packages could not be installed. This may mean that ... 
The following packages have unmet dependencies:
 fienix-customization-layer : Depends: gir1.2-nma-1.0 but it is not going to be installed
...
root@Fienix:/home/fienix# apt-get install gir1.2-nma-1.0
...
The following additional packages will be installed:
  gir1.2-nm-1.0 libnm0
The following packages will be REMOVED:
  network-manager network-manager-gnome
The following NEW packages will be installed:
  gir1.2-nm-1.0 gir1.2-nma-1.0
The following packages will be upgraded:
  libnm0
1 upgraded, 2 newly installed, 2 to remove and 6 not upgraded.
...
Get:1 http://ppcutopia.ddns.net/repos/apt/debian sid/main powerpc libnm0 powerpc 1.20.6-1 [433 kB]
Get:2 http://ppcutopia.ddns.net/repos/apt/debian sid/main powerpc gir1.2-nm-1.0 powerpc 1.20.6-1 [95.9 kB]
Get:3 http://ppcutopia.ddns.net/repos/apt/debian sid/main powerpc gir1.2-nma-1.0 powerpc 1.8.24-1 [64.7 kB]
...
removing network-manager (1.20.2-1) ...
...
Setting up libnm0:powerpc (1.20.6-1) ...
Setting up gir1.2-nm-1.0:powerpc (1.20.6-1) ...
Setting up gir1.2-nma-1.0:powerpc (1.8.24-1) ...
...
root@Fienix:/home/fienix# apt-get install fienix-customization-layer
Some packages could not be installed. ...
...
 fienix-customization-layer : Depends: network-manager (>= 1.20) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@Fienix:/home/fienix# apt-get install network-manager
...
Some packages could not be installed. This may mean ...

The following packages have unmet dependencies:
 network-manager : Depends: libnm0 (= 1.20.2-1) but 1.20.6-1 is to be installed
E: Unable to correct problems, you have held broken packages.


Post Reply