Keyboard ignored

AmigaOne X5000 platform specific issues.
Post Reply
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Keyboard ignored

Post by kilaueabart »

I can no longer do anything in Amiga OS4 with my keyboard. I first noticed this about a month ago (sadly, I use linux much more than Amiga these days).

My keyboard is a Logitech K800, one that sends signals to a USB dongle. It still works just as it should on both my linux platforms but Amiga doesn't detect the signal.

Any hints on how and where to look for the problem?
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1438
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Keyboard ignored

Post by tonyw »

I can no longer do anything in Amiga OS4 with my keyboard
That implies that in the past, it worked OK. Is that right?

If so, what have you changed since then? Software doesn't go stale, although some hardware (batteries and things) wear out.

If you were a betatester, you would be asked to backtrack some of your updates until it worked again, then write a report on what caused this malfunction. But I assume that you haven't changed any system software.

Or have you?
cheers
tony
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Keyboard ignored

Post by kilaueabart »

I have changed some Fienix things, and curiously that is near the time I first noticed the Amiga problem. Here is something I forgot to mention. The last two times I booted OS4 this message spread across the top of the screen. Any idea what it means?

Fri Aug 21 01:14:16 2020 [error]: Interface "interface.1" configuration failed with station address = 38:83:45:EE:F9:F3 (10,19, Driver is offline, Unit currently not connected).
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1438
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Keyboard ignored

Post by tonyw »

That message means that the Ethernet driver could not start up. Perhaps you have the cable plugged into a different port? If not, then some configuration has been changed so that the driver can no longer talk to the outside world.
cheers
tony
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Keyboard ignored

Post by kilaueabart »

I wrote this with Pluma in Fienix, where I can type text, to try to send from the browser in OS4, where I
can't.

Re: Kernel 5.8
Edit Report Quote
Post by kilaueabart » Mon Aug 03, 2020 5:05 pm

Skateman wrote: ↑Mon Aug 03, 2020 5:18 am
Can you use the onboard adapter ? Does it function like it should. Internet / Lan etc working as expected ?
Well, when you ask, I'm not sure! I took it for granted that that was what
CODE: SELECT ALL
DEVICE TYPE STATE CONNECTION
eth0 ethernet connected Wired connection 2
enP4096p4s4 ethernet unavailable --

means. I.e., that the enP4096p4s4 was not an "onboard adapter," but eth0 maybe was it.

Whatever I'm using it functions at least as well in fienix and Ubuntu as the enP thing did.
User avatar
kilaueabart
Posts: 744
Joined: Mon Mar 05, 2012 2:36 am

Re: Keyboard ignored

Post by kilaueabart »

Update: The keyboard is now working slightly more often than not. When I boot, I test it with Notepad, "aaa." If that doesn't work I plug an old USB keyboard in and work with that. The next time I boot OS4 the wireless keyboard will probably work. What the heck?
Post Reply