USB flash FAT32 and usb external NTFS drive

AmigaOne X5000 platform specific issues.
User avatar
simulant
Posts: 38
Joined: Sat May 25, 2019 1:28 pm

Re: USB flash FAT32 and usb external NTFS drive

Post by simulant »

nbache wrote:After the popup, can you try hitting Ctrl-Alt-M and see if you get the massstorage GUI up? What does it show, if anything?

Best regards,

Niels
Hi thanks for the suggestion but after it pops up and I hit ctrl alt + m only my hard drive partitions are shown...

usb.log shows this:
I: [21:52:09] hub.usbfd | HUB | Device found on port 4 of hub "".
I: [21:52:09] hub.usbfd | Hub port | Device at port 4 of hub "" is high-speed.
I: [21:52:09] USB stack | New Fkt | Fkt 0x53958a00 at level 4
I: [21:52:09] hub.usbfd | HUB | Device on hub port 4 successfully added.
I: [21:52:09] USB Fkt Init | Init Fkt | Fkt 0x53958a00 is {Vendor: 0x1058, Product: 0x0748, Class: 00.00}
I: [21:52:09] USB Fkt Init | Init Fkt | Fkt 0x53958a00 ("Western Digital","My Passport 0748","575837314336324C36343931") initialized

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1461
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: USB flash FAT32 and usb external NTFS drive

Post by nbache »

That sounds strange. The massstorage GUI should only show disks (massstorage devices) connected over USB. Your hard drive is not on USB, is it?

BTW, I happen to have a WD My Passport Ultra drive myself, but it's not quite the same as yours, mine has a product ID of 0x0820.

But I can't use that under AmigaOS either.

My popup says that the attached device is a multiclass device (or similar), which is probably the reason, I believe those are not supported (yet?).

Does your attachment popup say something similar?

My log goes on to say (after similar lines to yours):

Code: Select all

I: [19:31:10]        MassStorage Device Task |                    Massstorage | Lun 0 has device type 0x00 (Direct access) and is not removable
I: [19:31:10]        MassStorage Device Task |                    Massstorage | Lun 1 has device type 0x0D (Unknown) and is not removable
E: [19:31:10]        MassStorage Device Task |                    Massstorage | Device type ignored
Best regards,

Niels

xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: USB flash FAT32 and usb external NTFS drive

Post by xenic »

nbache wrote:That sounds strange. The massstorage GUI should only show disks (massstorage devices) connected over USB. Your hard drive is not on USB, is it?
The massstorage GUI on the current X5000 is different than all other OS4.x hardware in that respect. The last I heard the p5020sata.device isn't done and the X5000 disk system seems like some sort of a workaround to me.
AmigaOne X1000 with 2GB memory - OS4.1 FE

User avatar
Petrol
Beta Tester
Beta Tester
Posts: 164
Joined: Mon Dec 20, 2010 6:19 pm
Location: France

Re: USB flash FAT32 and usb external NTFS drive

Post by Petrol »

Hi,

It seems that the AmigaOS USB stack or another component can't mount disk partitions over 2TB currently, USB2 or 3 doesn't matter.

For your 1TB disk, if it is empty, try to format it on a OS other than Win10. Some users reports that some of there disks didn't work when they were formated with a win10 machines.

Regards,

User avatar
simulant
Posts: 38
Joined: Sat May 25, 2019 1:28 pm

Re: USB flash FAT32 and usb external NTFS drive

Post by simulant »

Petrol wrote:Hi,

It seems that the AmigaOS USB stack or another component can't mount disk partitions over 2TB currently, USB2 or 3 doesn't matter.

For your 1TB disk, if it is empty, try to format it on a OS other than Win10. Some users reports that some of there disks didn't work when they were formated with a win10 machines.

Regards,
Ah that explains it! I made a mistake with the drive size and on checking it looks like this drive is 3TB not 1TB!

Thanks at least now I know that it *shouldn't* work. Hopefully some bigger drive support will come along in a future update :)

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1461
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: USB flash FAT32 and usb external NTFS drive

Post by nbache »

xenic wrote:
nbache wrote:That sounds strange. The massstorage GUI should only show disks (massstorage devices) connected over USB. Your hard drive is not on USB, is it?
The massstorage GUI on the current X5000 is different than all other OS4.x hardware in that respect. The last I heard the p5020sata.device isn't done and the X5000 disk system seems like some sort of a workaround to me.
Ah, yes, of course. Sorry, I had forgotten that simulant is on an X5000.

Best regards,

Niels

Post Reply