Sam440ep Linux

Linux only discussion for the AmigaOne 500 and Sam series
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:57 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
User avatar
YesCop
Posts: 44
Joined: Tue Oct 25, 2011 11:45 pm
Location: Caen, France

Re: Sam440ep Linux

Post by YesCop »

Hi spectre660.

I need some explanations about installing linux on my sam flex.
I use the ubuntu iso version as you wrote it is better for sam440.
Here is my history.
I booted with the disk. I choose sam flex install and it unziped the kernel and all seemed right, i.e. no error printed.
I noticed the last two addresses were 0x0.
After that, my sam reseted and rebooted and wanted to repeat the pre-installation ever and ever.

I tried to change the bootlever of my disk to ublb2 and repeated the pre installation procedure.
Same thing but when I tried to boot on my AOS4 disk system, Uboot complained it didn't find the ext2 filesystem. I couldn't reboot.
I had to use my old install cd to remove ublb2.
So here are my questions.

On the pdf located in the iso, it is written that slb_v2 can be used (for Debian version).
For Ubuntu too ?
My second question is :
The linux partition must be located on the same disk as the os4 boot disk or no ?

Thanks in advance for your answer.
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:57 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:58 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
User avatar
YesCop
Posts: 44
Joined: Tue Oct 25, 2011 11:45 pm
Location: Caen, France

Re: Sam440ep Linux

Post by YesCop »

Ok, I will download the iso again but befre could you tell me if the linux partition must be in the same hd than os4's one.
Yes, I am using a radeon 9250.
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:58 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
User avatar
YesCop
Posts: 44
Joined: Tue Oct 25, 2011 11:45 pm
Location: Caen, France

Re: Sam440ep Linux

Post by YesCop »

Hello again Spectre660.
Guess what. That didn't work.

I resume what I did.
I changed the fs of my OS4 boot partition to sfs. I used u2lb in my two disks.
Here are my partitions of my first disk.
System (OS4 boot sfs00), work (sfs00, 110 G), Data (SFS02, 200 G), Internet (JXF 150G) and the last Linux (2G, sfs00).
Linux contains the boot directory and the config file.

Here is the second disk.
Data1 (900Go, sfs02), Data2 (900 sfs02, not mounted just here to leave unpartitioned the end of the disk, about 20G).

I made the iso again. And again, it installed the boot image as before (the last two address are null) and reseted the computer.
If I don't remove the cd (or choose to boot on hd), it repeats the same procedure.
It didn't make any ext2 partitions on my second disk. The difference with previous tests is I can boot on oS4 without problem.
The only doubt I have is if the size of my second disk is not a problem (about 2T).
If you have any idea, I take.
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:59 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Spectre660
Posts: 1506
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Sam440ep Linux

Post by Spectre660 »

.
Last edited by Spectre660 on Fri Jan 24, 2014 3:59 pm, edited 1 time in total.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
User avatar
YesCop
Posts: 44
Joined: Tue Oct 25, 2011 11:45 pm
Location: Caen, France

Re: Sam440ep Linux

Post by YesCop »

HI Spectre,
How are you ? Let's begin.
I compared my dvd and the iso. All was identical except the icons for two text files were different. In the cd, the file type was unknown.
So I decided to make a new iso with AmiDVD (I used frying pan). Ok now, the installation is done and no error was displayed.
Now my second disk is :
dh4 (sf02), dh5(sfs02), dhx (LNX00), dhx (Ext03), dhx(SWP00).
But during the boot, I have error message complaining about not mounting the ext2 filesystem.
I tried to change with different numbers the X in sdbX in menu.lst file, whith no success.
Could you confirm what you wrote to me about the menu.lst file on the first disk ?
I also read in the doc that a A1boot file is created (when used with standard bootloader). I haven't this file.
So, do you have any file in the boot partition (sfs00) except menu.list and ulimage ?
Thanks again for your patience.
Last edited by YesCop on Tue Nov 19, 2013 3:02 pm, edited 1 time in total.
Post Reply