Images in Intuition menus

AmigaOS users can make feature requests in this forum.
Post Reply
chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Images in Intuition menus

Post by chris »

I'd like to be able to add custom images in individual Intuition/GadTools menu items.

This should be possible already, but since nobody can tell me how to do it, I'm assuming it's not actually implemented and therefore should be a feature request. (my previous thread with futile attempts to get this to work: http://forum.hyperion-entertainment.biz ... ?f=26&t=94)
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 521
Joined: Sat Jun 18, 2011 3:12 pm
Location: Finland
Contact:

Re: Images in Intuition menus

Post by salass00 »

@chris

I just tried your code on my beta system and as you say it crashes on the LayoutMenus() call. I'll look into this and see if it's something that I can fix.

Edit:
Just found the problem. The bug was in CreateMenus() in the code that's supposed to check if the provided image is a BOOPSI image (non-BOOPSI images are copied to an internal buffer in CreateMenus()). Easy to fix once I saw it.
chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Re: Images in Intuition menus

Post by chris »

salass00 wrote:@chris

I just tried your code on my beta system and as you say it crashes on the LayoutMenus() call. I'll look into this and see if it's something that I can fix.

Edit:
Just found the problem. The bug was in CreateMenus() in the code that's supposed to check if the provided image is a BOOPSI image (non-BOOPSI images are copied to an internal buffer in CreateMenus()). Easy to fix once I saw it.
Thank you! This thread can be closed since it was actually a real bug.
Post Reply