How to solve the login loop issue?

AmigaOne X1000 platform specific issues related to Linux only.
Post Reply
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 485
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

How to solve the login loop issue?

Post by Hypex »

So. After the reminders I decided to upgrade my Ubuntu 12.04 to 14.04. It gave me a warning about graphics since by then I would have replaced my 5450 with an R7 250 by then. So I cloned it first to test to avoid breaking my present install.

And break it did. I never did get it back into a working state. But a few days ago I did I migrated from a black screen to a log in screen. After installing linux-firmware-nonfree. I thought I had fixed it. But all I had done is gone from low graphics warning and black login to a working login and no desktop.

What happens is I log in and then it disappears and takes me back to the log in screen again! I've only seen this on Debian where I had no disk space left. But here I have 10GB with 15% free so it certainly has space. Is this a known PPC Linux thing? I think we need to collect all the info needed to fix a broken upgraded system.
User avatar
xeno74
Posts: 7167
Joined: Fri Mar 23, 2012 7:58 am

Re: How to solve the login loop issue?

Post by xeno74 »

Hypex wrote: Fri Jun 11, 2021 3:28 pm What happens is I log in and then it disappears and takes me back to the log in screen again! I've only seen this on Debian where I had no disk space left. But here I have 10GB with 15% free so it certainly has space. Is this a known PPC Linux thing? I think we need to collect all the info needed to fix a broken upgraded system.
Maybe you find a hint in the following thread.

Link: Lubuntu 14.04
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 485
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: How to solve the login loop issue?

Post by Hypex »

xeno74 wrote: Fri Jun 11, 2021 4:59 pm Maybe you find a hint in the following thread.
Thanks. I've read through it but nothing stands out. Apart from the render acceleration I can test off.

Also, I've managed to break my Ubuntu 12.04 now. Right now it too is going into a login loop for some reason, loading up a guest session, then returning back when I log in. I tested 5.13, 5.12, reverted to 5.11 and now it's broken. I also tried 5.2 and it won't work any more as above. I don't know what's happened to it but it's as if 5.12 did some damage. :-?
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 485
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: How to solve the login loop issue?

Post by Hypex »

Okay I solved it. It was the .Xauthority file. It must have got ruined when Xorg failed to start on the later kernel. It was tied to root. Had to reset it to my account.

I knew it had to be something simple. Since I could still log in as guest. And the desktop was fine. Which was bizarre since I had auto log in. So it shouldn't have even asked me to log in.

I looked it up online.
Post Reply