Fienix - New PowerPC Distro

AmigaOne X1000 platform specific issues related to Linux only.
Post Reply
User avatar
musa
Posts: 481
Joined: Tue Aug 23, 2011 7:58 pm

Re: Fienix - New PowerPC Distro

Post by musa »

musa wrote:
xeno74 wrote:
musa wrote: ps Do you know anything about the possibility of Gimp coming to fienix
Here you are: Fienix X5000 thread

— Christian
Thanks Christian
Hi Christian
Gimp 2.8..16-fienix is there now but libjasper libpng12 and libgegl is missing and gimp fail to install.
Package libjasper1 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

libpng12
Package libpng12-0 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

libgegl
libgegl-0.2-0:
Package libgegl-0.2-0 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

have you try install Gimp?
Peter
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
xeno74
Posts: 6839
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

Hi Peter,

Thanks a lot for reporting the Gimp package dependencies issue. :-)

I informed Casey about the Gimp package dependencies issue today and here is the answer:
caseycullen wrote:Thanks, I’m aware - I don’t have all of the dependencies packaged yet. Hopefully tomorrow.
Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
musa
Posts: 481
Joined: Tue Aug 23, 2011 7:58 pm

Re: Fienix - New PowerPC Distro

Post by musa »

xeno74 wrote:Hi Peter,

Thanks a lot for reporting the Gimp package dependencies issue. :-)

I informed Casey about the Gimp package dependencies issue today and here is the answer:
caseycullen wrote:Thanks, I’m aware - I don’t have all of the dependencies packaged yet. Hopefully tomorrow.
Cheers,
Christian
Thanks Cristian
I think Casey has done a fantastic job with Fienix.
Cheers
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
sundown
Beta Tester
Beta Tester
Posts: 465
Joined: Mon Dec 20, 2010 10:38 pm
Location: California, USA

Re: Fienix - New PowerPC Distro

Post by sundown »

I bought the new Fienix usb stick hoping it would make for an easy install, but not to be.
I get a "usbdisk0:zImage-4.20 "file not found" error.
root=/dev/usbdrive, should 'usbdrive' be something else?
Also the install instructions say the stick should be in the top left usb port, but then I would have no keyboard so using another port.
I also see instructions to put the kernel on a CF card & may need the uncompressed kernel. would I just need the one vmlinux file?
I do have a live CD that boots from a CF card now, but no 3d & I want to support this new version.

Please, if you give me answers, just remember I'm still a linux dummy.
X1000 - Antec Solo case, 4GB DDR2 mem, XFX R9 270 gfx card, Plextor DVD, 2 Samsung 1TB F3 HDD, RTL-8139 network card, Cooler Master Silent Pro 600W PSU
User avatar
xeno74
Posts: 6839
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

Hi Sundown,
sundown wrote:I bought the new Fienix usb stick hoping it would make for an easy install, but not to be.
I get a "usbdisk0:zImage-4.20 "file not found" error.
I also odered the Fienix USB stick four days ago. I haven't received it yet. I think there are two partitions on this USB stick so "usbdisk0:zImage-4.20" can't work. Please try usbdisk0.0:zImage-4.20. I think the first partition has a FAT file system so you need -fatfs in your CFE command. I will modify the USB device to usbdisk0.0 in the installation instructions.
sundown wrote: root=/dev/usbdrive, should 'usbdrive' be something else?
Please try the following commands if you have one hard disk installed in your X1000.

Code: Select all

setenv bootargs "root=/dev/sdb2 rootdelay=5"

Code: Select all

boot -elf -noints -z -fatfs usbdisk0.0:zImage-4.20
Please try the following commands if you have two hard disks installed in your X1000.

Code: Select all

setenv bootargs "root=/dev/sdc2 rootdelay=5"

Code: Select all

boot -elf -noints -z -fatfs usbdisk0.0:zImage-4.20
sundown wrote: Also the install instructions say the stick should be in the top left usb port, but then I would have no keyboard so using another port.
To recognise a USB stick into a different USB-port, you always have to insert the USB device AFTER entering the CFE console.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
sundown
Beta Tester
Beta Tester
Posts: 465
Joined: Mon Dec 20, 2010 10:38 pm
Location: California, USA

Re: Fienix - New PowerPC Distro

Post by sundown »

usbdisk0.0 doesn't work, all the examples I see just have usbdisk0:
There are 2 partitions on the usb drive, fienix-boot which is fat formatted & FIENIX which is ext2.
Maybe another x1000 user that got a usb disk to boot can post his CFE command.
X1000 - Antec Solo case, 4GB DDR2 mem, XFX R9 270 gfx card, Plextor DVD, 2 Samsung 1TB F3 HDD, RTL-8139 network card, Cooler Master Silent Pro 600W PSU
User avatar
musa
Posts: 481
Joined: Tue Aug 23, 2011 7:58 pm

Re: Fienix - New PowerPC Distro

Post by musa »

sundown wrote:usbdisk0.0 doesn't work, all the examples I see just have usbdisk0:
There are 2 partitions on the usb drive, fienix-boot which is fat formatted & FIENIX which is ext2.
Maybe another x1000 user that got a usb disk to boot can post his CFE command.

Hi My boot commands for my usb disk with 2 partisions (fat32 and ext4) are as follows.
setenv bootargs "root =/dev/sde2" (remember " ")
boot -elf -noints -z -fatfs usbdisk0: zimage-4.20

I have three hard drives sdb, sdc, sdb therefore my usbdisk will be called sde. Part 2 is then called sde2.
I boot to CFE write the first line and pres enter
inset usbdisk in the first usbbay in the top of the tower. (from the left)
write the second line and pres enter
boot into Fienix

Musa
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
xeno74
Posts: 6839
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

sundown wrote:usbdisk0.0 doesn't work, all the examples I see just have usbdisk0:
There are 2 partitions on the usb drive, fienix-boot which is fat formatted & FIENIX which is ext2.
Maybe another x1000 user that got a usb disk to boot can post his CFE command.
I haven't received the Fienix USB stick from AOTL yet. When I received it then I will test it and report the results. Maybe I can help you better after testing the USB stick.

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6839
Joined: Fri Mar 23, 2012 7:58 am

Re: Fienix - New PowerPC Distro

Post by xeno74 »

sundown wrote:usbdisk0.0 doesn't work, all the examples I see just have usbdisk0:
There are 2 partitions on the usb drive, fienix-boot which is fat formatted & FIENIX which is ext2.
Maybe another x1000 user that got a usb disk to boot can post his CFE command.
Please copy the new uncompressed kernel 4.20.17 (vmlinux-4.20) to the fienix-boot partition and boot it with the following commands:

Code: Select all

setenv bootargs "root=/dev/sdb2 rootdelay=5"

Code: Select all

boot -elf -noints -fatfs usbdisk0:vmlinux-4.20
How many hard disks are installed in your X1000?

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
sundown
Beta Tester
Beta Tester
Posts: 465
Joined: Mon Dec 20, 2010 10:38 pm
Location: California, USA

Re: Fienix - New PowerPC Distro

Post by sundown »

[quote="musa"]

Hi My boot commands for my usb disk with 2 partisions (fat32 and ext4) are as follows.
setenv bootargs "root =/dev/sde2" (remember " ")
boot -elf -noints -z -fatfs usbdisk0: zimage-4.20

I have three hard drives sdb, sdc, sdb therefore my usbdisk will be called sde. Part 2 is then called sde2.
I boot to CFE write the first line and pres enter
inset usbdisk in the first usbbay in the top of the tower. (from the left)
write the second line and pres enter
boot into Fienix

So the usb disk will only boot from the top left usb port. so how are you getting the keyboard to work to use linux?

I have 2 front usb ports that work with usb sticks & had a feeling that was the problem, may need to buy a cheap hub.
When the x1000 first started beta testing, some of the back usb ports didn't work, Steven got them working so I will
check them all to see if there is another "magic" port, never know :-)
X1000 - Antec Solo case, 4GB DDR2 mem, XFX R9 270 gfx card, Plextor DVD, 2 Samsung 1TB F3 HDD, RTL-8139 network card, Cooler Master Silent Pro 600W PSU
Post Reply