Kernel 4.16

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
tbreeden
Posts: 160
Joined: Sat Jun 18, 2011 12:57 am
Location: Charlottesville, VA, USA
Contact:

Re: Kernel 4.16

Post by tbreeden »

Tom,

Could you also test the alpha11?
Ok. I get the same failure to boot with
4.16-alphas 8, 9, 10, and 11.
This happens whether I include the
pci=pcie_scan_all parameter or not.

I double checked to see that the
parameter was actually getting from
CFE to vmlinux.
File /proc/cmdline does show it ok.

4.16-alpha7 does still boot ok
whether the parameter is there or not.

tom

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

tbreeden wrote: Ok. I get the same failure to boot with
4.16-alphas 8, 9, 10, and 11.
This happens whether I include the
pci=pcie_scan_all parameter or not.

I double checked to see that the
parameter was actually getting from
CFE to vmlinux.
File /proc/cmdline does show it ok.

4.16-alpha7 does still boot ok
whether the parameter is there or not.

tom
Hi Tom,

Many thanks for testing all the alphas! Unfortunately I haven’t found the issue yet.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

Hi Tom,

Could you also please test the first update of the stable kernel 4.15 on your X1000? Maybe my cross compiling environment is the problem.

Download: vmlinux-4.15.1-AmigaOne_X1000_X5000.tar.gz

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
tbreeden
Posts: 160
Joined: Sat Jun 18, 2011 12:57 am
Location: Charlottesville, VA, USA
Contact:

Re: Kernel 4.16

Post by tbreeden »

Could you also please test the first update of the stable kernel 4.15 on your X1000? Maybe my cross compiling environment is the problem.
4.15.1 boots and runs fine here.
Screenshot from 2018-02-11 11-33-11.png
tom

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

tbreeden wrote: 4.15.1 boots and runs fine here.

tom
Hi Tom,

Thank you! Good to know that my cross compiling environment is OK. I have compiled the alpha12 for testing.

New:
Download: vmlinux-4.16-alpha12-AmigaOne_X1000_X5000.tar.gz

Could you please test it?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
tbreeden
Posts: 160
Joined: Sat Jun 18, 2011 12:57 am
Location: Charlottesville, VA, USA
Contact:

Re: Kernel 4.16

Post by tbreeden »

Hi Christian,
Good to know that my cross compiling environment is OK. I have compiled the alpha12 for testing.
That did it! 4.16-alpha12 boots and runs well.

many thanks,

tom

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

tbreeden wrote:Hi Christian,
That did it! 4.16-alpha12 boots and runs well.

many thanks,

tom
Fantastic! Great news! Many thanks for testing!
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5904
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.16

Post by xeno74 »

Hi All,

I compiled the RC1-2 for the X5000 and X1000 yesterday.

New:
Download: vmlinux-4.16-rc1-2-AmigaOne_X1000_X5000.tar.gz

@Tom
Could you please test the RC1 and RC1-2 on your X1000?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
tbreeden
Posts: 160
Joined: Sat Jun 18, 2011 12:57 am
Location: Charlottesville, VA, USA
Contact:

Re: Kernel 4.16

Post by tbreeden »

Hi Christian,
Download: vmlinux-4.16-rc1-2-AmigaOne_X1000_X5000.tar.gz
@Tom
Could you please test the RC1 and RC1-2 on your X1000?
Both of these seem to be working very well on my X1000.

tom

Post Reply