Kernel 4.9

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

TearsOfMe wrote:Booting with alpha7 works here.
Dont test more while with Si card its pain slow.
Thanks a lot for testing! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

Hi All,

Here is the first release candidate. :-)

New:
Download: vmlinux-4.9-rc1-AmigaONE_X1000.tar.gz

Please please please test it if it boots.

Thanks in advance,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

Could someone please test the first release candidate? I'd like to know if you can see the boot messages.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.9

Post by Srtest »

I don't know how to say it one more time: no kernel works for me since 4.7. That darren patch that fixed things for all of you NI guys didn't do so for me with a R9-270 GCN 1.0. It goes to a very early boot stage when it says - "boots something something ........" and then nothing. It is similiar to the way the microcode didn't work a few kernels back until it was reverted.

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

Srtest wrote:I don't know how to say it one more time: no kernel works for me since 4.7. That darren patch that fixed things for all of you NI guys didn't do so for me with a R9-270 GCN 1.0. It goes to a very early boot stage when it says - "boots something something ........" and then nothing. It is similiar to the way the microcode didn't work a few kernels back until it was reverted.
Hi Srtest,

Sorry that you have to say it one more time. :-( I will forward it to Darren.

Could you please test the stable kernel 4.7.8?

I'd like to know if it boots. If it boots then something is missing in Darren's patch.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

Hi Srtest,

Maybe Darren's patch isn't the problem. Maybe the following patch:

powerpc/pci: Only do fixed PHB numbering on powernv

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

daz
Beta Tester
Beta Tester
Posts: 318
Joined: Tue Dec 21, 2010 7:32 pm

Re: Kernel 4.9

Post by daz »

Srtest wrote:I don't know how to say it one more time: no kernel works for me since 4.7. That darren patch that fixed things for all of you NI guys didn't do so for me with a R9-270 GCN 1.0. It goes to a very early boot stage when it says - "boots something something ........" and then nothing. It is similiar to the way the microcode didn't work a few kernels back until it was reverted.
That report doesn't really tell us very much. Is there any chance you can hook you system up to serial terminal and catch the boot log for us? I'm writing this from my X1000, fitted with my HD7750 - and I booted Christians alpha 5 (this was all I had handy) - The boot procceded just as all others do. There is something funny going on with your system and we need more information to find out what.

Perhaps you could post your specs here so we can try and re-create the problem.

Regards
Darren

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.9

Post by Srtest »

daz wrote:
Srtest wrote:I don't know how to say it one more time: no kernel works for me since 4.7. That darren patch that fixed things for all of you NI guys didn't do so for me with a R9-270 GCN 1.0. It goes to a very early boot stage when it says - "boots something something ........" and then nothing. It is similiar to the way the microcode didn't work a few kernels back until it was reverted.
That report doesn't really tell us very much. Is there any chance you can hook you system up to serial terminal and catch the boot log for us? I'm writing this from my X1000, fitted with my HD7750 - and I booted Christians alpha 5 (this was all I had handy) - The boot procceded just as all others do. There is something funny going on with your system and we need more information to find out what.

Perhaps you could post your specs here so we can try and re-create the problem.

Regards
Darren
The only differences between a standard X1000 and mine are graphics and sound: Radeon R9-270 (some generic manufacturer which works very well on different computers) and an ESI Juli@ for sound which also works great (except a driver issue sometimes on AOS4.1FE). I boot from a CF card and tested both cf and usb - with ext2 and fat. 4.7.8 works, 4.8 + 4.9 doesn't. Everything else is what I got from Amigakit.

I'm adding a pic of the failed boot and log of a good boot.
Attachments
20161021_004709.jpg
goodboot4.7.8.zip
(15.66 KiB) Downloaded 172 times

User avatar
xeno74
Posts: 5947
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.9

Post by xeno74 »

I had a similar problem with the alpha2 of kernel 4.8 few months ago.
xeno74 wrote:Hi All,

I reverted the following patch:

- pasemi: Remove IOBMAP allocation from platform probe()

After that I compiled the kernel again. Unfortunately the kernel doesn't boot.

The last message from CFE:

Code: Select all

Booting Linux via __start()...
Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply