ubuntu MATE 16.04.1 Live DVD

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
AlfredOne
Beta Tester
Beta Tester
Posts: 126
Joined: Wed Dec 22, 2010 11:45 pm
Location: Terlizzi (BA) , Italy
Contact:

Re: ubuntu MATE 16.04.1 Live DVD

Post by AlfredOne »

xeno74 wrote:
AlfredOne wrote: I tried both cases: with using OS4.1 before and without using OS4.1 before. Same behaviour.

I think it's a problem with my DVD sata drive and Nemo board.
I copied the "powerpc64" directory from live DVD to the CompactFlash and booted successfully from there.
So it seems that Linux and OS4.1 can read from DVD but initrd and vmlinux can not be loaded easily.
Hi AlfredOne,

Good to know. Many thanks for testing!

Have a lot of fun with the live DVD. Would you like to install it?

Cheers,
Christian
Installed with the alternative script on HD.
Booted from HD.
Well done!
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

AlfredOne wrote: Installed with the alternative script on HD.
Booted from HD.
Well done!
Hi AlfredOne,

Fantastic! Well done! :-) Which graphics card is installed in your AmigaOne X1000? Radeon R9-280X 3GB or Radeon HIS4670 or even both?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

Srtest wrote:Had to give up on the installation. It started okay (or so I thought) and then it became extremely slow when it reached the Libreoffice files. It seemed to go on forever so I had to stop it.
Hi Srtest,

Sorry for the late answer. Maybe you typed the incorrect partition device or you typed it in a wrong format in the installer.

The correct format is: /dev/<your partition>

For example: /dev/sdb2

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: ubuntu MATE 16.04.1 Live DVD

Post by Srtest »

xeno74 wrote:
Srtest wrote:Had to give up on the installation. It started okay (or so I thought) and then it became extremely slow when it reached the Libreoffice files. It seemed to go on forever so I had to stop it.
Hi Srtest,

Sorry for the late answer. Maybe you typed the incorrect partition device or you typed it in a wrong format in the installer.

The correct format is: /dev/<your partition>

For example: /dev/sdb2

Cheers,
Christian
That is what I did. It started okay and then started to have difficulties copying or maybe setting-up files when the installation arrived to the Libreoffice files. After I rebooted I saw it had managed to copy quite a lot before I stopped it, yet installing an os for hours and hours occupying the X1k is unacceptable for me.
User avatar
AlfredOne
Beta Tester
Beta Tester
Posts: 126
Joined: Wed Dec 22, 2010 11:45 pm
Location: Terlizzi (BA) , Italy
Contact:

Re: ubuntu MATE 16.04.1 Live DVD

Post by AlfredOne »

xeno74 wrote:
AlfredOne wrote: Installed with the alternative script on HD.
Booted from HD.
Well done!
Hi AlfredOne,

Fantastic! Well done! :-) Which graphics card is installed in your AmigaOne X1000? Radeon R9-280X 3GB or Radeon HIS4670 or even both?

Thanks,
Christian
Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

AlfredOne wrote: Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.
Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

Please note: We use the fbdev video driver so it works with SI graphics cards too. If you have a NI graphics card and you want enable hardware 3D acceleration, please replace the fbdev video driver with the radeon driver in the xorg.conf.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

xeno74 wrote:
AlfredOne wrote: Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.
Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian
AlfredOne,

You need a xorg.conf for two graphics cards. Please create one with:
  1. Code: Select all

    Ctrl + Alt + F1
  2. Code: Select all

    sudo service lightdm stop
  3. Code: Select all

    sudo Xorg -configure
Please post this xorg.conf.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
AlfredOne
Beta Tester
Beta Tester
Posts: 126
Joined: Wed Dec 22, 2010 11:45 pm
Location: Terlizzi (BA) , Italy
Contact:

Re: ubuntu MATE 16.04.1 Live DVD

Post by AlfredOne »

xeno74 wrote:
xeno74 wrote:
AlfredOne wrote: Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.
Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian
AlfredOne,

You need a xorg.conf for two graphics cards. Please create one with:
  1. Code: Select all

    Ctrl + Alt + F1
  2. Code: Select all

    sudo service lightdm stop
  3. Code: Select all

    sudo Xorg -configure
Please post this xorg.conf.

Thanks,
Christian
The command failed and generated the attached log file:
Xorg.0.log.tar.gz
"Xorg -configure" log file
(3.91 KiB) Downloaded 148 times
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
xeno74
Posts: 6330
Joined: Fri Mar 23, 2012 7:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Post by xeno74 »

AlfredOne wrote: Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.

The command failed and generated the attached log file:
Xorg.0.log.tar.gz
Hi AlfredOne,

Thank you for posting the Xorg.0.log. Could you please post the output of the command lspci -vv?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
Post Reply