Broken Cluster Geometry -- CF CARD?

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
Posts: 694
Joined: Mon Mar 05, 2012 2:36 am

Re: Broken Cluster Geometry -- CF CARD?

Post by kilaueabart »

xeno74 wrote:Hi Bart,

I am sorry I have forgotten to tell you that you have to create partitions on the CF card if the CF card is bigger than 2GB.

I think OS4.1 only supports FAT16 partitions <= 2GB. I use a 256MB CF card in my X1000.
Aargh! I reformatted CF CARD yesterday, but forgot what you said about the maximum size, as I was following instructions right off page 10 of Installing Ubuntu 12.04 LTS on the AmigaONE X1000:
Note: the maximum size of a FAT16 partition is 4GB or 4095MB
Naturally that erroneous instruction left me with a 640x480 screen in Amiga! I wonder why no one ever caught it?

OK, here I go again! GParted coming up.

Worse yet! Ubuntu 16.04 had been working just fine with the kernels in a less-than 4GB FAT16 partition, but AmigaOS4.1FE, which shouldn't have anything to do with the CF CARD, wouldn't display right. So I reformatted the CF CARD to what GParted said was just under 2GB, but I could not mount it from Desktop. Looked at it with menu item "Disks," and that said I was just over 2GB. So again I reformatted, smaller, and opened the partition and copied three kernels back in. (Oddly enough, I had opened it with no trouble when the whole card was formatted, nearly 4GB!)

Back to OS4, and with a little effort I was able to get it to open properly. But there were things I needed to do in Ubuntu, so I rebooted, with this result:

Code: Select all

Loader:elf Filesys:fat Dev:cf0 File:vmlinux-4.1 Options:(null)
Loadiing: Failed
Could not load cf0:vmlinux-4.1: File system not recognized
I don't know whether the file system of the kernel wasn't recognized, or the file system of the card, Hoping to fine a clue, I continued with

Code: Select all

dir cf0:
Could not get directory listing: Unsupported function
*** command status = -19
Well, OS4 C:list has no trouble:

Code: Select all

Directory "CF CARD:" on Sunday 04-Sep-16
vmlinux-4.1                24657192 ----rwed 23-Aug-16 08:55:40
4.1.31_A-EON_AmigaONE_X1000_Nemo        Dir ---arwed Yesterday 01:56:00
vmlinux-4.8                30528400 ----rwed Monday    06:37:58
vmlinux-4.8-rc4-AmigaONE_X1000        Dir ---arwed Monday    06:58:44
vmlinux-4.7                30633616 ----rwed 08-Aug-16 12:16:24
4.7.0-rc5_A-EON_AmigaONE_X1000_Nemo        Dir ---arwed 27-Jun-16 08:48:48
3 files - 81M bytes - 3 directories - 167812 blocks used
Next I booted ubuntu 12.04 from the old installation disk, where I am easily able to open CF CARD on the desktop, and it agrees that the files listed above are on the card. And GParted still says CF CARD is a 2GB- partition in FAT16 with a tiny portion of it in use.
So what in the world could be wrong now? I NEED to use Scribus and some scribus documents on my Ubuntu 16.04 install tomorrow morning. I wonder whether I will be able to figure out how to do that from my 12.04 DVD?

User avatar
Posts: 173
Joined: Thu Jun 23, 2011 2:19 pm
Location: Belgrade Country:Serbia

Re: Broken Cluster Geometry -- CF CARD?

Post by vox »

kilaueabart wrote:
xeno74 wrote:Hi Bart,
I am sorry I have forgotten to tell you that you have to create partitions on the CF card if the CF card is bigger than 2GB.
With OS 4.1FE this nightmare started:

I have also upgraded from 128MB to 4GB CF card, sticking to official FAT16 limit (as CFE will never get updated to read FAT32 or NTFS, EXT4).
Hope was to use it as Amigaboot.of space to free that strange BDH0:, to have space for several kernels and as well to use it as inter-exchange storage
between Linux and AmigaOS 4 (amigaboot.of can boot from CF card and read KS file from hdd, no real need for BHD0: - I wonder why it wasnt part
of official solution)

After some time, sooner or later, simply CFE would be unable to read it, remarking as you sad that its unable to read it, with same, perfect -fatfs switch.
It seems to me it happens always if you format it from Amiga MediaToolbox - AmigaOS sees it, Linux too if you get to boot it, CFE doesnt.
So some people are right AmigaOS has good FAT16 support - it seems CFE doesnt.

If one does it from Gparted, AmigaOS gets wicked and often reports bad cluster geometry and card as unreadable. Worse, it causes Workbench not to initialize

Now I have read sub 2GB partitions are the solution - ... ry-cf-card

Other way around might be using EXT2 for full 4GB card, but that would require change of both amigaboot.of (boot from CF card) menu option and ubuntu one,
replacing -fatfs switch with -ext2

Again, no comfortable way to do it, but typing the full lines again from CFE.

x1000 is nicely built machines, but some CFE oddities are not well documented and can cause probs.

As an example, I have tried to upgrade to 8GB for filling the machine and making Ubuntu more usable.
CFE failed to register and test memory, wouldnt even boot to Linux without removal of memory.

Later on I have learned on forums that memsizelimit line needs to be set. And memory I have tried could be fully working otherwize.

Such CFE oddities should be noted and our CFE manual updated. Best, at least some small app to change CFE settings from AmigaOS or Linux on more
intuitive way would be best. Now I see just why it was used just for routers, where UBoot surpasses its abilities by far.

Or it may be other way around - I am not sure anymore

Post Reply